mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/pari to 2.13.2-1
This commit is contained in:
parent
132f04f9c5
commit
48944007e4
2 changed files with 8 additions and 30 deletions
|
@ -6,8 +6,8 @@
|
|||
# - generalize cd Olinux-* for install-bin-sta
|
||||
|
||||
pkgname=pari
|
||||
pkgver=2.13.1
|
||||
pkgrel=2
|
||||
pkgver=2.13.2
|
||||
pkgrel=1
|
||||
pkgdesc='Computer algebra system designed for fast computations in number theory'
|
||||
url='https://pari.math.u-bordeaux.fr/'
|
||||
license=(GPL)
|
||||
|
@ -19,17 +19,14 @@ optdepends=('perl: gphelp, tex2mail'
|
|||
'pari-galdata: to compute Galois groups in degrees 8 through 11'
|
||||
'pari-seadata: needed by ellap for large primes'
|
||||
'pari-galpol: GALPOL database of polynomials defining Galois extensions of the rationals')
|
||||
source=("https://pari.math.u-bordeaux.fr/pub/pari/unix/$pkgname-$pkgver.tar.gz"{,.asc}
|
||||
pari-rnfdisc.patch)
|
||||
sha256sums=('81ecf7d70ccdaae230165cff627c9ce2ec297b8f22f9f40742279d85f86dfcb1'
|
||||
'SKIP'
|
||||
'4ddd27fa348d5c00b9a668c1122461488ad719ad31a397ed9b49fb14f6599d94')
|
||||
checkdepends=(pari-elldata pari-galdata pari-seadata pari-galpol)
|
||||
source=(https://pari.math.u-bordeaux.fr/pub/pari/unix/$pkgname-$pkgver.tar.gz{,.asc})
|
||||
sha256sums=('1679985094a0b723d14f49aa891dbe5ec967aa4040050a2c50bd764ddb3eba24'
|
||||
'SKIP')
|
||||
validpgpkeys=('42028EA404A2E9D80AC453148F0E7C2B4522E387')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver
|
||||
|
||||
patch -p1 < ../pari-rnfdisc.patch # https://pari.math.u-bordeaux.fr/cgi-bin/bugreport.cgi?bug=2284
|
||||
sed -e 's|DLLDFLAGS = \$DLLDFLAGS|DLLDFLAGS = $DLLDFLAGS $LDFLAGS|' -i config/Makefile.SH # Honor system LDFLAGS
|
||||
}
|
||||
|
||||
|
@ -52,7 +49,7 @@ build() {
|
|||
|
||||
check() {
|
||||
cd $pkgname-$pkgver
|
||||
make bench
|
||||
make test-all
|
||||
}
|
||||
|
||||
package() {
|
||||
|
|
|
@ -1,19 +0,0 @@
|
|||
From 3edb98db78dd49bb8b4137b46781a7cd570c2556 Mon Sep 17 00:00:00 2001
|
||||
From: Bill Allombert <Bill.Allombert@math.u-bordeaux.fr>
|
||||
Date: Sun, 28 Mar 2021 13:27:24 +0200
|
||||
Subject: [PATCH] rnfdisc_factored: remove spurious Q_primpart [#2284]
|
||||
|
||||
diff --git a/src/basemath/base2.c b/src/basemath/base2.c
|
||||
index b2b63ada5..531f5c558 100644
|
||||
--- a/src/basemath/base2.c
|
||||
+++ b/src/basemath/base2.c
|
||||
@@ -3582,7 +3582,7 @@ rnfdisc_factored(GEN nf, GEN pol, GEN *pd)
|
||||
|
||||
nf = checknf(nf);
|
||||
pol = rnfdisc_get_T(nf, pol, &lim);
|
||||
- disc = nf_to_scalar_or_basis(nf, nfX_disc(nf, Q_primpart(pol)));
|
||||
+ disc = nf_to_scalar_or_basis(nf, nfX_disc(nf, pol));
|
||||
pol = nfX_to_monic(nf, pol, NULL);
|
||||
fa = idealfactor_partial(nf, disc, lim);
|
||||
P = gel(fa,1); l = lg(P);
|
||||
|
Loading…
Reference in a new issue