core/linux-armv7 to 4.20.2-2

This commit is contained in:
Kevin Mihelich 2019-01-18 03:26:39 +00:00
parent fbe4c678dd
commit 4896008b0f
10 changed files with 75 additions and 34 deletions

View file

@ -1,7 +1,7 @@
From 87f9d8f819d91c53e805731e414dda1e4df4d647 Mon Sep 17 00:00:00 2001
From b0383806e04f3ec9bb8c54e1ff142b03fc16ef3c Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:59:28 +0100
Subject: [PATCH 1/8] ARM: atags: add support for Marvell's u-boot
Subject: [PATCH 1/9] ARM: atags: add support for Marvell's u-boot
Marvell uses a specific atag in its u-boot which includes among other
information the MAC addresses for up to 4 network interfaces.
@ -47,5 +47,5 @@ index 6b335a9ff8c8..614150b53643 100644
};
--
2.19.0
2.19.2

View file

@ -1,7 +1,7 @@
From 222f535102a5991c3b66c8399c0f55edc2550a71 Mon Sep 17 00:00:00 2001
From 79a223586f088505b766e86b5762fb3399ab6f76 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@xxxxxx>
Date: Sun, 2 Dec 2012 19:56:58 +0100
Subject: [PATCH 2/8] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
Subject: [PATCH 2/9] ARM: atags/fdt: retrieve MAC addresses from Marvell boot
loader
The atags are parsed and if a Marvell atag is found, up to 4 MAC
@ -43,5 +43,5 @@ index 41fa7316c52b..807ed160a4b9 100644
}
--
2.19.0
2.19.2

View file

@ -1,7 +1,7 @@
From ac901e5dc70f393fb646b64f3968d27a2c71214e Mon Sep 17 00:00:00 2001
From f1ec970d7f0ae471a18f23ce33ab00619f198d19 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:41:19 -0600
Subject: [PATCH 3/8] SMILE Plug device tree file
Subject: [PATCH 3/9] SMILE Plug device tree file
This adds a dts file for the SMILE Plug, which only differs from the Mirabox
dts with the LED definitions.
@ -205,5 +205,5 @@ index 000000000000..d01308ab848b
+ };
+};
--
2.19.0
2.19.2

View file

@ -1,7 +1,7 @@
From 9f825fec8b1e366c27d759011835d7583fa36600 Mon Sep 17 00:00:00 2001
From 659ffdc3f28c87dc54d3ee4d4d597f07ea4f0221 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 5 Sep 2014 15:43:56 -0600
Subject: [PATCH 4/8] fix mvsdio eMMC timing
Subject: [PATCH 4/9] fix mvsdio eMMC timing
These changes from Globalscale change the MMC timing to allow the eMMC versions
of the Mirabox and SMILE Plug to work.
@ -34,5 +34,5 @@ index e22bbff89c8d..6b30c850ce07 100644
host->clock = ios->clock;
host->ns_per_clk = 1000000000 / (host->base_clock / (m+1));
--
2.19.0
2.19.2

View file

@ -1,14 +1,14 @@
From 3c01b2e173ec9bcfe828e1e860f2a653918bcbff Mon Sep 17 00:00:00 2001
From 76b41625a2f0bd09ad91f30bc785d238f444b178 Mon Sep 17 00:00:00 2001
From: popcornmix <popcornmix@gmail.com>
Date: Tue, 18 Feb 2014 01:43:50 -0300
Subject: [PATCH 5/8] net/smsc95xx: Allow mac address to be set as a parameter
Subject: [PATCH 5/9] net/smsc95xx: Allow mac address to be set as a parameter
---
drivers/net/usb/smsc95xx.c | 56 ++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)
diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
index 262e7a3c23cb..c2b3c5b6e1f3 100644
index f2d01cb6f958..6a39efed33ea 100644
--- a/drivers/net/usb/smsc95xx.c
+++ b/drivers/net/usb/smsc95xx.c
@@ -60,6 +60,7 @@
@ -91,5 +91,5 @@ index 262e7a3c23cb..c2b3c5b6e1f3 100644
/* maybe the boot loader passed the MAC address in devicetree */
--
2.19.0
2.19.2

View file

@ -1,7 +1,7 @@
From 82bd3fc447c442bae2f082ac1fe765089ce3e312 Mon Sep 17 00:00:00 2001
From 227f68f9dcb5f1c50121d7fa5ba49f0715522d18 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 Feb 2015 12:32:27 +0100
Subject: [PATCH 6/8] set default cubietruck led triggers
Subject: [PATCH 6/9] set default cubietruck led triggers
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -29,5 +29,5 @@ index 5649161de1d7..2be64a886555 100644
};
--
2.19.0
2.19.2

View file

@ -1,7 +1,7 @@
From cd97ab74c3c0f71ea8f3ea3c655084e8e5122a1c Mon Sep 17 00:00:00 2001
From 9b489a0d23c2e0e1025330f301ffde8754b81228 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Thu, 11 Aug 2016 00:42:37 -0600
Subject: [PATCH 7/8] exynos4412-odroid: set higher minimum buck2 regulator
Subject: [PATCH 7/9] exynos4412-odroid: set higher minimum buck2 regulator
voltage
Set a higher minimum voltage to help reboot issue.
@ -26,5 +26,5 @@ index 2caa3132f34e..06c6ca20a969 100644
regulator-always-on;
regulator-boot-on;
--
2.19.0
2.19.2

View file

@ -1,7 +1,7 @@
From 8606176243418d2735ef99c848afe9ef2a867be2 Mon Sep 17 00:00:00 2001
From d75f6db84386ce81fb595daab15a0425dd1f9dd7 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sun, 7 May 2017 13:32:25 -0600
Subject: [PATCH 8/8] ARM: dove: enable ethernet on D3Plug
Subject: [PATCH 8/9] ARM: dove: enable ethernet on D3Plug
Signed-off-by: Kevin Mihelich <kevin@archlinuxarm.org>
---
@ -27,5 +27,5 @@ index 826026c28f90..a4c9963e1261 100644
/* Samsung M8G2F eMMC */
&sdio0 {
--
2.19.0
2.19.2

View file

@ -0,0 +1,38 @@
From 9b6ed88a92f7f5e6b04024dcefec19c59698c5c8 Mon Sep 17 00:00:00 2001
From: Marek Szyprowski <m.szyprowski@samsung.com>
Date: Mon, 7 Jan 2019 13:04:14 +0100
Subject: [PATCH 9/9] media: s5p-mfc: fix incorrect bus assignment in virtual
child device
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Virtual MFC codec's child devices must not be assigned to platform bus,
because they are allocated as raw 'struct device' and don't have the
corresponding 'platform' part. This fixes NULL pointer access revealed
recently by commit a66d972465d1 ("devres: Align data[] to
ARCH_KMALLOC_MINALIGN").
Reported-by: Paweł Chmiel <pawel.mikolaj.chmiel@gmail.com>
Fixes: c79667dd93b0 ("media: s5p-mfc: replace custom reserved memory handling code with generic one")
Signed-off-by: Marek Szyprowski <m.szyprowski@samsung.com>
Tested-by: Paweł Chmiel <pawel.mikolaj.chmiel@gmail.com>
---
drivers/media/platform/s5p-mfc/s5p_mfc.c | 1 -
1 file changed, 1 deletion(-)
diff --git a/drivers/media/platform/s5p-mfc/s5p_mfc.c b/drivers/media/platform/s5p-mfc/s5p_mfc.c
index 927a1235408d..ca11f8a7569d 100644
--- a/drivers/media/platform/s5p-mfc/s5p_mfc.c
+++ b/drivers/media/platform/s5p-mfc/s5p_mfc.c
@@ -1089,7 +1089,6 @@ static struct device *s5p_mfc_alloc_memdev(struct device *dev,
device_initialize(child);
dev_set_name(child, "%s:%s", dev_name(dev), name);
child->parent = dev;
- child->bus = dev->bus;
child->coherent_dma_mask = dev->coherent_dma_mask;
child->dma_mask = dev->dma_mask;
child->release = s5p_mfc_memdev_release;
--
2.19.2

View file

@ -8,7 +8,7 @@ _srcname=linux-4.20
_kernelname=${pkgbase#linux}
_desc="ARMv7 multi-platform"
pkgver=4.20.2
pkgrel=1
pkgrel=2
rcnrel=armv7-x3
arch=('armv7h')
url="http://www.kernel.org/"
@ -26,6 +26,7 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
'0006-set-default-cubietruck-led-triggers.patch'
'0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch'
'0008-ARM-dove-enable-ethernet-on-D3Plug.patch'
'0009-media-s5p-mfc-fix-incorrect-bus-assignment-in-virtua.patch'
'config'
'kernel.its'
'kernel.keyblock'
@ -36,14 +37,15 @@ source=("http://www.kernel.org/pub/linux/kernel/v4.x/${_srcname}.tar.xz"
md5sums=('d39dd4ba2d5861c54b90d49be19eaf31'
'17eb4912f0e4141e8a0dc02dd4432bb6'
'10154f97faeb65748a31806a85481933'
'0e7aaf27edd95d74cebd059c66b51db2'
'939760cd495c15a2fe3a2039bc328306'
'869394fae9703e6ea8838381923b9e4e'
'8a3e3a3d5248dc3067d7a4068f28d442'
'290e413b7da4367efe25b203c4704e69'
'eb4c624fee628384bb89136dfe1e5242'
'87113c3a1f0df84ebbcfeb0b03529a36'
'5ffeacda419ee62c668c333a2d3a4c4d'
'a9f76b75f18f89d535bbbe357c08f70e'
'40708505c237608fbc3923a714f8ffcb'
'339f1a7d7242c8639f33f6acd370f761'
'f276f1bfdd926516db36c81096eb6914'
'32ba1be48b4305dde4a3503097f1ad10'
'37c972c5bc79514b85846d5f1b13838a'
'c5fce59d890676702244170c2736dcb1'
'2907befef7c5dc788ceb5a99fdefd23c'
'2faa70647c4965b32e9f0f597614fcbf'
'6b95ea40314c5531cea810e3a16e02f9'
'4f2379ed84258050edb858ee8d281678'
'61c5ff73c136ed07a7aadbf58db3d96a'
@ -70,6 +72,7 @@ prepare() {
git apply ../0006-set-default-cubietruck-led-triggers.patch
git apply ../0007-exynos4412-odroid-set-higher-minimum-buck2-regulator.patch
git apply ../0008-ARM-dove-enable-ethernet-on-D3Plug.patch
git apply ../0009-media-s5p-mfc-fix-incorrect-bus-assignment-in-virtua.patch
cat "${srcdir}/config" > ./.config