mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
community/opensubdiv to 3.4.4-1
This commit is contained in:
parent
1dab715098
commit
48b3e18771
2 changed files with 4 additions and 76 deletions
|
@ -4,8 +4,8 @@
|
|||
# - remove makedepend on cuda
|
||||
|
||||
pkgname=opensubdiv
|
||||
pkgver=3.4.3
|
||||
pkgrel=5
|
||||
pkgver=3.4.4
|
||||
pkgrel=1
|
||||
pkgdesc="An Open-Source subdivision surface library"
|
||||
arch=(x86_64)
|
||||
url="http://graphics.pixar.com/opensubdiv"
|
||||
|
@ -15,8 +15,8 @@ makedepends=('cmake' 'doxygen' 'glfw' 'glew' 'python' 'python-pygments' 'python-
|
|||
source=("https://github.com/PixarAnimationStudios/OpenSubdiv/archive/v${pkgver//./_}.tar.gz"
|
||||
python3.patch
|
||||
cuda9.patch)
|
||||
sha512sums=('44fd1361d9e7f48c3fa84f3420ed34743571220602aefb082a42f769ca5b8e9ac21907ce8714f6e3a2caadd75adae03c535a1949a8e6450dfea9ae7a2247cfc2'
|
||||
'035a6691080e9ec1a6eb5e4a7746f3f0ba6caea4b74c1bfededdc477b701431456b026ee75dbf7ca03fabd6526f62e9181c616a62304f26e614474577b96fcc7'
|
||||
sha512sums=('fc8f28b79347015c8991150535c1339e695d96947c72fadd4fa27b546a0813c1125cd175ee03bed5aacdb3609f74c4e526ef70103d1195ba9f7df041e73ea9fb'
|
||||
'10f1f63e07d59deb4d91ba04448bb360efff0e41202bb6737caffbce09ba244efb349fe25b24880420b80fdadb268aed84923464af0d66ee1a36e4ba8f96cfd5'
|
||||
'fe51160959f71f33e3c8008158f9f98c3c7a065b22360e7719ec1d262105b35d02c2c2f64f05acee58281c938a007a88054dcc07f1aef89908e6dbf4e3e3ab6f')
|
||||
|
||||
prepare() {
|
||||
|
|
|
@ -1,75 +1,3 @@
|
|||
diff --git a/build_scripts/build_osd.py b/build_scripts/build_osd.py
|
||||
index e8ebef88..4b2b6fb9 100644
|
||||
--- a/build_scripts/build_osd.py
|
||||
+++ b/build_scripts/build_osd.py
|
||||
@@ -38,7 +38,7 @@ import shutil
|
||||
import subprocess
|
||||
import sys
|
||||
import tarfile
|
||||
-import urllib2
|
||||
+import urllib.request, urllib.error, urllib.parse
|
||||
import zipfile
|
||||
|
||||
# Helpers for printing output
|
||||
@@ -46,26 +46,26 @@ verbosity = 1
|
||||
|
||||
def Print(msg):
|
||||
if verbosity > 0:
|
||||
- print msg
|
||||
+ print(msg)
|
||||
|
||||
def PrintWarning(warning):
|
||||
if verbosity > 0:
|
||||
- print "WARNING:", warning
|
||||
+ print("WARNING:", warning)
|
||||
|
||||
def PrintStatus(status):
|
||||
if verbosity >= 1:
|
||||
- print "STATUS:", status
|
||||
+ print("STATUS:", status)
|
||||
|
||||
def PrintInfo(info):
|
||||
if verbosity >= 2:
|
||||
- print "INFO:", info
|
||||
+ print("INFO:", info)
|
||||
|
||||
def PrintCommandOutput(output):
|
||||
if verbosity >= 3:
|
||||
sys.stdout.write(output)
|
||||
|
||||
def PrintError(error):
|
||||
- print "ERROR:", error
|
||||
+ print("ERROR:", error)
|
||||
|
||||
# Helpers for determining platform
|
||||
def Windows():
|
||||
@@ -290,7 +290,7 @@ def DownloadFileWithPowershell(url, outputFilename):
|
||||
Run(cmd,logCommandOutput=False)
|
||||
|
||||
def DownloadFileWithUrllib(url, outputFilename):
|
||||
- r = urllib2.urlopen(url)
|
||||
+ r = urllib.request.urlopen(url)
|
||||
with open(outputFilename, "wb") as outfile:
|
||||
outfile.write(r.read())
|
||||
|
||||
@@ -329,7 +329,7 @@ def DownloadURL(url, context, force, dontExtract = None):
|
||||
if os.path.exists(tmpFilename):
|
||||
os.remove(tmpFilename)
|
||||
|
||||
- for i in xrange(maxRetries):
|
||||
+ for i in range(maxRetries):
|
||||
try:
|
||||
context.downloader(url, tmpFilename)
|
||||
break
|
||||
@@ -993,7 +993,7 @@ if context.buildArgs:
|
||||
|
||||
def FormatBuildArguments(buildArgs):
|
||||
s = ""
|
||||
- for depName in sorted(buildArgs.iterkeys()):
|
||||
+ for depName in sorted(buildArgs.keys()):
|
||||
args = buildArgs[depName]
|
||||
s += """
|
||||
{name}: {args}""".format(
|
||||
diff --git a/documentation/CMakeLists.txt b/documentation/CMakeLists.txt
|
||||
index 32b12a3d..581159ca 100644
|
||||
--- a/documentation/CMakeLists.txt
|
||||
|
|
Loading…
Reference in a new issue