added community/libuhd

This commit is contained in:
Kevin Mihelich 2016-05-14 17:24:24 +00:00
parent acd1838336
commit 4906106ba0
2 changed files with 95 additions and 0 deletions

View file

@ -0,0 +1,39 @@
From d48353b54007a39d8ef9cb53c3d18adf8be9b62c Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Sat, 14 May 2016 11:08:46 -0600
Subject: [PATCH] remove ineffectual neon check
---
host/lib/convert/CMakeLists.txt | 16 ----------------
1 file changed, 16 deletions(-)
diff --git a/host/lib/convert/CMakeLists.txt b/host/lib/convert/CMakeLists.txt
index 10376ba..4d793c4 100644
--- a/host/lib/convert/CMakeLists.txt
+++ b/host/lib/convert/CMakeLists.txt
@@ -54,22 +54,6 @@ IF(HAVE_EMMINTRIN_H)
ENDIF(HAVE_EMMINTRIN_H)
########################################################################
-# Check for NEON SIMD headers
-########################################################################
-IF(CMAKE_COMPILER_IS_GNUCXX)
- CHECK_INCLUDE_FILE_CXX(arm_neon.h HAVE_ARM_NEON_H)
-ENDIF(CMAKE_COMPILER_IS_GNUCXX)
-
-IF(HAVE_ARM_NEON_H AND (${CMAKE_SIZEOF_VOID_P} EQUAL 4))
- ENABLE_LANGUAGE(ASM)
-
- LIBUHD_APPEND_SOURCES(
- ${CMAKE_CURRENT_SOURCE_DIR}/convert_with_neon.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/convert_neon.S
- )
-ENDIF()
-
-########################################################################
# Convert types generation
########################################################################
INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
--
2.8.2

56
community/libuhd/PKGBUILD Normal file
View file

@ -0,0 +1,56 @@
# $Id$
# Maintainer: Kyle Keen <keenerd@gmail.com>
# Contributor: Dominik Heidler <dheidler@gmail.com>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - patch out ineffectual neon check
pkgname=libuhd
pkgver=3.9.3
_verstring='003_009_003'
pkgrel=2
pkgdesc="Universal Software Radio Peripheral (USRP) userspace driver"
arch=('x86_64' 'i686')
url="http://www.ettus.com/kb/category/software-documentation/uhd-manual"
license=('GPL')
depends=('boost-libs' 'orc' 'libusbx')
optdepends=('python2: usrp utils')
makedepends=('cmake' 'boost' 'python2-cheetah' 'python2-mako')
source=("libuhd-$pkgver.tar.gz::https://github.com/EttusResearch/uhd/archive/release_${_verstring}.tar.gz"
'0001-remove-ineffectual-neon-check.patch')
md5sums=('c9c1dbc571422fe6678611381765a41f'
'2cb16216ee735ab1160e572d523155ea')
prepare() {
patch -d uhd-release_$_verstring -p1 -i ../0001-remove-ineffectual-neon-check.patch
}
build() {
cd "$srcdir/uhd-release_$_verstring/host"
# fix for py2
find -name "*.py" -or -name '*.py.in' | xargs sed -i "s|#!/usr/bin/env python$|#!/usr/bin/env python2|"
mkdir -p build
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr/ \
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DENABLE_EXAMPLES=OFF \
-DENABLE_UTILS=ON \
-DENABLE_TESTS=OFF \
-DENABLE_E100=ON \
-DENABLE_E300=ON
make
}
check() {
cd "$srcdir/uhd-release_$_verstring/host/build"
make test
}
package() {
cd "$srcdir/uhd-release_$_verstring/host/build"
make DESTDIR="$pkgdir" install
install -Dm644 "../utils/uhd-usrp.rules" "$pkgdir/usr/lib/udev/rules.d/10-uhd-usrp.rules"
}