extra/vigra to 1.11.0-7

This commit is contained in:
Kevin Mihelich 2017-05-29 17:28:48 +00:00
parent e17949431f
commit 491d4c2eb0
3 changed files with 35 additions and 36 deletions

View file

@ -8,7 +8,7 @@
pkgbase=vigra
pkgname=('vigra' 'vigra-doc')
pkgver=1.11.0
pkgrel=6
pkgrel=7
arch=('i686' 'x86_64')
url="http://hci.iwr.uni-heidelberg.de/vigra/"
license=('custom:MIT')
@ -16,8 +16,15 @@ makedepends=(# runtime deps
'libpng' 'libtiff' 'openexr' 'gcc-libs' 'sh' 'hdf5' 'fftw'
# additional makedeps
'cmake' 'python-nose' 'doxygen' 'python-sphinx' 'boost' 'python-numpy')
source=(https://github.com/ukoethe/vigra/releases/download/Version-${pkgver//./-}/vigra-${pkgver}-src.tar.gz)
md5sums=('7f80d289e03a2f2e8c8e85f3ff29d988')
source=(https://github.com/ukoethe/vigra/releases/download/Version-${pkgver//./-}/vigra-${pkgver}-src.tar.gz
vigra-1.11.0-const-swap.patch)
md5sums=('7f80d289e03a2f2e8c8e85f3ff29d988'
'a571f3a8d4cd66c8a8071ca958091f7b')
prepare() {
cd "${srcdir}"/${pkgbase}-${pkgver}
patch -p1 -i "${srcdir}"/vigra-1.11.0-const-swap.patch
}
build() {
cd "${srcdir}"/${pkgbase}-${pkgver}

View file

@ -0,0 +1,25 @@
From 18675a51fca27b324eb4e4b49593bcee9bc4535e Mon Sep 17 00:00:00 2001
From: Jonathan Wakely <jwakely@redhat.com>
Date: Fri, 17 Feb 2017 00:55:25 +0000
Subject: [PATCH] Fix parameter of ImagePyramid::swap
You can't swap with a const object. This fixes a compilation failure
with GCC 7 which rejects the incorrect function even if it isn't
instantiated.
---
include/vigra/imagecontainer.hxx | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/vigra/imagecontainer.hxx b/include/vigra/imagecontainer.hxx
index a6f0f80..636cc64 100644
--- a/include/vigra/imagecontainer.hxx
+++ b/include/vigra/imagecontainer.hxx
@@ -763,7 +763,7 @@ public:
/** swap contents of this array with the contents of other
(STL-Container interface)
*/
- void swap(const ImagePyramid<ImageType, Alloc> &other)
+ void swap(ImagePyramid<ImageType, Alloc> &other)
{
images_.swap(other.images_);
std::swap(lowestLevel_, other.lowestLevel_);

View file

@ -1,33 +0,0 @@
diff -baur vigra-1.7.1.old/include/vigra/random_forest.hxx vigra-1.7.1/include/vigra/random_forest.hxx
--- vigra-1.7.1.old/include/vigra/random_forest.hxx 2010-12-03 17:40:34.000000000 +0000
+++ vigra-1.7.1/include/vigra/random_forest.hxx 2011-01-28 00:16:32.000000000 +0000
@@ -43,6 +43,7 @@
#include <set>
#include <list>
#include <numeric>
+#include <stddef.h>
#include "mathutil.hxx"
#include "array_vector.hxx"
#include "sized_int.hxx"
diff -baur vigra-1.7.1.old/include/vigra/sifImport.hxx vigra-1.7.1/include/vigra/sifImport.hxx
--- vigra-1.7.1.old/include/vigra/sifImport.hxx 2010-12-03 17:40:34.000000000 +0000
+++ vigra-1.7.1/include/vigra/sifImport.hxx 2011-01-28 00:23:31.000000000 +0000
@@ -57,6 +57,7 @@
#include <fstream>
#include <cstring>
#include <vector>
+#include <stddef.h>
#include "vigra/multi_array.hxx"
namespace vigra {
diff -baur vigra-1.7.1.old/include/vigra/multi_iterator.hxx vigra-1.7.1/include/vigra/multi_iterator.hxx
--- vigra-1.7.1.old/include/vigra/multi_iterator.hxx 2010-12-03 17:40:34.000000000 +0000
+++ vigra-1.7.1/include/vigra/multi_iterator.hxx 2011-01-28 00:23:31.000000000 +0000
@@ -41,6 +41,7 @@
#define VIGRA_MULTI_ITERATOR_HXX
#include <sys/types.h>
+#include <stddef.h>
#include "tinyvector.hxx"
#include "iteratortags.hxx"