extra/calligra to 2.8.0-1

This commit is contained in:
Kevin Mihelich 2014-03-05 19:39:48 +00:00
parent ba33eb1861
commit 496e2a8ccd
2 changed files with 63 additions and 73 deletions

View file

@ -1,4 +1,4 @@
# $Id: PKGBUILD 184364 2013-05-06 19:36:46Z foutrelis $
# $Id$
# Maintainer: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Ronald van Haren <ronald.archlinux.org>
@ -8,6 +8,7 @@
pkgbase=calligra
pkgname=('calligra-braindump'
'calligra-devtools'
'calligra-extras'
'calligra-filters'
'calligra-flow'
@ -21,30 +22,28 @@ pkgname=('calligra-braindump'
'calligra-sheets'
'calligra-stage'
'calligra-words')
pkgver=2.7.5
pkgrel=5
pkgver=2.8.0
pkgrel=1
arch=('i686' 'x86_64')
url='http://www.calligra-suite.org/'
license=('FDL1.2' 'GPL2' 'LGPL')
makedepends=('cmake' 'automoc4' 'boost' 'kdepimlibs' 'eigen2' 'kdeedu-marble'
'lcms2' 'libmariadbclient' 'freetds' 'xbase' 'libwpg' 'opencolorio'
'libwps' 'gsl' 'glew' 'fftw' 'poppler-qt' 'libkdcraw'
'openjpeg' 'kdegraphics-okular' 'pstoedit' 'libvisio')
'libwps' 'gsl' 'glew' 'fftw' 'poppler-qt' 'libkdcraw' 'libodfgen'
'openjpeg' 'kdegraphics-okular' 'pstoedit' 'libvisio'
'libetonyek' 'libpqxx' 'libspnav')
groups=('calligra')
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.xz"
"arm.patch")
md5sums=('05d1d0bac970d6dc68ffabc12fca2eb7'
'07d60efe2cdd472cb8860ea1ae157976')
'arm.patch')
md5sums=('59abfc331220f5282ea2d6df5e80e899'
'dc5105bcc612560f46d27071aca69cba')
prepare() {
cd $pkgbase-$pkgver
patch -p1 -i "$srcdir"/arm.patch
cd ..
mkdir build
# fix openjpeg detection
# fix openjpeg detection
sed -i "s:/usr/include/openjpeg:/usr/include/openjpeg-1.5:" \
${srcdir}/${pkgbase}-${pkgver}/cmake/modules/FindOpenJPEG.cmake
${pkgbase}-${pkgver}/cmake/modules/FindOpenJPEG.cmake
}
build() {
@ -52,34 +51,37 @@ build() {
cmake ../${pkgbase}-${pkgver} \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_active=OFF
make
}
package_calligra-filters() {
pkgdesc="Filters for the Calligra office suite"
depends=('libodfgen')
optdepends=('libwpg: Corel WordPerfect Graphics image importer'
'libwps: Microsoft Works file word processor format import'
'libvisio: Microsoft Visio import filter')
'libvisio: Microsoft Visio import filter'
'libetonyek: Apple Keynote import filter')
conflicts=('koffice-filters')
replaces=('koffice-filters')
install=calligra-filters.install
cd "${srcdir}"/build/filters
cd build/filters
make DESTDIR="${pkgdir}" install
}
package_calligra-libs() {
pkgdesc="Libraries for the Calligra office suite"
depends=('kdepimlibs' 'lcms2' 'kactivities')
depends=('kdepimlibs' 'kactivities')
conflicts=('koffice-interfaces' 'koffice-libs' 'koffice-pics'
'koffice-servicetypes' 'koffice-templates' 'calligra-interfaces'
'calligra-pics' 'calligra-servicetypes' 'calligra-templates')
'koffice-servicetypes' 'calligra-interfaces'
'calligra-pics' 'calligra-servicetypes')
replaces=('koffice-interfaces' 'koffice-libs' 'koffice-pics'
'koffice-servicetypes' 'koffice-templates' 'calligra-interfaces'
'calligra-pics' 'calligra-servicetypes' 'calligra-templates')
'koffice-servicetypes' 'calligra-interfaces'
'calligra-pics' 'calligra-servicetypes')
for d in interfaces libs pics servicetypes templates; do
for d in interfaces libs pics servicetypes; do
cd "${srcdir}"/build/${d}
make DESTDIR="${pkgdir}" install
done
@ -87,16 +89,16 @@ package_calligra-libs() {
package_calligra-plugins() {
pkgdesc="Plugins for the Calligra office suite"
depends=('calligra-libs' 'calligra-filters')
depends=('calligra-libs' 'calligra-filters' 'libspnav')
optdepends=('kdeedu-marble: map shape for Calligra')
conflicts=('koffice-plugins' 'koffice-kchart')
replaces=('koffice-plugins' 'koffice-kchart' 'koffice-kformula')
install=calligra-plugins.install
cd "${srcdir}"/build/plugins
cd build/plugins
make DESTDIR="${pkgdir}" install
cd "${srcdir}"/build/3rdparty/kdchart
cd ../3rdparty/kdchart
make DESTDIR="${pkgdir}" install
}
@ -109,7 +111,7 @@ package_calligra-karbon() {
replaces=('koffice-karbon' 'koffice-karbon-doc' 'calligra-karbon-doc')
install=calligra-karbon.install
cd "${srcdir}"/build/karbon
cd build/karbon
make DESTDIR="${pkgdir}" install
}
@ -117,6 +119,7 @@ package_calligra-kexi() {
pkgdesc="Develop desktop database applications"
depends=('calligra-libs' 'glew' 'fftw')
optdepends=('libmariadbclient: MariaDB driver'
'libpqxx: PostgreSQL driver'
'freetds: Sybase & MS SQL driver'
'xbase: XBase driver'
'calligra-sheets: Spreadsheet-to-Kexi-table import plugin'
@ -126,9 +129,9 @@ package_calligra-kexi() {
replaces=('koffice-kexi' 'koffice-kexi-doc' 'calligra-kexi-doc')
install=calligra-kexi.install
cd "${srcdir}"/build/kexi
cd build/kexi
make DESTDIR="${pkgdir}" install
cd "${srcdir}"/build/doc/kexi
cd ../doc/kexi
make DESTDIR="${pkgdir}" install
}
@ -139,10 +142,10 @@ package_calligra-plan() {
replaces=('koffice-kplato' 'calligra-kplato')
install=calligra-plan.install
cd "${srcdir}"/build/plan
cd build/plan
make DESTDIR="${pkgdir}" install
cd "${srcdir}"/build/3rdparty/kdgantt
cd ../3rdparty/kdgantt
make DESTDIR="${pkgdir}" install
}
@ -153,9 +156,9 @@ package_calligra-stage() {
replaces=('koffice-kpresenter' 'koffice-kpresenter-doc' 'calligra-stage-doc')
install=calligra-stage.install
cd "${srcdir}"/build/stage
cd build/stage
make DESTDIR="${pkgdir}" install
cd "${srcdir}"/build/doc/stage
cd ../doc/stage
make DESTDIR="${pkgdir}" install
}
@ -167,7 +170,7 @@ package_calligra-krita() {
replaces=('koffice-krita' 'calligra-krita-doc')
install=calligra-krita.install
cd "${srcdir}"/build/krita
cd build/krita
make DESTDIR="${pkgdir}" install
}
@ -181,9 +184,9 @@ package_calligra-sheets() {
replaces=('koffice-kspread' 'koffice-kspread-doc' 'calligra-tables-doc' 'calligra-tables')
install=calligra-sheets.install
cd "${srcdir}"/build/sheets
cd build/sheets
make DESTDIR="${pkgdir}" install
cd "${srcdir}"/build/doc/sheets
cd ../doc/sheets
make DESTDIR="${pkgdir}" install
}
@ -195,7 +198,7 @@ package_calligra-words() {
replaces=('koffice-kword')
install=calligra-words.install
cd "${srcdir}"/build/words
cd build/words
make DESTDIR="${pkgdir}" install
}
@ -205,7 +208,7 @@ package_calligra-handbook() {
replaces=('koffice-handbook')
options=('docs')
cd "${srcdir}"/build/doc/calligra
cd build/doc/calligra
make DESTDIR="${pkgdir}" install
}
@ -214,19 +217,19 @@ package_calligra-braindump() {
depends=('calligra-libs' 'kdebase-runtime')
install=calligra-braindump.install
cd "${srcdir}"/build/braindump
cd build/braindump
make DESTDIR="${pkgdir}" install
}
package_calligra-flow() {
pkgdesc="Flowchart & Diagram Editing"
depends=('calligra-words')
optdepends=('calligra-karbon: to export the charts in various formats')
conflicts=('calligra-flow-doc')
replaces=('calligra-flow-doc')
install=calligra-flow.install
optdepends=('calligra-karbon: to export the charts in various formats')
cd "${srcdir}"/build/flow
cd build/flow
make DESTDIR="${pkgdir}" install
}
@ -234,10 +237,21 @@ package_calligra-extras() {
pkgdesc="Calligra suite extras"
depends=('calligra-libs')
optdepends=('kdegraphics-okular')
conflicts=('calligra-tools')
replaces=('calligra-tools')
conflicts=('calligra-tools' 'koffice-templates' 'calligra-templats')
replaces=('calligra-tools' 'koffice-templates' 'calligra-templats')
install=calligra-extras.install
cd "${srcdir}"/build/extras
cd build/extras
make DESTDIR="${pkgdir}" install
cd ../data
make DESTDIR="${pkgdir}" install
}
package_calligra-devtools() {
pkgdesc="Calligra developer tools"
depends=('calligra-libs')
cd build/devtools
make DESTDIR="${pkgdir}" install
}

View file

@ -1,6 +1,6 @@
diff -urN a/krita/image/kis_fixed_point_maths.h b/krita/image/kis_fixed_point_maths.h
--- a/krita/image/kis_fixed_point_maths.h 2013-07-29 00:27:14.000000000 -0600
+++ b/krita/image/kis_fixed_point_maths.h 2013-08-07 11:11:37.025564690 -0600
--- a/krita/image/kis_fixed_point_maths.h 2014-03-02 07:46:08.000000000 -0700
+++ b/krita/image/kis_fixed_point_maths.h 2014-03-05 12:33:56.583956529 -0700
@@ -34,7 +34,7 @@
d = iValue << 8;
}
@ -10,21 +10,9 @@ diff -urN a/krita/image/kis_fixed_point_maths.h b/krita/image/kis_fixed_point_ma
d = fValue * (1 << 8);
}
diff -urN a/krita/image/tests/kis_filter_weights_buffer_test.cpp b/krita/image/tests/kis_filter_weights_buffer_test.cpp
--- a/krita/image/tests/kis_filter_weights_buffer_test.cpp 2013-07-29 00:27:14.000000000 -0600
+++ b/krita/image/tests/kis_filter_weights_buffer_test.cpp 2013-08-07 10:44:47.563284702 -0600
@@ -38,7 +38,7 @@
KisFixedPoint fp2;
const int startIndex = 1;
- const int endIndex = 255 * qMin(scale, 1.0);
+ const int endIndex = 255 * qMin((double)scale, 1.0);
fp1.from256Frac(startIndex);
fp2.from256Frac(endIndex);
diff -urN a/krita/ui/kis_image_view_converter.cpp b/krita/ui/kis_image_view_converter.cpp
--- a/krita/ui/kis_image_view_converter.cpp 2013-07-29 00:27:15.000000000 -0600
+++ b/krita/ui/kis_image_view_converter.cpp 2013-08-07 10:44:47.563284702 -0600
--- a/krita/ui/kis_image_view_converter.cpp 2014-03-02 07:46:08.000000000 -0700
+++ b/krita/ui/kis_image_view_converter.cpp 2014-03-05 12:33:56.583956529 -0700
@@ -40,7 +40,7 @@
// remember here; document is postscript points; view is krita pixels.
@ -35,8 +23,8 @@ diff -urN a/krita/ui/kis_image_view_converter.cpp b/krita/ui/kis_image_view_conv
Q_ASSERT(zoomX);
Q_ASSERT(zoomY);
diff -urN a/krita/ui/kis_image_view_converter.h b/krita/ui/kis_image_view_converter.h
--- a/krita/ui/kis_image_view_converter.h 2013-07-29 00:27:15.000000000 -0600
+++ b/krita/ui/kis_image_view_converter.h 2013-08-07 10:44:47.563284702 -0600
--- a/krita/ui/kis_image_view_converter.h 2014-03-02 07:46:08.000000000 -0700
+++ b/krita/ui/kis_image_view_converter.h 2014-03-05 12:33:56.588956485 -0700
@@ -52,7 +52,7 @@
using KoViewConverter::viewToDocument;
@ -46,15 +34,3 @@ diff -urN a/krita/ui/kis_image_view_converter.h b/krita/ui/kis_image_view_conver
qreal documentToViewX(qreal documentX) const;
qreal documentToViewY(qreal documentY) const;
diff -urN a/krita/ui/tests/kis_zoom_and_pan_test.cpp b/krita/ui/tests/kis_zoom_and_pan_test.cpp
--- a/krita/ui/tests/kis_zoom_and_pan_test.cpp 2013-07-29 00:27:15.000000000 -0600
+++ b/krita/ui/tests/kis_zoom_and_pan_test.cpp 2013-08-07 10:44:47.568284679 -0600
@@ -218,7 +218,7 @@
qreal oldPreferredCenterFractionY = 1.0 * oldPreferredCenter.y() / oldDocumentSize.height();
qreal roundingTolerance =
- qMax(1.0, qMax(oldPreferredCenterFractionX, oldPreferredCenterFractionY) / k);
+ qMax((float)1.0, qMax(oldPreferredCenterFractionX, oldPreferredCenterFractionY) / k);
/**
* In the computation of the offset two roundings happen: