From 49877dc6977a1ee82d9c41c0393997233ce9c075 Mon Sep 17 00:00:00 2001
From: Kevin Mihelich <kevin@archlinuxarm.org>
Date: Fri, 25 Mar 2022 12:59:04 +0000
Subject: [PATCH] community/cppcheck to 2.7.4-1

---
 community/cppcheck/PKGBUILD            | 14 ++++----------
 community/cppcheck/find-tinyxml2.patch | 13 -------------
 2 files changed, 4 insertions(+), 23 deletions(-)
 delete mode 100644 community/cppcheck/find-tinyxml2.patch

diff --git a/community/cppcheck/PKGBUILD b/community/cppcheck/PKGBUILD
index c5c2d3bb2..5985d75ff 100644
--- a/community/cppcheck/PKGBUILD
+++ b/community/cppcheck/PKGBUILD
@@ -6,7 +6,7 @@
 #  - remove makedepend on pandoc, don't generate manuals
 
 pkgname=cppcheck
-pkgver=2.7.3
+pkgver=2.7.4
 pkgrel=1
 pkgdesc="A tool for static C/C++ code analysis"
 arch=('x86_64')
@@ -31,18 +31,15 @@ optdepends=(
   'clang: for cppcheck-gui integration'
 )
 options=('debug')
-_commit='97bf53515b8ec8db6f6f12ea15db4786e26afbc8'
+_commit='1cc234ac2c1a7ba8c62e4d57b4595b8f69990bd2'
 source=(
   "$pkgname::git+https://github.com/danmar/cppcheck.git#commit=$_commit"
   'translations-location.patch'
-  'find-tinyxml2.patch'
 )
 sha512sums=('SKIP'
-            'd3528834d719017ec3a0e08005a293089b556622928defa1b37f940e62cb01165dcbd741e6d5e989c0156fb8789f7e63702af8b2390738648b2300a92f4ab0ae'
-            '09b03952ea98f56ed750f3e4443dd148a8aafc68072235537c7db09aca83a11a9f28e7a573b0d63d2a1bf1b57886fd540be060d933bcec9b38d09a09426ae5ff')
+            'd3528834d719017ec3a0e08005a293089b556622928defa1b37f940e62cb01165dcbd741e6d5e989c0156fb8789f7e63702af8b2390738648b2300a92f4ab0ae')
 b2sums=('SKIP'
-        '8156920eacc630cb5eceb2387937b747c84c6325bef906717cfbad68c122bdd27965da1e8070a560a0bed3a7b7c59ff5f0e116bb1d035c4c42f430c927a75b1f'
-        '51585895a91142fecac88e49c9c182897441ee8033638927b0cbd1c66e5345096d0b03f296a2a8ff8622ef5959b73963617e46be231c8e9a6fbc563571db7ba5')
+        '8156920eacc630cb5eceb2387937b747c84c6325bef906717cfbad68c122bdd27965da1e8070a560a0bed3a7b7c59ff5f0e116bb1d035c4c42f430c927a75b1f')
 
 pkgver() {
   cd "$pkgname"
@@ -55,9 +52,6 @@ prepare() {
 
   # fix location of translations
   patch -p1 -i ../translations-location.patch
-
-  # fix undefined reference to tinyxml2
-  patch -p1 -i ../find-tinyxml2.patch
 }
 
 build() {
diff --git a/community/cppcheck/find-tinyxml2.patch b/community/cppcheck/find-tinyxml2.patch
deleted file mode 100644
index def3237b6..000000000
--- a/community/cppcheck/find-tinyxml2.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/cmake/findDependencies.cmake
-+++ b/cmake/findDependencies.cmake
-@@ -48,7 +48,9 @@ endif()
- 
- if (NOT USE_BUNDLED_TINYXML2)
-     find_package(tinyxml2 QUIET)
--    if (NOT tinyxml2_FOUND)
-+    if (tinyxml2_FOUND)
-+        set(tinyxml2_LIBRARIES "tinyxml2")
-+    else()
-         find_library(tinyxml2_LIBRARIES tinyxml2)
-         if (NOT tinyxml2_LIBRARIES)
-             message(FATAL_ERROR "tinyxml2 has not been found")