diff --git a/community/spice-gtk3/PKGBUILD b/community/spice-gtk3/PKGBUILD
index ed5fb2ce0..84da385d3 100644
--- a/community/spice-gtk3/PKGBUILD
+++ b/community/spice-gtk3/PKGBUILD
@@ -9,13 +9,14 @@
 
 pkgname=spice-gtk3
 pkgver=0.24
-pkgrel=3
+pkgrel=4
 pkgdesc="Gtk client and libraries for SPICE remote desktop servers (gtk3 version)"
 arch=('i686' 'x86_64')
 url="http://spice-space.org"
 license=('LGPL2.1')
-depends=('celt0.5.1' 'dbus-glib' 'gstreamer0.10-good' 'gtk3' 'libpulse' 'usbredir' 'libsoup')
-makedepends=('gobject-introspection' 'intltool' 'python2-pyparsing' 'spice-protocol' 'usbutils' 'vala')
+depends=('celt0.5.1' 'dbus-glib' 'gtk3' 'libpulse' 'usbredir' 'libsoup')
+makedepends=('gobject-introspection' 'intltool' 'python2-pyparsing' 'spice-protocol' 'usbutils'
+	     'vala' 'sdl')
 source=("http://www.spice-space.org/download/gtk/spice-gtk-$pkgver.tar.bz2")
 sha256sums=('6efe500845f910945670f11664f584fd13b9db494075c41137eb7bacd60d1ed1')
 
@@ -28,7 +29,7 @@ build() {
   cd "$srcdir/spice-gtk-$pkgver"
   PYTHON=python2 ./configure --prefix=/usr \
     --disable-static --enable-vala --with-gtk=3.0 \
-    --with-audio=pulse --with-audio=gstreamer \
+    --with-audio=pulse \
     --with-coroutine=gthread --sbindir=/usr/bin
   make
 }