mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
removed community/python-pytables
This commit is contained in:
parent
890e7879b5
commit
49cfe36c73
2 changed files with 0 additions and 74 deletions
|
@ -1,61 +0,0 @@
|
|||
# $Id$
|
||||
# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
|
||||
# Contributor: Sebastien Binet <binet@cern.ch>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove package when bumped upstream
|
||||
|
||||
pkgbase=python-pytables
|
||||
pkgname=('python2-pytables' 'python-pytables')
|
||||
pkgver=3.1.1
|
||||
pkgrel=2
|
||||
arch=("i686" "x86_64")
|
||||
pkgdesc="A package for managing hierarchical datasets and designed to efficiently and easily cope with extremely large amounts of data"
|
||||
url="http://www.pytables.org"
|
||||
license=("BSD")
|
||||
makedepends=('lzo' 'hdf5' 'python2-numexpr' 'cython2' 'python-numexpr' 'cython')
|
||||
source=("http://pypi.python.org/packages/source/t/tables/tables-$pkgver.tar.gz"
|
||||
'arm.patch')
|
||||
md5sums=('38d917f0c6dfb0bc28ce9ea0c3492524'
|
||||
'ead28de59a99ef97aceec17cc1a9132d')
|
||||
|
||||
prepare() {
|
||||
cd "$srcdir/tables-$pkgver"
|
||||
#patch -p1 -i ../arm.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd "$srcdir"
|
||||
cp -a tables-$pkgver tables-py2-$pkgver
|
||||
|
||||
msg "Building Python2"
|
||||
cd "$srcdir"/tables-py2-$pkgver
|
||||
python2 setup.py build
|
||||
|
||||
msg "Building Python3"
|
||||
cd "$srcdir"/tables-$pkgver
|
||||
python setup.py build
|
||||
}
|
||||
|
||||
package_python2-pytables() {
|
||||
depends=('lzo' 'hdf5' 'python2-numexpr' 'cython2')
|
||||
|
||||
cd "$srcdir"/tables-py2-${pkgver}
|
||||
python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
|
||||
|
||||
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
|
||||
# see FS#36015
|
||||
mv "$pkgdir"/usr/bin/pt2to3{,-2.7}
|
||||
mv "$pkgdir"/usr/bin/ptdump{,-2.7}
|
||||
mv "$pkgdir"/usr/bin/ptrepack{,-2.7}
|
||||
}
|
||||
|
||||
package_python-pytables() {
|
||||
depends=('lzo' 'hdf5' 'python-numexpr' 'cython')
|
||||
|
||||
cd "$srcdir"/tables-${pkgver}
|
||||
python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
|
||||
|
||||
install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
|
||||
}
|
|
@ -1,13 +0,0 @@
|
|||
diff -urN a/setup.py b/setup.py
|
||||
--- a/setup.py 2014-01-20 05:05:14.000000000 -0700
|
||||
+++ b/setup.py 2014-02-07 06:45:06.632571190 -0700
|
||||
@@ -734,9 +734,6 @@
|
||||
inc_dirs += glob.glob('c-blosc/internal-complibs/*')
|
||||
# ...and the macros for all the compressors supported
|
||||
def_macros += [('HAVE_LZ4', 1), ('HAVE_SNAPPY', 1), ('HAVE_ZLIB', 1)]
|
||||
- # Add -msse2 flag for optimizing shuffle in include Blosc
|
||||
- if os.name == 'posix':
|
||||
- CFLAGS.append("-msse2")
|
||||
else:
|
||||
ADDLIBS += ['blosc']
|
||||
|
Loading…
Reference in a new issue