mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/haproxy to 2.2.0-2
This commit is contained in:
parent
7655714d6a
commit
49fb62395e
2 changed files with 9 additions and 27 deletions
|
@ -1,33 +1,18 @@
|
|||
From 53fd8dbb4ecd3f8bcf4c1f3c0bc7fe39c7be6bd7 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Johannes=20L=C3=B6thberg?= <johannes@kyriasis.com>
|
||||
Date: Wed, 9 Jan 2019 23:37:02 +0100
|
||||
Subject: [PATCH] Use CFLAGS and LDFLAGS when building contrib
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Johannes Löthberg <johannes@kyriasis.com>
|
||||
---
|
||||
contrib/halog/Makefile | 2 +-
|
||||
contrib/ip6range/Makefile | 2 +-
|
||||
contrib/iprange/Makefile | 2 +-
|
||||
3 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/contrib/halog/Makefile b/contrib/halog/Makefile
|
||||
index 5e687c09..2474409a 100644
|
||||
index bf67c1f..e98a3fa 100644
|
||||
--- a/contrib/halog/Makefile
|
||||
+++ b/contrib/halog/Makefile
|
||||
@@ -16,7 +16,7 @@ DEFINE =
|
||||
OBJS = halog
|
||||
|
||||
halog: halog.c fgets2.c
|
||||
- $(CC) $(OPTIMIZE) $(DEFINE) -o $@ $(INCLUDE) $(EBTREE_DIR)/ebtree.c $(EBTREE_DIR)/eb32tree.c $(EBTREE_DIR)/eb64tree.c $(EBTREE_DIR)/ebmbtree.c $(EBTREE_DIR)/ebsttree.c $(EBTREE_DIR)/ebistree.c $(EBTREE_DIR)/ebimtree.c $^
|
||||
+ $(CC) $(OPTIMIZE) $(CFLAGS) $(LDFLAGS) $(DEFINE) -o $@ $(INCLUDE) $(EBTREE_DIR)/ebtree.c $(EBTREE_DIR)/eb32tree.c $(EBTREE_DIR)/eb64tree.c $(EBTREE_DIR)/ebmbtree.c $(EBTREE_DIR)/ebsttree.c $(EBTREE_DIR)/ebistree.c $(EBTREE_DIR)/ebimtree.c $^
|
||||
- $(CC) $(OPTIMIZE) $(DEFINE) -o $@ $(INCLUDE) $(SRC)/ebtree.c $(SRC)/eb32tree.c $(SRC)/eb64tree.c $(SRC)/ebmbtree.c $(SRC)/ebsttree.c $(SRC)/ebistree.c $(SRC)/ebimtree.c $^
|
||||
+ $(CC) $(OPTIMIZE) $(CFLAGS) $(LDFLAGS) $(DEFINE) -o $@ $(INCLUDE) $(SRC)/ebtree.c $(SRC)/eb32tree.c $(SRC)/eb64tree.c $(SRC)/ebmbtree.c $(SRC)/ebsttree.c $(SRC)/ebistree.c $(SRC)/ebimtree.c $^
|
||||
|
||||
clean:
|
||||
rm -f $(OBJS) *.[oas]
|
||||
diff --git a/contrib/ip6range/Makefile b/contrib/ip6range/Makefile
|
||||
index 55849b6d..1276b97d 100644
|
||||
index 55849b6..1276b97 100644
|
||||
--- a/contrib/ip6range/Makefile
|
||||
+++ b/contrib/ip6range/Makefile
|
||||
@@ -7,7 +7,7 @@ OBJS = ip6range
|
||||
|
@ -40,7 +25,7 @@ index 55849b6d..1276b97d 100644
|
|||
clean:
|
||||
rm -f $(OBJS) *.o *.a *~
|
||||
diff --git a/contrib/iprange/Makefile b/contrib/iprange/Makefile
|
||||
index b3c72eda..e92baf3d 100644
|
||||
index b3c72ed..e92baf3 100644
|
||||
--- a/contrib/iprange/Makefile
|
||||
+++ b/contrib/iprange/Makefile
|
||||
@@ -7,7 +7,7 @@ OBJS = iprange
|
||||
|
@ -52,6 +37,3 @@ index b3c72eda..e92baf3d 100644
|
|||
|
||||
clean:
|
||||
rm -f $(OBJS) *.o *.a *~
|
||||
--
|
||||
2.20.1
|
||||
|
||||
|
|
|
@ -5,8 +5,8 @@
|
|||
# - explicitly link v5/v6 with libatomic
|
||||
|
||||
pkgname=haproxy
|
||||
pkgver=2.1.7
|
||||
pkgrel=1
|
||||
pkgver=2.2.0
|
||||
pkgrel=2
|
||||
|
||||
pkgdesc='Reliable, high performance TCP/HTTP load balancer'
|
||||
url='https://www.haproxy.org/'
|
||||
|
@ -25,10 +25,10 @@ source=(https://www.haproxy.org/download/${pkgver%.*}/src/haproxy-$pkgver.tar.gz
|
|||
haproxy.sysusers
|
||||
0001-Use-CFLAGS-and-LDFLAGS-when-building-contrib.patch)
|
||||
|
||||
sha256sums=('392e6cf18e75fe7e166102e8c4512942890a0b5ae738f6064faab4687f60a339'
|
||||
sha256sums=('3c1a87160eea40e067f1e2813bfe692280a10c455beb17a8ee7fae11e4223274'
|
||||
'e88edeb2fe23508565e46ff485c93cfb7c2e9c64f231538452ec7ecd7ec37a42'
|
||||
'b02b4088205039f0979aef0ef3e22957f493dd54eabefaee7011f2d795303b3e'
|
||||
'ba489cec86ea7dae643128825d69fd560a53dd9dc85d0bf4e81f2614aade164e')
|
||||
'81c03ef5d69f4f2ef2c7caa6722c82cda4a53b65f788a46e668ec2faa3abd8f5')
|
||||
|
||||
prepare() {
|
||||
cd haproxy-$pkgver
|
||||
|
|
Loading…
Reference in a new issue