extra/libreoffice-fresh to 6.0.3-2

This commit is contained in:
Kevin Mihelich 2018-04-28 15:01:05 +00:00
parent 3fbf9148ae
commit 4a0e6d3f6f
2 changed files with 71 additions and 1 deletions

View file

@ -21,7 +21,7 @@ pkgbase=libreoffice-fresh
pkgname=('libreoffice-fresh-sdk' 'libreoffice-fresh')
_LOver=6.0.3.2
pkgver=6.0.3
pkgrel=1
pkgrel=2
arch=('x86_64')
license=('LGPL3')
url="http://www.libreoffice.org/"
@ -63,6 +63,7 @@ sha256sums=('12b8a2f57d797ad51b7661e2302babfe73c0d23b52ddac9f4c7eb1b82472859b'
'aa8896eef3adbd6b54d4ec1817c1bc3871cce99120faf26f93502077480233cf'
'eafde646a7dbe46d20c291685b0beac2382174d78d66ee990e229a1bf6e6cec6'
'c463654a73ecfbc242ff109726fb4faecdbfb3d91affafe919b24bea65afb563'
'944064e8f8fa18beeb348468348d910d365d8a3e36ddb76076a368bd9bd6f894'
'76f62957d0058092b11316357d9d716a62b48a53e5277426ffa87429ab5510e4'
'd24cfcb556ae1db02087c49012bbc4621f9ef7e3465ca832e1410326d260f283')
@ -88,6 +89,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
${_additional_source_url2}/odfvalidator-1.2.0-incubating-SNAPSHOT-jar-with-dependencies+ODFTOOLKIT-460+ODFTOOLKIT-461.jar # for test suite
${_additional_source_url2}/185d60944ea767075d27247c3162b3bc-unowinreg.dll
make-pyuno-work-with-system-wide-module-install.diff
poppler-0.64.patch
libreoffice-fresh.sh libreoffice-fresh.csh)
noextract=(boost_1_65_1.tar.bz2
35c94d2df8893241173de1d16b6034c0-swingExSrc.zip
@ -132,6 +134,9 @@ prepare() {
# fix not upstreamable pyuno paths - FS#54250
patch -Np1 -i ${srcdir}/make-pyuno-work-with-system-wide-module-install.diff
# fix build with poppler 0.64
patch -Np1 -i ${srcdir}/poppler-0.64.patch
#use the CFLAGS but remove the LibO overridden ones
for i in $CFLAGS; do
case "$i" in

View file

@ -0,0 +1,65 @@
From 42cebff14f7d486c20f04863681cc5ef4602f4eb Mon Sep 17 00:00:00 2001
From: Rene Engelhard <rene@debian.org>
Date: Tue, 24 Apr 2018 15:56:23 +0200
Subject: [PATCH] fix build with poppler 0.64
GooString became const...
Change-Id: Icc95be2e8603a4e22c6a9ac2008986bacd0bfba5
---
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 10 ++++++++++
sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 ++++
2 files changed, 14 insertions(+)
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
index 48a735ba54a5..06e4faead383 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
@@ -432,6 +432,9 @@ int PDFOutDev::parseFont( long long nNewId, GfxFont* gfxFont, GfxState* state )
FontAttributes aNewFont;
int nSize = 0;
+#if POPPLER_CHECK_VERSION(0, 64, 0)
+ const
+#endif
GooString* pFamily = gfxFont->getName();
if( pFamily )
{
@@ -728,6 +731,9 @@ void PDFOutDev::updateFont(GfxState *state)
FontAttributes aFont;
int nEmbedSize=0;
+#if POPPLER_CHECK_VERSION(0, 64, 0)
+ const
+#endif
Ref* pID = gfxFont->getID();
// TODO(Q3): Portability problem
long long fontID = static_cast<long long>(pID->gen) << 32 | static_cast<long long>(pID->num);
@@ -918,7 +924,11 @@ void PDFOutDev::drawChar(GfxState *state, double x, double y,
printf( "\n" );
}
+#if POPPLER_CHECK_VERSION(0, 64, 0)
+void PDFOutDev::drawString(GfxState*, const GooString* /*s*/)
+#else
void PDFOutDev::drawString(GfxState*, GooString* /*s*/)
+#endif
{
// TODO(F3): NYI
}
diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
index c3367aa6ddf2..7e65f085d288 100644
--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
@@ -224,7 +224,11 @@ namespace pdfi
double dx, double dy,
double originX, double originY,
CharCode code, int nBytes, Unicode *u, int uLen) override;
+#if POPPLER_CHECK_VERSION(0, 64, 0)
+ virtual void drawString(GfxState *state, const GooString *s) override;
+#else
virtual void drawString(GfxState *state, GooString *s) override;
+#endif
virtual void endTextObject(GfxState *state) override;
//----- image drawing