added community/texstudio

This commit is contained in:
Kevin Mihelich 2016-01-06 04:52:11 +00:00
parent 7f345d50eb
commit 4aa65513a3
3 changed files with 91 additions and 0 deletions

View file

@ -0,0 +1,41 @@
# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
# Contributor: Clément DEMOULINS <clement@archivel.fr>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - ARM patch, use NO_CRASH_HANDLER=1 for AArch64
pkgname=texstudio
pkgver=2.10.4
pkgrel=3
pkgdesc="Integrated writing environment for creating LaTeX documents"
arch=('i686' 'x86_64')
url="http://texstudio.sourceforge.net/"
license=('GPL')
depends=('poppler-qt5' 'qt5-svg' 'qt5-script' 'libxkbcommon-x11')
makedepends=('qt5-tools')
optdepends=('evince: pdf reader'
'kdegraphics-okular: alternate pdf reader')
replaces=('texmakerx')
install=$pkgname.install
source=(http://downloads.sourceforge.net/project/texstudio/texstudio/TeXstudio%20${pkgver}/${pkgname}-${pkgver}.tar.gz
texstudio-debughelper-arm-fix.patch)
md5sums=('96b34746e5a2b7b41111cc7ac83d7a92'
'54eba96da2c93980fd9d85f751a56905')
prepare() {
cd "$srcdir/$pkgname$pkgver"
patch -p1 -i ../texstudio-debughelper-arm-fix.patch
}
build() {
cd "$srcdir/$pkgname$pkgver"
[[ $CARCH == "aarch64" ]] && EXTRA="NO_CRASH_HANDLER=1"
qmake-qt5 CONFIG-="debug" $EXTRA texstudio.pro
make
}
package() {
cd "$srcdir/$pkgname$pkgver"
make INSTALL_ROOT="$pkgdir" install
}

View file

@ -0,0 +1,35 @@
From 7f41bb239a89d1e66e954577d03b92373ad4da0e Mon Sep 17 00:00:00 2001
From: hannes <hannes@fedoraproject.org>
Date: Sun, 13 Sep 2015 16:40:51 +0200
Subject: [PATCH 3/3] debughelper arm fix
---
debughelper.cpp | 8 ++------
1 file changed, 2 insertions(+), 6 deletions(-)
diff --git a/debughelper.cpp b/debughelper.cpp
index 4b14ae3..f07c48e 100644
--- a/debughelper.cpp
+++ b/debughelper.cpp
@@ -501,16 +501,12 @@ QString print_backtrace(const QString& message){
#define FRAME_FROM_UCONTEXT(context) (context)->uc_mcontext.gp_regs[31] //not always used
#define RETURNTO_FROM_UCONTEXT(context) (context)->uc_mcontext.gp_regs[34]
#elif defined(CPU_IS_ARM)
-/*
+
#define PC_FROM_UCONTEXT(context) (context)->uc_mcontext.arm_pc
#define STACK_FROM_UCONTEXT(context) (context)->uc_mcontext.arm_sp
#define FRAME_FROM_UCONTEXT(context) (context)->uc_mcontext.arm_fp
#define RETURNTO_FROM_UCONTEXT(context) (context)->uc_mcontext.arm_lr
-*/
-#define PC_FROM_UCONTEXT(context) (context)->uc_mcontext.__gregs[_REG_R15]
-#define STACK_FROM_UCONTEXT(context) (context)->uc_mcontext.__gregs[_REG_R13]
-#define FRAME_FROM_UCONTEXT(context) (context)->uc_mcontext.__gregs[_REG_R11]
-#define RETURNTO_FROM_UCONTEXT(context) (context)->uc_mcontext.__gregs[_REG_R14]
+
#elif defined(CPU_IS_IA64)
#define PC_FROM_UCONTEXT(context) (context)->_u._mc.sc_ip
#define STACK_FROM_UCONTEXT(context) (context)->_u._mc.sc_gr[12] //is that register 12?
--
2.4.3

View file

@ -0,0 +1,15 @@
pkgname=texstudio
post_install() {
update-desktop-database -q
}
post_upgrade() {
post_install "$1"
}
post_remove() {
update-desktop-database -q
}
# vim:set ts=2 sw=2 et: