core/glibc: v5 glibc-ports patch

This commit is contained in:
Kevin Mihelich 2012-05-13 21:13:29 -04:00
parent 143d5c9ed7
commit 4b0291f97d
2 changed files with 19 additions and 0 deletions

View file

@ -7,6 +7,7 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - Added source file for glibc-ports, needed for building on ARM
# - Symlink glibc-ports source dir to ports dir in glibc directory
# - Patch glibc-ports for v5
# - Changed configure to enable ports add-on, specify our build host type
# - Disabled distcc, make -j1 for v5, -j2 for v7
@ -31,6 +32,7 @@ options=('!strip' '!distcc')
install=glibc.install
source=(ftp://ftp.archlinux.org/other/glibc/${pkgname}-${pkgver}_${_glibcdate}.tar.xz
http://ftp.gnu.org/gnu/libc/glibc-ports-2.15.tar.bz2
alarm.patch
glibc-2.15-do-not-install-timezone-files.patch
glibc-2.15-do-not-install-timezone-files-2.patch
glibc-__i686.patch
@ -65,6 +67,7 @@ source=(ftp://ftp.archlinux.org/other/glibc/${pkgname}-${pkgver}_${_glibcdate}.t
locale-gen)
md5sums=('6ffdf5832192b92f98bdd125317c0dfc'
'56efe246ce89f16a52792cea9224823c'
'c45df830828555a85e5b15d46fb0520a'
'349227bcedb19cea008fbcb2c7e1a582'
'880439de2c608177ed1d749722d26820'
'40cd342e21f71f5e49e32622b25acc52'
@ -112,6 +115,7 @@ build() {
# ALARM: Symlink ports dir
ln -s ${srcdir}/${pkgname}-ports-${pkgver} ./ports
[[ $CARCH == "arm" ]] && patch -p1 -i "${srcdir}/alarm.patch"
# timezone data is in separate package (tzdata)
# http://sourceware.org/git/?p=glibc.git;a=commit;h=482ff4da

15
core/glibc/alarm.patch Normal file
View file

@ -0,0 +1,15 @@
diff --git a/sysdeps/arm/Makefile b/sysdeps/arm/Makefile
index 5651161..1a88430 100644
--- a/sysdeps/arm/Makefile
+++ b/sysdeps/arm/Makefile
@@ -7,3 +7,8 @@ endif
ifeq ($(subdir),csu)
gen-as-const-headers += tlsdesc.sym
endif
+
+# to pull in __aeabi_read_tp, needed for tls
+ifeq ($(subdir),malloc)
+$(objpfx)libmemusage.so: $(common-objpfx)libc_nonshared.a
+endif
--
1.7.6.5