mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
added aur/nx-common
This commit is contained in:
parent
5e5fa592b3
commit
4b449965bd
2 changed files with 69 additions and 0 deletions
51
aur/nx-common/PKGBUILD
Normal file
51
aur/nx-common/PKGBUILD
Normal file
|
@ -0,0 +1,51 @@
|
|||
# Maintainer: Miguel Rasero <skuda21@gmail.com>
|
||||
# Contributor: Tobias Powalowski <tpowa@archlinux.org>
|
||||
# Contributed: eliott <eliott@solarblue.net>, Andre Naumann <anaumann@SPARCed.org>
|
||||
|
||||
pkgname=nx-common
|
||||
pkgver=3.5.0
|
||||
pkgrel=6
|
||||
pkgdesc="NoMachine NX common package for client and server"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL')
|
||||
url="http://nomachine.com/"
|
||||
depends=('libjpeg-turbo' 'libpng' 'openssl' 'gcc-libs' 'libxcomp')
|
||||
makedepends=('xorg-server-devel' 'nx-headers')
|
||||
source=(ftp://ftp.uni-duisburg.de/X11/NX/sources/$pkgver/nxcompsh-$pkgver-1.tar.gz
|
||||
ftp://ftp.uni-duisburg.de/X11/NX/sources/$pkgver/nxssh-$pkgver-2.tar.gz
|
||||
nxcompsh-gcc43.patch)
|
||||
options=('!libtool')
|
||||
md5sums=('84ade443b79ea079380b754aba9d392e'
|
||||
'f52fcdb38e09f8dcfb9ff0344dfbbbd6'
|
||||
'3b2436f0090cbe0fa77cde0dfa80a87a')
|
||||
|
||||
build() {
|
||||
# nxcompsh
|
||||
cd ${srcdir}/nxcompsh
|
||||
patch -Np1 -i ${srcdir}/nxcompsh-gcc43.patch
|
||||
./configure --prefix=/usr/lib/nx
|
||||
make
|
||||
|
||||
# nxssh
|
||||
cd ${srcdir}/nxssh
|
||||
sed -i "s:NX.h:nx/NX.h:g" clientloop.c packet.c proxy.c
|
||||
./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
install -dm755 ${pkgdir}/usr/{bin,lib/nx}
|
||||
|
||||
# nxcompsh
|
||||
cd ${srcdir}/nxcompsh
|
||||
cp -a libXcompsh.so* ${pkgdir}/usr/lib/nx
|
||||
cd ${pkgdir}/usr/lib/
|
||||
ln -sv /usr/lib/nx/libXcompsh.so{,.3,.3.5.0} .
|
||||
# ^ really needed?
|
||||
|
||||
# nxssh
|
||||
cd ${srcdir}/nxssh
|
||||
install -D -m755 nxssh ${pkgdir}/usr/lib/nx/bin/nxssh
|
||||
cd ${pkgdir}/usr/bin
|
||||
ln -sv /usr/lib/nx/bin/nxssh .
|
||||
}
|
18
aur/nx-common/nxcompsh-gcc43.patch
Normal file
18
aur/nx-common/nxcompsh-gcc43.patch
Normal file
|
@ -0,0 +1,18 @@
|
|||
--- nxcompsh/Misc.h~ 2007-06-04 13:39:49.000000000 +0200
|
||||
+++ nxcompsh/Misc.h 2008-04-12 12:46:24.000000000 +0200
|
||||
@@ -18,10 +18,12 @@
|
||||
#ifndef Misc_H
|
||||
#define Misc_H
|
||||
|
||||
-#include <iostream.h>
|
||||
+#include <iostream>
|
||||
|
||||
-#include <errno.h>
|
||||
-#include <string.h>
|
||||
+#include <cerrno>
|
||||
+#include <cstring>
|
||||
+
|
||||
+using namespace std;
|
||||
|
||||
//
|
||||
// Error handling macros.
|
Loading…
Reference in a new issue