mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/calligra fix
This commit is contained in:
parent
ce118be1e2
commit
4b57b2789a
2 changed files with 18 additions and 2 deletions
|
@ -6,6 +6,7 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - upstream patch for signed char on ARM
|
||||
# - fedora patch to fix ARM build with GCC 6
|
||||
|
||||
pkgbase=calligra
|
||||
pkgname=('calligra-braindump'
|
||||
|
@ -35,10 +36,12 @@ makedepends=('cmake' 'automoc4' 'boost' 'kdepimlibs4' 'eigen' 'libmarble4'
|
|||
'libetonyek' 'libpqxx' 'libspnav' 'postgresql') # 'libqgit2'
|
||||
groups=('calligra')
|
||||
source=("http://download.kde.org/stable/${pkgbase}-${pkgver}/${pkgbase}-${pkgver}.tar.xz" 'libwps-0.4.patch'
|
||||
'https://github.com/KDE/calligra/commit/956bb80db4f300e4f8edeaf19d24fd61eb1932b2.patch')
|
||||
'https://github.com/KDE/calligra/commit/956bb80db4f300e4f8edeaf19d24fd61eb1932b2.patch'
|
||||
'calligra-2.9.11-gcc6_arm.patch')
|
||||
md5sums=('a1a4935debae64724cd4c0d17d61ae4e'
|
||||
'6ea15f8b3938838d89ea0aa08921afd1'
|
||||
'47305e6e25a076d5761e7b22a65b777e')
|
||||
'47305e6e25a076d5761e7b22a65b777e'
|
||||
'6f40e8f90b21fd1b5fe9d57998fc2b3e')
|
||||
|
||||
prepare() {
|
||||
mkdir -p build
|
||||
|
@ -54,6 +57,7 @@ prepare() {
|
|||
|
||||
# Fix build on ARM
|
||||
patch -p1 -i ../956bb80db4f300e4f8edeaf19d24fd61eb1932b2.patch
|
||||
patch -p1 -i ../calligra-2.9.11-gcc6_arm.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
12
extra/calligra/calligra-2.9.11-gcc6_arm.patch
Normal file
12
extra/calligra/calligra-2.9.11-gcc6_arm.patch
Normal file
|
@ -0,0 +1,12 @@
|
|||
diff -up calligra-2.9.11/libs/flake/KoSnapStrategy.cpp.gcc6_arm calligra-2.9.11/libs/flake/KoSnapStrategy.cpp
|
||||
--- calligra-2.9.11/libs/flake/KoSnapStrategy.cpp.gcc6_arm 2016-02-02 13:53:15.000000000 -0600
|
||||
+++ calligra-2.9.11/libs/flake/KoSnapStrategy.cpp 2016-02-08 09:12:39.452896965 -0600
|
||||
@@ -181,7 +181,7 @@ bool ExtensionSnapStrategy::snap(const Q
|
||||
Q_ASSERT(isfinite(maxSnapDistance));
|
||||
|
||||
const qreal maxDistance = maxSnapDistance * maxSnapDistance;
|
||||
- qreal minDistances[2] = { HUGE_VAL, HUGE_VAL };
|
||||
+ qreal minDistances[2] = { (qreal)HUGE_VAL, (qreal)HUGE_VAL };
|
||||
|
||||
QPointF snappedPoints[2] = { mousePosition, mousePosition };
|
||||
QPointF startPoints[2];
|
Loading…
Reference in a new issue