mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/cairo to 1.15.14-1
This commit is contained in:
parent
b1816042f8
commit
4b694d0bf7
2 changed files with 8 additions and 59 deletions
|
@ -1,4 +1,3 @@
|
||||||
# $Id$
|
|
||||||
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
# Maintainer: Jan de Groot <jgc@archlinux.org>
|
||||||
# Contributor: Brice Carpentier <brice@daknet.org>
|
# Contributor: Brice Carpentier <brice@daknet.org>
|
||||||
|
|
||||||
|
@ -6,7 +5,7 @@
|
||||||
# - drop valgrind makedepend
|
# - drop valgrind makedepend
|
||||||
|
|
||||||
pkgname=cairo
|
pkgname=cairo
|
||||||
pkgver=1.15.12
|
pkgver=1.15.14
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
pkgdesc="2D graphics library with support for multiple output devices"
|
pkgdesc="2D graphics library with support for multiple output devices"
|
||||||
url="https://cairographics.org/"
|
url="https://cairographics.org/"
|
||||||
|
@ -14,11 +13,9 @@ arch=(x86_64)
|
||||||
license=(LGPL MPL)
|
license=(LGPL MPL)
|
||||||
depends=(libpng libxrender libxext fontconfig pixman glib2 lzo)
|
depends=(libpng libxrender libxext fontconfig pixman glib2 lzo)
|
||||||
makedepends=(librsvg gtk2 poppler-glib libspectre gtk-doc git)
|
makedepends=(librsvg gtk2 poppler-glib libspectre gtk-doc git)
|
||||||
_commit=7149686456ec3c481fa1d3dbe76a0dab1e42b519 # tags/1.15.12^0
|
_commit=d9aaea0c1e1484c632e1a6735c6ecc961c4b032b # tags/1.15.14^0
|
||||||
source=("git+https://anongit.freedesktop.org/git/cairo#commit=$_commit"
|
source=("git+https://gitlab.freedesktop.org/cairo/cairo.git#commit=$_commit")
|
||||||
utf-8.diff)
|
sha1sums=('SKIP')
|
||||||
sha1sums=('SKIP'
|
|
||||||
'3f680dea8533bcce4ca2af5d25c546235ef7b339')
|
|
||||||
|
|
||||||
pkgver() {
|
pkgver() {
|
||||||
cd $pkgname
|
cd $pkgname
|
||||||
|
@ -28,12 +25,6 @@ pkgver() {
|
||||||
prepare() {
|
prepare() {
|
||||||
cd $pkgname
|
cd $pkgname
|
||||||
|
|
||||||
# Fixup tag for pkgver()
|
|
||||||
git tag -f 1.15.10 5e6b9aeb5e3402ff17ae8ee8548ae2341c2f7d59
|
|
||||||
|
|
||||||
# Fix non-UTF-8 sources giving gtk-doc trouble
|
|
||||||
patch -Np1 -i ../utf-8.diff
|
|
||||||
|
|
||||||
# Update gtk-doc
|
# Update gtk-doc
|
||||||
cp /usr/share/aclocal/gtk-doc.m4 build/aclocal.gtk-doc.m4
|
cp /usr/share/aclocal/gtk-doc.m4 build/aclocal.gtk-doc.m4
|
||||||
cp /usr/share/gtk-doc/data/gtk-doc.make build/Makefile.am.gtk-doc
|
cp /usr/share/gtk-doc/data/gtk-doc.make build/Makefile.am.gtk-doc
|
||||||
|
@ -54,14 +45,16 @@ build() {
|
||||||
--enable-pdf \
|
--enable-pdf \
|
||||||
--enable-gobject \
|
--enable-gobject \
|
||||||
--enable-gtk-doc
|
--enable-gtk-doc
|
||||||
|
#--enable-full-testing \
|
||||||
|
#--enable-test-surfaces
|
||||||
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
|
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
|
||||||
make
|
make
|
||||||
}
|
}
|
||||||
|
|
||||||
check() {
|
check() {
|
||||||
cd $pkgname
|
cd $pkgname
|
||||||
# https://people.gnome.org/~federico/blog/helping-cairo.html
|
# many tests in cairo-test-suite hang forever
|
||||||
#make check
|
# xvfb-run make check
|
||||||
}
|
}
|
||||||
|
|
||||||
package() {
|
package() {
|
||||||
|
|
|
@ -1,44 +0,0 @@
|
||||||
src/cairo-quartz-image.h | 2 +-
|
|
||||||
src/cairo-quartz.h | 2 +-
|
|
||||||
src/cairo-vg.h | 4 ++--
|
|
||||||
3 files changed, 4 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git c/src/cairo-quartz-image.h i/src/cairo-quartz-image.h
|
|
||||||
index dae234dac..0dd5abb4f 100644
|
|
||||||
--- c/src/cairo-quartz-image.h
|
|
||||||
+++ i/src/cairo-quartz-image.h
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
/* cairo - a vector graphics library with display and print output
|
|
||||||
*
|
|
||||||
- * Copyright © 2008 Mozilla Corporation
|
|
||||||
+ * Copyright © 2008 Mozilla Corporation
|
|
||||||
*
|
|
||||||
* This library is free software; you can redistribute it and/or
|
|
||||||
* modify it either under the terms of the GNU Lesser General Public
|
|
||||||
diff --git c/src/cairo-quartz.h i/src/cairo-quartz.h
|
|
||||||
index 9be5f9ae5..9e11e876f 100644
|
|
||||||
--- c/src/cairo-quartz.h
|
|
||||||
+++ i/src/cairo-quartz.h
|
|
||||||
@@ -1,6 +1,6 @@
|
|
||||||
/* cairo - a vector graphics library with display and print output
|
|
||||||
*
|
|
||||||
- * Copyright © 2006, 2007 Mozilla Corporation
|
|
||||||
+ * Copyright © 2006, 2007 Mozilla Corporation
|
|
||||||
*
|
|
||||||
* This library is free software; you can redistribute it and/or
|
|
||||||
* modify it either under the terms of the GNU Lesser General Public
|
|
||||||
diff --git c/src/cairo-vg.h i/src/cairo-vg.h
|
|
||||||
index f9a62e51c..a2701db3b 100644
|
|
||||||
--- c/src/cairo-vg.h
|
|
||||||
+++ i/src/cairo-vg.h
|
|
||||||
@@ -1,8 +1,8 @@
|
|
||||||
/* -*- Mode: c; tab-width: 8; c-basic-offset: 4; indent-tabs-mode: t; -*- */
|
|
||||||
/* cairo - a vector graphics library with display and print output
|
|
||||||
*
|
|
||||||
- * Copyright © 2007 * Mozilla Corporation
|
|
||||||
- * Copyright © 2009 Chris Wilson
|
|
||||||
+ * Copyright © 2007 * Mozilla Corporation
|
|
||||||
+ * Copyright © 2009 Chris Wilson
|
|
||||||
*
|
|
||||||
* This library is free software; you can redistribute it and/or
|
|
||||||
* modify it either under the terms of the GNU Lesser General Public
|
|
Loading…
Reference in a new issue