mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
added extra/lensfun
This commit is contained in:
parent
d5cfc3b634
commit
4b6ac77068
3 changed files with 56 additions and 0 deletions
32
extra/lensfun/PKGBUILD
Normal file
32
extra/lensfun/PKGBUILD
Normal file
|
@ -0,0 +1,32 @@
|
|||
# $Id: PKGBUILD 162692 2012-06-28 10:33:24Z tpowa $
|
||||
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
|
||||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - disable vectorization, ensure our cflags get used to build
|
||||
|
||||
pkgname=lensfun
|
||||
pkgver=0.2.6
|
||||
pkgrel=1
|
||||
pkgdesc="Database of photographic lenses and a library that allows advanced access to the database"
|
||||
arch=(i686 x86_64)
|
||||
url="http://lensfun.berlios.de/"
|
||||
license=('LGPL3')
|
||||
depends=('glibc' 'glib2')
|
||||
makedepends=('python2' 'libpng' 'doxygen')
|
||||
source=("http://download.berlios.de/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
|
||||
|
||||
build() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
sed -i 's|#!/usr/bin/python|#!/usr/bin/python2|' configure
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib \
|
||||
--vectorization='' --cflags="${CFLAGS}" --cxxflags="${CXXFLAGS}"
|
||||
make all
|
||||
}
|
||||
|
||||
package() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
make INSTALL_PREFIX="$pkgdir" install
|
||||
}
|
||||
md5sums=('740e4749db04da0a597630dd6339b966')
|
13
extra/lensfun/lensfun-0.2.3-as-needed.patch
Normal file
13
extra/lensfun/lensfun-0.2.3-as-needed.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff -ru lensfun-0.2.3.orig/build/mak/compiler/gcc.mak lensfun-0.2.3/build/mak/compiler/gcc.mak
|
||||
--- lensfun-0.2.3.orig/build/mak/compiler/gcc.mak 2009-03-15 02:42:40.000000000 +0100
|
||||
+++ lensfun-0.2.3/build/mak/compiler/gcc.mak 2009-03-15 02:43:37.000000000 +0100
|
||||
@@ -71,7 +71,7 @@
|
||||
endef
|
||||
|
||||
LINK.GCC.AR = $(GCC.AR) $(GCC.ARFLAGS) $@ $^
|
||||
-LINK.GCC.EXEC = $(GCC.LD) -o $@ $(GCC.LDFLAGS) $(LDFLAGS) $1 $^ $(GCC.LDFLAGS.LIBS) $(LDFLAGS.LIBS) $2
|
||||
+LINK.GCC.EXEC = $(GCC.LD) $(LDFLAGS) $^ $2 $(GCC.LDFLAGS.LIBS) $(LDFLAGS.LIBS) $(GCC.LDFLAGS) $1 -o $@
|
||||
define LINK.GCC.SO
|
||||
$(GCC.LD) -o $@.$(SHARED.$3) -Wl,"-soname=$(notdir $@).$(basename $(basename $(SHARED.$3)))" $(GCC.LDFLAGS.SHARED) $(GCC.LDFLAGS) $(LDFLAGS) $1 $^ $(GCC.LDFLAGS.LIBS) $(LDFLAGS.LIBS) $2
|
||||
ln -fs $(notdir $@.$(SHARED.$3)) $@.$(basename $(basename $(SHARED.$3)))
|
||||
Only in lensfun-0.2.3/out/posix/release: deps
|
11
extra/lensfun/lensfun-0.2.3-glibc-2.10.patch
Normal file
11
extra/lensfun/lensfun-0.2.3-glibc-2.10.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- lensfun-0.2.3.orig/tools/makedep/cppsetup.cpp 2009-07-04 21:20:49.000000000 +0200
|
||||
+++ lensfun-0.2.3/tools/makedep/cppsetup.cpp 2009-07-04 22:19:18.000000000 +0200
|
||||
@@ -195,7 +195,7 @@
|
||||
}
|
||||
while (s);
|
||||
|
||||
- eol = strchr (var, 0);
|
||||
+ eol = (char *)strchr (var, 0);
|
||||
|
||||
// Skip parentheses which Microsoft likes so much
|
||||
if (*var == '(')
|
Loading…
Reference in a new issue