mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-18 22:54:00 +00:00
extra/libvpx to 1.8.0-1
This commit is contained in:
parent
e1292f60ea
commit
4b6ef910de
2 changed files with 33 additions and 35 deletions
|
@ -1,4 +1,4 @@
|
|||
From 7d11fe597a30e4b65b6915b9a275f0da5b655537 Mon Sep 17 00:00:00 2001
|
||||
From 2cc3f6718e1ca9a16007b944032137891b64b51d Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 15 Jan 2017 12:11:57 -0700
|
||||
Subject: [PATCH] ARM fixes
|
||||
|
@ -9,10 +9,10 @@ Subject: [PATCH] ARM fixes
|
|||
2 files changed, 13 insertions(+), 10 deletions(-)
|
||||
|
||||
diff --git a/build/make/configure.sh b/build/make/configure.sh
|
||||
index 683b43037..ee160d17a 100644
|
||||
index 00214c9d2e..865c338265 100644
|
||||
--- a/build/make/configure.sh
|
||||
+++ b/build/make/configure.sh
|
||||
@@ -696,6 +696,14 @@ process_common_toolchain() {
|
||||
@@ -740,6 +740,14 @@ process_common_toolchain() {
|
||||
aarch64*)
|
||||
tgt_isa=arm64
|
||||
;;
|
||||
|
@ -27,7 +27,7 @@ index 683b43037..ee160d17a 100644
|
|||
armv7*-hardfloat* | armv7*-gnueabihf | arm-*-gnueabihf)
|
||||
tgt_isa=armv7
|
||||
float_abi=hard
|
||||
@@ -915,7 +923,7 @@ process_common_toolchain() {
|
||||
@@ -964,7 +972,7 @@ process_common_toolchain() {
|
||||
soft_enable neon
|
||||
;;
|
||||
armv7|armv7s)
|
||||
|
@ -36,8 +36,8 @@ index 683b43037..ee160d17a 100644
|
|||
# Only enable neon_asm when neon is also enabled.
|
||||
enabled neon && soft_enable neon_asm
|
||||
# If someone tries to force it through, die.
|
||||
@@ -936,13 +944,6 @@ process_common_toolchain() {
|
||||
check_add_asflags --defsym ARCHITECTURE=${arch_int}
|
||||
@@ -984,13 +992,6 @@ process_common_toolchain() {
|
||||
arch_int=${arch_int%%te}
|
||||
tune_cflags="-mtune="
|
||||
if [ ${tgt_isa} = "armv7" ] || [ ${tgt_isa} = "armv7s" ]; then
|
||||
- if [ -z "${float_abi}" ]; then
|
||||
|
@ -50,7 +50,7 @@ index 683b43037..ee160d17a 100644
|
|||
check_add_cflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
check_add_asflags -march=armv7-a -mfloat-abi=${float_abi}
|
||||
|
||||
@@ -954,8 +955,8 @@ EOF
|
||||
@@ -1002,8 +1003,8 @@ EOF
|
||||
check_add_cflags -march=armv8-a
|
||||
check_add_asflags -march=armv8-a
|
||||
else
|
||||
|
@ -62,18 +62,18 @@ index 683b43037..ee160d17a 100644
|
|||
|
||||
enabled debug && add_asflags -g
|
||||
diff --git a/configure b/configure
|
||||
index e5a74c6f2..07a7e155e 100755
|
||||
index 6204f10b6c..009fe8cbbe 100755
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -101,6 +101,8 @@ EOF
|
||||
all_platforms="${all_platforms} arm64-android-gcc"
|
||||
all_platforms="${all_platforms} arm64-darwin-gcc"
|
||||
@@ -103,6 +103,8 @@ all_platforms="${all_platforms} arm64-darwin-gcc"
|
||||
all_platforms="${all_platforms} arm64-linux-gcc"
|
||||
all_platforms="${all_platforms} arm64-win64-gcc"
|
||||
all_platforms="${all_platforms} arm64-win64-vs15"
|
||||
+all_platforms="${all_platforms} armv5te-linux-gcc"
|
||||
+all_platforms="${all_platforms} armv6-linux-gcc"
|
||||
all_platforms="${all_platforms} armv7-android-gcc" #neon Cortex-A8
|
||||
all_platforms="${all_platforms} armv7-darwin-gcc" #neon Cortex-A8
|
||||
all_platforms="${all_platforms} armv7-linux-rvct" #neon Cortex-A8
|
||||
--
|
||||
2.14.1
|
||||
2.21.0
|
||||
|
||||
|
|
|
@ -1,4 +1,3 @@
|
|||
# $Id$
|
||||
# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
|
||||
# Contributor: Ionut Biru <ibiru@archlinux.org>
|
||||
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
|
||||
|
@ -8,52 +7,51 @@
|
|||
# - disable neon and neon-asm
|
||||
|
||||
pkgname=libvpx
|
||||
pkgver=1.7.0
|
||||
pkgver=1.8.0
|
||||
pkgrel=1
|
||||
pkgdesc='VP8 and VP9 codec'
|
||||
arch=('x86_64')
|
||||
url='http://www.webmproject.org/'
|
||||
license=('BSD')
|
||||
depends=('glibc' 'gcc-libs')
|
||||
makedepends=('yasm' 'git')
|
||||
provides=('libvpx.so')
|
||||
source=("libvpx-${pkgver}.tar.gz::https://github.com/webmproject/libvpx/archive/v${pkgver}.tar.gz"
|
||||
arch=(x86_64)
|
||||
url=http://www.webmproject.org/
|
||||
license=(BSD)
|
||||
makedepends=(
|
||||
git
|
||||
nasm
|
||||
)
|
||||
provides=(libvpx.so)
|
||||
source=(git+https://chromium.googlesource.com/webm/libvpx#tag=v${pkgver}
|
||||
0001-ARM-fixes.patch)
|
||||
sha256sums=('1fec931eb5c94279ad219a5b6e0202358e94a93a90cfb1603578c326abfc1238'
|
||||
'5e1be5248079a37d1ddf3e20954fde6e8b0182030bbcec87f9064aba6f1d3875')
|
||||
sha256sums=('SKIP'
|
||||
'c3961bd173bde825221e766bb86d87de126b2e66d5c7b922935e5afcfcc40e62')
|
||||
|
||||
prepare() {
|
||||
cd libvpx-${pkgver}
|
||||
cd libvpx
|
||||
|
||||
patch -p1 -i ../0001-ARM-fixes.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
cd libvpx-${pkgver}
|
||||
cd libvpx
|
||||
|
||||
[[ $CARCH != "aarch64" ]] && CONFIG="--disable-neon --disable-neon-asm"
|
||||
./configure \
|
||||
--prefix='/usr' \
|
||||
--enable-runtime-cpu-detect \
|
||||
--enable-shared \
|
||||
--enable-pic \
|
||||
--disable-install-docs \
|
||||
--disable-install-srcs \
|
||||
--enable-vp8 \
|
||||
--enable-pic \
|
||||
--enable-postproc \
|
||||
--enable-runtime-cpu-detect \
|
||||
--enable-shared \
|
||||
--enable-vp8 \
|
||||
--enable-vp9 \
|
||||
--enable-vp9-highbitdepth \
|
||||
--enable-experimental \
|
||||
--enable-spatial-svc \
|
||||
--disable-neon --disable-neon-asm
|
||||
|
||||
--enable-vp9-temporal-denoising $CONFIG
|
||||
make
|
||||
}
|
||||
|
||||
package() {
|
||||
cd libvpx-${pkgver}
|
||||
cd libvpx
|
||||
|
||||
make DIST_DIR="${pkgdir}"/usr install
|
||||
|
||||
install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/libvpx/
|
||||
}
|
||||
|
||||
|
|
Loading…
Reference in a new issue