mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
core/linux-odroid to 3.8.13.30-4
This commit is contained in:
parent
bb1311e643
commit
4bc888ce63
7 changed files with 23 additions and 80 deletions
|
@ -8,35 +8,32 @@ pkgname=('linux-odroid-x' 'linux-odroid-x2' 'linux-odroid-u2' 'linux-headers-odr
|
|||
_kernelname=${pkgname#linux}
|
||||
_basekernel=3.8
|
||||
pkgver=${_basekernel}.13.30
|
||||
pkgrel=3
|
||||
pkgrel=4
|
||||
arch=('armv7h')
|
||||
url="http://github.com/hardkernel/linux/"
|
||||
license=('GPL2')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'kmod' 'git' 'inetutils' 'bc')
|
||||
options=('!strip')
|
||||
_commit=1130f8761789bfe79de0db2b7f5013ff3eb1f978
|
||||
_commit=ddfddf829693c6bb739074e1b14e9e4fa1c55ea8
|
||||
source=("https://github.com/hardkernel/linux/archive/${_commit}.tar.gz"
|
||||
'add-gcc5-support.patch'
|
||||
'gcc5-use-std89.patch'
|
||||
'add-gcc6-support.patch'
|
||||
'rtl8812_to_v4_3_14_and_enable_rtl8821.patch.xz'
|
||||
'kernel-CVE-2016-0728.patch'
|
||||
'config_x'
|
||||
'config_x2'
|
||||
'config_u2')
|
||||
md5sums=('9eec4534016d3bd8dc6fb372ec7ab574'
|
||||
'2873a50f4311434fd07d7d52bccaade7'
|
||||
'407619b134dd00b453ebba9f23dcabf5'
|
||||
md5sums=('e4ff4cbd8bd2145ba26e085de665d806'
|
||||
'840a69592300bf7cbc3ad317e8100114'
|
||||
'c6d56cc8134dd25d97d0416ef98a3dfe'
|
||||
'6470e9783bd1c7a8feddc2d67f07afd5'
|
||||
'98decab218ac0e376f2bd9b435f5634e'
|
||||
'28e8fe0251cecf2e05798f2ac4cce06a'
|
||||
'67abbc5dd3f81a03012230423618ec1e')
|
||||
'f54b9fa32d672116c73e6e3c9585929f'
|
||||
'1211492fdd1125c68d03d0a1f8d6c498'
|
||||
'13011519e5c36655bdb5315178c5c1fe')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/linux-${_commit}"
|
||||
|
||||
patch -Np1 -i ${srcdir}/add-gcc5-support.patch
|
||||
patch -Np1 -i ${srcdir}/gcc5-use-std89.patch
|
||||
patch -Np1 -i ${srcdir}/add-gcc6-support.patch
|
||||
patch -p1 -i ${srcdir}/rtl8812_to_v4_3_14_and_enable_rtl8821.patch
|
||||
patch -p1 -i ${srcdir}/kernel-CVE-2016-0728.patch
|
||||
|
||||
|
|
|
@ -1,26 +1,5 @@
|
|||
commit 71458cfc782eafe4b27656e078d379a34e472adf upstream.
|
||||
|
||||
We're missing include/linux/compiler-gcc5.h which is required now
|
||||
because gcc branched off to v5 in trunk.
|
||||
|
||||
Just copy the relevant bits out of include/linux/compiler-gcc4.h,
|
||||
no new code is added as of now.
|
||||
|
||||
This fixes a build error when using gcc 5.
|
||||
|
||||
Signed-off-by: Sasha Levin <sasha.levin@oracle.com>
|
||||
Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
|
||||
Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
|
||||
Signed-off-by: Zefan Li <lizefan@huawei.com>
|
||||
---
|
||||
include/linux/compiler-gcc5.h | 66 +++++++++++++++++++++++++++++++++++++++++++
|
||||
1 file changed, 66 insertions(+)
|
||||
create mode 100644 include/linux/compiler-gcc5.h
|
||||
diff --git a/include/linux/compiler-gcc5.h b/include/linux/compiler-gcc5.h
|
||||
new file mode 100644
|
||||
index 0000000..cdd1cc2
|
||||
--- /dev/null
|
||||
+++ b/include/linux/compiler-gcc5.h
|
||||
+++ b/include/linux/compiler-gcc6.h
|
||||
@@ -0,0 +1,66 @@
|
||||
+#ifndef __LINUX_COMPILER_H
|
||||
+#error "Please don't include <linux/compiler-gcc5.h> directly, include <linux/compiler.h> instead."
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 3.8.13.30-1 Kernel Configuration
|
||||
# Linux/arm 3.8.13.30-4 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
|
||||
|
@ -187,6 +187,7 @@ CONFIG_HAVE_HW_BREAKPOINT=y
|
|||
CONFIG_HAVE_ARCH_JUMP_LABEL=y
|
||||
CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
|
||||
CONFIG_HAVE_ARCH_SECCOMP_FILTER=y
|
||||
CONFIG_SECCOMP_FILTER=y
|
||||
CONFIG_HAVE_MOD_ARCH_SPECIFIC=y
|
||||
CONFIG_MODULES_USE_ELF_REL=y
|
||||
CONFIG_CLONE_BACKWARDS=y
|
||||
|
@ -548,7 +549,7 @@ CONFIG_MIGRATION=y
|
|||
CONFIG_ZONE_DMA_FLAG=0
|
||||
CONFIG_BOUNCE=y
|
||||
CONFIG_VIRT_TO_BUS=y
|
||||
# CONFIG_KSM is not set
|
||||
CONFIG_KSM=y
|
||||
CONFIG_DEFAULT_MMAP_MIN_ADDR=4096
|
||||
CONFIG_CROSS_MEMORY_ATTACH=y
|
||||
# CONFIG_CLEANCACHE is not set
|
||||
|
@ -556,7 +557,7 @@ CONFIG_CROSS_MEMORY_ATTACH=y
|
|||
CONFIG_FORCE_MAX_ZONEORDER=11
|
||||
CONFIG_ALIGNMENT_TRAP=y
|
||||
# CONFIG_UACCESS_WITH_MEMCPY is not set
|
||||
# CONFIG_SECCOMP is not set
|
||||
CONFIG_SECCOMP=y
|
||||
# CONFIG_CC_STACKPROTECTOR is not set
|
||||
|
||||
#
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 3.8.13.30-1 Kernel Configuration
|
||||
# Linux/arm 3.8.13.30-4 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
|
||||
|
@ -187,6 +187,7 @@ CONFIG_HAVE_HW_BREAKPOINT=y
|
|||
CONFIG_HAVE_ARCH_JUMP_LABEL=y
|
||||
CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
|
||||
CONFIG_HAVE_ARCH_SECCOMP_FILTER=y
|
||||
CONFIG_SECCOMP_FILTER=y
|
||||
CONFIG_HAVE_MOD_ARCH_SPECIFIC=y
|
||||
CONFIG_MODULES_USE_ELF_REL=y
|
||||
CONFIG_CLONE_BACKWARDS=y
|
||||
|
@ -548,7 +549,7 @@ CONFIG_MIGRATION=y
|
|||
CONFIG_ZONE_DMA_FLAG=0
|
||||
CONFIG_BOUNCE=y
|
||||
CONFIG_VIRT_TO_BUS=y
|
||||
# CONFIG_KSM is not set
|
||||
CONFIG_KSM=y
|
||||
CONFIG_DEFAULT_MMAP_MIN_ADDR=4096
|
||||
CONFIG_CROSS_MEMORY_ATTACH=y
|
||||
# CONFIG_CLEANCACHE is not set
|
||||
|
@ -556,7 +557,7 @@ CONFIG_CROSS_MEMORY_ATTACH=y
|
|||
CONFIG_FORCE_MAX_ZONEORDER=11
|
||||
CONFIG_ALIGNMENT_TRAP=y
|
||||
# CONFIG_UACCESS_WITH_MEMCPY is not set
|
||||
# CONFIG_SECCOMP is not set
|
||||
CONFIG_SECCOMP=y
|
||||
# CONFIG_CC_STACKPROTECTOR is not set
|
||||
|
||||
#
|
||||
|
|
|
@ -1,6 +1,6 @@
|
|||
#
|
||||
# Automatically generated file; DO NOT EDIT.
|
||||
# Linux/arm 3.8.13.30-1 Kernel Configuration
|
||||
# Linux/arm 3.8.13.30-4 Kernel Configuration
|
||||
#
|
||||
CONFIG_ARM=y
|
||||
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
|
||||
|
@ -187,6 +187,7 @@ CONFIG_HAVE_HW_BREAKPOINT=y
|
|||
CONFIG_HAVE_ARCH_JUMP_LABEL=y
|
||||
CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
|
||||
CONFIG_HAVE_ARCH_SECCOMP_FILTER=y
|
||||
CONFIG_SECCOMP_FILTER=y
|
||||
CONFIG_HAVE_MOD_ARCH_SPECIFIC=y
|
||||
CONFIG_MODULES_USE_ELF_REL=y
|
||||
CONFIG_CLONE_BACKWARDS=y
|
||||
|
@ -548,7 +549,7 @@ CONFIG_MIGRATION=y
|
|||
CONFIG_ZONE_DMA_FLAG=0
|
||||
CONFIG_BOUNCE=y
|
||||
CONFIG_VIRT_TO_BUS=y
|
||||
# CONFIG_KSM is not set
|
||||
CONFIG_KSM=y
|
||||
CONFIG_DEFAULT_MMAP_MIN_ADDR=4096
|
||||
CONFIG_CROSS_MEMORY_ATTACH=y
|
||||
# CONFIG_CLEANCACHE is not set
|
||||
|
@ -556,7 +557,7 @@ CONFIG_CROSS_MEMORY_ATTACH=y
|
|||
CONFIG_FORCE_MAX_ZONEORDER=11
|
||||
CONFIG_ALIGNMENT_TRAP=y
|
||||
# CONFIG_UACCESS_WITH_MEMCPY is not set
|
||||
# CONFIG_SECCOMP is not set
|
||||
CONFIG_SECCOMP=y
|
||||
# CONFIG_CC_STACKPROTECTOR is not set
|
||||
|
||||
#
|
||||
|
|
|
@ -1,36 +0,0 @@
|
|||
|
||||
Signed-off-by: Sasha Levin <sasha.levin at oracle.com>
|
||||
Singed-off-by: Kirill A. Shutemov <kirill.shutemov at linux.intel.com>
|
||||
Signed-off-by: Linus Torvalds <torvalds at linux-foundation.org>
|
||||
[ kamal: backport to 3.13-stable: context ]
|
||||
Signed-off-by: Kamal Mostafa <kamal at canonical.com>
|
||||
---
|
||||
Makefile | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 1b0c93c..6f16559 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -244,7 +244,7 @@ CONFIG_SHELL := $(shell if [ -x "$$BASH" ]; then echo $$BASH; \
|
||||
|
||||
HOSTCC = gcc
|
||||
HOSTCXX = g++
|
||||
-HOSTCFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer
|
||||
+HOSTCFLAGS = -Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer -std=gnu89
|
||||
HOSTCXXFLAGS = -O2
|
||||
|
||||
# Decide whether to build built-in, modular, or both.
|
||||
@@ -376,7 +376,9 @@ KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
|
||||
-fno-strict-aliasing -fno-common \
|
||||
-Werror-implicit-function-declaration \
|
||||
-Wno-format-security \
|
||||
- -fno-delete-null-pointer-checks
|
||||
+ -fno-delete-null-pointer-checks \
|
||||
+ -std=gnu89
|
||||
+
|
||||
KBUILD_AFLAGS_KERNEL :=
|
||||
KBUILD_CFLAGS_KERNEL :=
|
||||
KBUILD_AFLAGS := -D__ASSEMBLY__
|
||||
--
|
||||
1.9.1
|
|
@ -1,7 +1,7 @@
|
|||
# arg 1: the new package version
|
||||
# arg 2: the old package versio
|
||||
|
||||
KERNEL_VERSION=3.8.13.30-2-ARCH
|
||||
KERNEL_VERSION=3.8.13.30-4-ARCH
|
||||
|
||||
post_install () {
|
||||
# updating module dependencies
|
||||
|
|
Loading…
Reference in a new issue