alarm/kodi-rbp to 17.4-1 (#1506)

This commit is contained in:
graysky 2017-08-24 21:09:46 -04:00 committed by Kevin Mihelich
parent 0fdee4302d
commit 4bda6c5d5f
2 changed files with 13 additions and 84 deletions

View file

@ -12,8 +12,8 @@ _prefix=/usr
pkgbase=kodi-rbp
pkgname=('kodi-rbp' 'kodi-rbp-eventclients' 'kodi-rbp-tools-texturepacker' 'kodi-rbp-dev')
_codename=Krypton
pkgver=17.3
pkgrel=4
pkgver=17.4
pkgrel=1
arch=('armv6h' 'armv7h')
url="http://kodi.tv"
license=('GPL2')
@ -23,28 +23,28 @@ makedepends=('hicolor-icon-theme' 'fribidi' 'lzo' 'smbclient' 'libtiff' 'libva'
'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'unzip' 'xorg-xdpyinfo' 'libbluray'
'libnfs' 'afpfs-ng' 'avahi' 'bluez-libs' 'tinyxml' 'raspberrypi-firmware' 'libcec-rpi'
'libplist' 'swig' 'taglib' 'libxslt' 'shairplay' 'boost' 'cmake' 'gperf' 'nasm' 'zip'
'upower' 'autoconf' 'java-environment' 'libcrossguid-git' 'dcadec' 'libpulse' 'cwiid')
'upower' 'autoconf' 'java-environment' 'dcadec' 'libpulse' 'cwiid')
source=("https://github.com/xbmc/xbmc/archive/$pkgver-$_codename.tar.gz"
'kodi.service'
'99-kodi.rules'
'https://github.com/popcornmix/xbmc/commit/0c320b6cdd4fb409be45008e6b9042463d54b742.patch'
'https://github.com/popcornmix/xbmc/commit/4d983105d7fd65b1d92f2ae2602e6e1cdcaddbe0.patch'
'polkit.rules'
'fix-ftpparse.patch'
'hifiberry_digi.patch'
'fix-python-lib-path.patch')
sha256sums=('1de8653a3729cefd1baaf09ecde5ace01a1e3a58fbf29d48c1363f2503d331a1'
sha256sums=('b05e11b2d108222bfc3ff0c9a466d798c0feedf1228166239948e6ed37c3cb4f'
'5235068d5800d69f0287087815990e7fe8d6572733d60c8800546d35f608e87f'
'b31570f95654434b01fd8531612fbb6be77cbc1c519dd60f92feae26eb160f3d'
'6f23df9cf214502f0a446edf07b18ce1855e549cabb1cd94ac9180770ba48ee4'
'82057eccc4cadbd568dda76103dcc667754194e926ede78e43d70b3a17bbb5e5'
'9ea592205023ba861603d74b63cdb73126c56372a366dc4cb7beb379073cbb96'
'1665f33f608f85b786393fc52667ed4f151dacbaf2a195df4ed9ab9f09a517f7'
'0b9d951911a8576c26dec8a31f394282677e48afff49b9579448121d27b8509e'
'1c07c9fdd8e2958262cf917e4266c4933fcd06529c111e3cb0cbaaa05c934033')
prepare() {
cd "$srcdir/xbmc-$pkgver-$_codename"
# python2 path fix
patch -p1 -i "$srcdir/fix-python-lib-path.patch"
# ffmpeg: Automatic switch to software decode for GMC with more than one warp point
patch -Np1 -i "$srcdir/0c320b6cdd4fb409be45008e6b9042463d54b742.patch"
@ -52,10 +52,6 @@ prepare() {
patch -Np1 -i "$srcdir/4d983105d7fd65b1d92f2ae2602e6e1cdcaddbe0.patch"
# fix for lack of passthrough audio with hifiberry-digi+ card
patch -Np1 -i "$srcdir/hifiberry_digi.patch"
#
patch -p1 -i "$srcdir/fix-python-lib-path.patch"
#
patch -p1 -i "$srcdir/fix-ftpparse.patch"
[[ -d kodi-build ]] && rm -rf kodi-build
mkdir $srcdir/kodi-build
@ -67,10 +63,14 @@ build() {
# -DCPU=arm1176jzf-s for rpi1
# -DCPU=cortex-a7 for rpi2
# -DCPU=cortex-a53 for rpi3
[[ $CARCH == "armv6h" ]] && _CPU=arm1176jzf-s && LDFLAGS+=" -latomic"
[[ $CARCH == "armv7h" ]] && _CPU=cortex-a7
# needed to avoid bad value on build/lib/libcrossguid.a
CFLAGS+=" -fPIC"
CXXFLAGS+=" -fPIC"
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DCMAKE_PREFIX_PATH=/opt/vc \
@ -81,6 +81,7 @@ build() {
-DENABLE_X11=OFF \
-DENABLE_VAAPI=OFF \
-DENABLE_VDPAU=OFF \
-DENABLE_INTERNAL_CROSSGUID=ON \
-DLIRC_DEVICE=/run/lirc/lircd \
../"xbmc-$pkgver-$_codename"/project/cmake
@ -95,7 +96,7 @@ package_kodi-rbp() {
'sdl_image' 'python2' 'python2-pillow' 'python2-pybluez' 'python2-simplejson' 'libass'
'libmpeg2' 'libmad' 'libmodplug' 'jasper' 'rtmpdump' 'xorg-xdpyinfo' 'libbluray'
'avahi' 'bluez-libs' 'tinyxml' 'raspberrypi-firmware' 'libpulse'
'libplist' 'swig' 'taglib' 'libxslt' 'libcrossguid-git')
'libplist' 'swig' 'taglib' 'libxslt')
optdepends=(
'afpfs-ng: Apple airplay and AFP share support'
'libcec-rpi: Pulse-Eight USB-CEC adapter support'
@ -166,7 +167,6 @@ package_kodi-rbp-eventclients() {
package_kodi-rbp-tools-texturepacker() {
pkgdesc="Kodi texturepacker tool (Raspberry Pi)"
depends=('libpng' 'giflib' 'libjpeg-turbo' 'lzo')
_components=('kodi-tools-texturepacker')
cd kodi-build

View file

@ -1,71 +0,0 @@
--- a/xbmc/filesystem/FTPParse.cpp 2017-05-24 22:49:32.000000000 +0200
+++ b/xbmc/filesystem/FTPParse.cpp 2017-07-15 14:15:54.908823456 +0200
@@ -34,7 +34,7 @@
m_time = 0;
}
-string CFTPParse::getName()
+std::string CFTPParse::getName()
{
return m_name;
}
@@ -59,16 +59,16 @@
return m_time;
}
-void CFTPParse::setTime(string str)
+void CFTPParse::setTime(std::string str)
{
/* Variables used to capture patterns via the regexes */
- string month;
- string day;
- string year;
- string hour;
- string minute;
- string second;
- string am_or_pm;
+ std::string month;
+ std::string day;
+ std::string year;
+ std::string hour;
+ std::string minute;
+ std::string second;
+ std::string am_or_pm;
/* time struct used to set the time_t variable */
struct tm time_struct = {};
@@ -338,21 +338,21 @@
return day_of_week;
}
-int CFTPParse::FTPParse(string str)
+int CFTPParse::FTPParse(std::string str)
{
/* Various variable to capture patterns via the regexes */
- string permissions;
- string link_count;
- string owner;
- string group;
- string size;
- string date;
- string name;
- string type;
- string stuff;
- string facts;
- string version;
- string file_id;
+ std::string permissions;
+ std::string link_count;
+ std::string owner;
+ std::string group;
+ std::string size;
+ std::string date;
+ std::string name;
+ std::string type;
+ std::string stuff;
+ std::string facts;
+ std::string version;
+ std::string file_id;
/* Regex for standard Unix listing formats */
pcrecpp::RE unix_re("^([-bcdlps])" // type