mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/rust to 1.80.0-1
This commit is contained in:
parent
1558e2efb6
commit
4c14f4010c
5 changed files with 28 additions and 25 deletions
|
@ -1,7 +1,7 @@
|
|||
pkgbase = rust
|
||||
pkgdesc = Systems programming language focused on safety, speed and concurrency
|
||||
pkgver = 1.79.0
|
||||
pkgrel = 3
|
||||
pkgver = 1.80.0
|
||||
pkgrel = 1
|
||||
epoch = 1
|
||||
url = https://www.rust-lang.org/
|
||||
arch = x86_64
|
||||
|
@ -21,6 +21,7 @@ pkgbase = rust
|
|||
makedepends = python
|
||||
makedepends = rust
|
||||
makedepends = wasi-libc
|
||||
makedepends = wasm-component-ld
|
||||
depends = bash
|
||||
depends = curl
|
||||
depends = gcc
|
||||
|
@ -32,18 +33,18 @@ pkgbase = rust
|
|||
depends = zlib
|
||||
options = !emptydirs
|
||||
options = !lto
|
||||
source = https://static.rust-lang.org/dist/rustc-1.79.0-src.tar.gz
|
||||
source = https://static.rust-lang.org/dist/rustc-1.79.0-src.tar.gz.asc
|
||||
source = https://static.rust-lang.org/dist/rustc-1.80.0-src.tar.gz
|
||||
source = https://static.rust-lang.org/dist/rustc-1.80.0-src.tar.gz.asc
|
||||
source = 0001-bootstrap-Change-libexec-dir.patch
|
||||
source = 0002-bootstrap-Change-bash-completion-dir.patch
|
||||
source = 0003-compiler-Change-LLVM-targets.patch
|
||||
source = 0004-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||
validpgpkeys = 108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE
|
||||
b2sums = 07fbb29007921cffa6fc11a928d64a43c93c14cd421aee77cf44b7ee71a67c67d9f7454f5d1b85f2d79f50dcc7048a356f4f3971ba87ebad21f53321c51808ca
|
||||
b2sums = 759e86509b4a5516fb98971614e3ab7a54d08970b120f1fee54250316e1e2569c1dc53e09ff11cb1fad5a73ede5ba7fdbae384656d3db2119849935d68bfbde8
|
||||
b2sums = SKIP
|
||||
b2sums = c1cf64e26d240fbacbe2170ad4a114e09deb8230c8c7934415c7b9cb32eb30f708694265b34f281f466c8d8ec7841bfa4895da877d2ca87a3a953a7faa40de80
|
||||
b2sums = 093cf81b7c5be5ef8421b4a31a56b5b28d3ecfcb2e952bfea379683f31a237142afdd1c2e45a67e29a11e8e915e80671249fdc2b5760e58702234e5b339abf4e
|
||||
b2sums = c81eb7e5f4dd8225701aa379381bd377be2348f42f778e67b77118f68e92ac1fe60aab692fbcd61a02af900f9e017ea05adc7bb508ef6297dd096585e0571e5e
|
||||
b2sums = ba3444d558b9428231fd33156fc231b34dc445813c2c849106f0db0a519c26eb8b8f7f2b8b13e9a303949c50611d95b0ffaf4d0bdc7fde640337d04602b03312
|
||||
b2sums = b582b6bf142ad574e489d3aec1d8b317b014921fc7d8e28a496576ec08535a595a10491198dd04144bf266cb09cbd6427e313d734f65b04658ca7755051a0997
|
||||
b2sums = 32be97e6fefb20f3d1f16834d3522e22a79e3928e99817418e1f4599d2b5432a9f2d3c09e962c180bb0146d8725949bae24a0dffa7e5bd948a72ffb92d7ca22f
|
||||
b2sums = 963aa64d27763f063b9fac483a870563f5a71a49ec02d17b7ca0c14dbf67064ba56028bbc45f2ee50b16eada725cb55c2aa2ab17ceadff65ba9e40cb220f7a0c
|
||||
|
||||
pkgname = rust
|
||||
|
@ -76,6 +77,7 @@ pkgname = rust-wasm
|
|||
pkgdesc = WebAssembly targets for Rust
|
||||
depends = lld
|
||||
depends = rust
|
||||
depends = wasm-component-ld
|
||||
|
||||
pkgname = rust-src
|
||||
pkgdesc = Source code for the Rust standard library
|
||||
|
|
|
@ -9,10 +9,10 @@ Subject: [PATCH] bootstrap: Change libexec dir
|
|||
2 files changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/bootstrap/src/core/build_steps/dist.rs b/src/bootstrap/src/core/build_steps/dist.rs
|
||||
index 770a5cdb232d..d115a615774c 100644
|
||||
index 91039d0c8dcc..b01827f85ca1 100644
|
||||
--- a/src/bootstrap/src/core/build_steps/dist.rs
|
||||
+++ b/src/bootstrap/src/core/build_steps/dist.rs
|
||||
@@ -424,7 +424,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
|
||||
@@ -426,7 +426,7 @@ fn prepare_image(builder: &Builder<'_>, compiler: Compiler, image: &Path) {
|
||||
},
|
||||
builder.kind,
|
||||
) {
|
||||
|
@ -22,10 +22,10 @@ index 770a5cdb232d..d115a615774c 100644
|
|||
|
||||
let libdir_relative = builder.libdir_relative(compiler);
|
||||
diff --git a/src/bootstrap/src/core/build_steps/tool.rs b/src/bootstrap/src/core/build_steps/tool.rs
|
||||
index 994f0bef0dc7..075f3e9e4166 100644
|
||||
index 9df4698f21f3..ad0514be5f1d 100644
|
||||
--- a/src/bootstrap/src/core/build_steps/tool.rs
|
||||
+++ b/src/bootstrap/src/core/build_steps/tool.rs
|
||||
@@ -681,7 +681,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {
|
||||
@@ -724,7 +724,7 @@ fn run(self, builder: &Builder<'_>) -> Option<PathBuf> {
|
||||
|
||||
// Copy `rust-analyzer-proc-macro-srv` to `<sysroot>/libexec/`
|
||||
// so that r-a can use it.
|
||||
|
|
|
@ -8,10 +8,10 @@ Subject: [PATCH] bootstrap: Change bash-completion dir
|
|||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/bootstrap/src/core/build_steps/dist.rs b/src/bootstrap/src/core/build_steps/dist.rs
|
||||
index d115a615774c..444369829413 100644
|
||||
index b01827f85ca1..f0003352c570 100644
|
||||
--- a/src/bootstrap/src/core/build_steps/dist.rs
|
||||
+++ b/src/bootstrap/src/core/build_steps/dist.rs
|
||||
@@ -1095,7 +1095,11 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
@@ -1111,7 +1111,11 @@ fn run(self, builder: &Builder<'_>) -> Option<GeneratedTarball> {
|
||||
|
||||
tarball.add_file(cargo, "bin", 0o755);
|
||||
tarball.add_file(etc.join("_cargo"), "share/zsh/site-functions", 0o644);
|
||||
|
|
|
@ -23,10 +23,10 @@ targets, as things break when this is done:
|
|||
3 files changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/compiler/rustc_session/src/config.rs b/compiler/rustc_session/src/config.rs
|
||||
index 4f259960ac3a..fbd643f93bbc 100644
|
||||
index a622f1b577df..849e9ceee01c 100644
|
||||
--- a/compiler/rustc_session/src/config.rs
|
||||
+++ b/compiler/rustc_session/src/config.rs
|
||||
@@ -1921,6 +1921,10 @@ pub fn parse_target_triple(early_dcx: &EarlyDiagCtxt, matches: &getopts::Matches
|
||||
@@ -1974,6 +1974,10 @@ pub fn parse_target_triple(early_dcx: &EarlyDiagCtxt, matches: &getopts::Matches
|
||||
early_dcx.early_fatal(format!("target file {path:?} does not exist"))
|
||||
})
|
||||
}
|
||||
|
@ -51,11 +51,11 @@ index 1d4916cabfdf..4caab818efdb 100644
|
|||
description: None,
|
||||
tier: None,
|
||||
diff --git a/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs b/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs
|
||||
index 11fb28a9aed7..3be190b535ae 100644
|
||||
index bd12d4d8af0e..67ee03d56da4 100644
|
||||
--- a/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs
|
||||
+++ b/compiler/rustc_target/src/spec/targets/x86_64_unknown_linux_gnu.rs
|
||||
@@ -19,7 +19,7 @@ pub fn target() -> Target {
|
||||
base.supports_xray = true;
|
||||
@@ -26,7 +26,7 @@ pub fn target() -> Target {
|
||||
}
|
||||
|
||||
Target {
|
||||
- llvm_target: "x86_64-unknown-linux-gnu".into(),
|
||||
|
|
|
@ -6,6 +6,7 @@
|
|||
|
||||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - remove lib32, musl, and wasm packages and related bits
|
||||
# - remove wasm-component-ld from makedepends
|
||||
# - add a link to g++ to compensate for broken cross-compiler decisions
|
||||
# - build v6/v7 with -j2 - RAM constraints
|
||||
# - set llvm-config in config.toml for ARM architectures
|
||||
|
@ -20,8 +21,8 @@ pkgname=(
|
|||
rust-src
|
||||
)
|
||||
epoch=1
|
||||
pkgver=1.79.0
|
||||
pkgrel=3
|
||||
pkgver=1.80.0
|
||||
pkgrel=1
|
||||
pkgdesc="Systems programming language focused on safety, speed and concurrency"
|
||||
url=https://www.rust-lang.org/
|
||||
arch=(x86_64)
|
||||
|
@ -64,11 +65,11 @@ source=(
|
|||
0003-compiler-Change-LLVM-targets.patch
|
||||
0004-compiler-Use-wasm-ld-for-wasm-targets.patch
|
||||
)
|
||||
b2sums=('07fbb29007921cffa6fc11a928d64a43c93c14cd421aee77cf44b7ee71a67c67d9f7454f5d1b85f2d79f50dcc7048a356f4f3971ba87ebad21f53321c51808ca'
|
||||
b2sums=('759e86509b4a5516fb98971614e3ab7a54d08970b120f1fee54250316e1e2569c1dc53e09ff11cb1fad5a73ede5ba7fdbae384656d3db2119849935d68bfbde8'
|
||||
'SKIP'
|
||||
'c1cf64e26d240fbacbe2170ad4a114e09deb8230c8c7934415c7b9cb32eb30f708694265b34f281f466c8d8ec7841bfa4895da877d2ca87a3a953a7faa40de80'
|
||||
'093cf81b7c5be5ef8421b4a31a56b5b28d3ecfcb2e952bfea379683f31a237142afdd1c2e45a67e29a11e8e915e80671249fdc2b5760e58702234e5b339abf4e'
|
||||
'c81eb7e5f4dd8225701aa379381bd377be2348f42f778e67b77118f68e92ac1fe60aab692fbcd61a02af900f9e017ea05adc7bb508ef6297dd096585e0571e5e'
|
||||
'ba3444d558b9428231fd33156fc231b34dc445813c2c849106f0db0a519c26eb8b8f7f2b8b13e9a303949c50611d95b0ffaf4d0bdc7fde640337d04602b03312'
|
||||
'b582b6bf142ad574e489d3aec1d8b317b014921fc7d8e28a496576ec08535a595a10491198dd04144bf266cb09cbd6427e313d734f65b04658ca7755051a0997'
|
||||
'32be97e6fefb20f3d1f16834d3522e22a79e3928e99817418e1f4599d2b5432a9f2d3c09e962c180bb0146d8725949bae24a0dffa7e5bd948a72ffb92d7ca22f'
|
||||
'963aa64d27763f063b9fac483a870563f5a71a49ec02d17b7ca0c14dbf67064ba56028bbc45f2ee50b16eada725cb55c2aa2ab17ceadff65ba9e40cb220f7a0c')
|
||||
validpgpkeys=(
|
||||
108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
|
||||
|
|
Loading…
Reference in a new issue