mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
Merge pull request #1010 from jarondl/add-flexget-reqs
add python2-dateutil1 and python2-path
This commit is contained in:
commit
4c2979c2d1
3 changed files with 78 additions and 0 deletions
35
aur/python2-dateutil1/PKGBUILD
Normal file
35
aur/python2-dateutil1/PKGBUILD
Normal file
|
@ -0,0 +1,35 @@
|
|||
#Maintainer: Tor Arne Thune <http://devia.org/contact>
|
||||
#Contributor: Jelle van der Waa <jelle@vdwaa.nl>
|
||||
|
||||
pkgname=python2-dateutil1
|
||||
pkgver=2.1
|
||||
pkgrel=8
|
||||
pkgdesc="Provides powerful extensions to the standard datetime module"
|
||||
arch=('any')
|
||||
license=('custom:PYTHON')
|
||||
url="http://labix.org/python-dateutil"
|
||||
makedepends=('python2-setuptools' 'python2-six')
|
||||
provides=('python2-dateutil=2.1')
|
||||
conflicts=('python2-dateutil')
|
||||
source=(http://pypi.python.org/packages/source/p/python-dateutil/python-dateutil-$pkgver.tar.gz{,.asc} python-dateutil-2.1-open-utf-8.patch)
|
||||
md5sums=('1534bb15cf311f07afaa3aacba1c028b' '4aa0ba908299d983781c58ec0640ef2b' '4b780c62fc03be161629ee08e35eba6a')
|
||||
|
||||
build() {
|
||||
cd $srcdir/python-dateutil-$pkgver
|
||||
patch -Np0 -i $srcdir/python-dateutil-2.1-open-utf-8.patch
|
||||
}
|
||||
|
||||
package() {
|
||||
depends=('python2' 'python2-six')
|
||||
cd $srcdir/python-dateutil-$pkgver
|
||||
python2 setup.py install --root=$pkgdir --optimize=1
|
||||
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
|
||||
|
||||
chmod -R a+r $pkgdir/usr/lib/python2.7/
|
||||
rm $pkgdir/usr/lib/python2.7/site-packages/dateutil/zoneinfo/zoneinfo--latest.tar.gz
|
||||
}
|
||||
|
||||
check() {
|
||||
cd $srcdir/python-dateutil-$pkgver
|
||||
python2 test.py
|
||||
}
|
21
aur/python2-dateutil1/python-dateutil-2.1-open-utf-8.patch
Normal file
21
aur/python2-dateutil1/python-dateutil-2.1-open-utf-8.patch
Normal file
|
@ -0,0 +1,21 @@
|
|||
Fix UnicodeDecodeError in setup.py.
|
||||
|
||||
https://bugs.gentoo.org/show_bug.cgi?id=410725
|
||||
--- setup.py
|
||||
+++ setup.py
|
||||
@@ -1,5 +1,6 @@
|
||||
#!/usr/bin/python
|
||||
from os.path import isfile, join
|
||||
+import codecs
|
||||
import glob
|
||||
import os
|
||||
import re
|
||||
@@ -13,7 +14,7 @@
|
||||
|
||||
TOPDIR = os.path.dirname(__file__) or "."
|
||||
VERSION = re.search('__version__ = "([^"]+)"',
|
||||
- open(TOPDIR + "/dateutil/__init__.py").read()).group(1)
|
||||
+ codecs.open(TOPDIR + "/dateutil/__init__.py", encoding='utf-8').read()).group(1)
|
||||
|
||||
|
||||
setup(name="python-dateutil",
|
22
aur/python2-path/PKGBUILD
Normal file
22
aur/python2-path/PKGBUILD
Normal file
|
@ -0,0 +1,22 @@
|
|||
# Maintainer: David Danier <david.danier@team23.de>
|
||||
|
||||
# ALARM AUR:
|
||||
# Maintainer: Yaron de Leeuw <me@jarondl.net>
|
||||
# only changed arch to any
|
||||
pkgname=python2-path
|
||||
pkgver=5.1
|
||||
pkgrel=1
|
||||
pkgdesc="path.py provides a class (path) for working with files and directories. Less typing than os.path, more fun, a few new tricks"
|
||||
arch=('any')
|
||||
url="https://pypi.python.org/pypi/path.py"
|
||||
license=('MIT')
|
||||
depends=('python2')
|
||||
options=(!emptydirs)
|
||||
source=(http://pypi.python.org/packages/source/p/path.py/path.py-${pkgver}.zip)
|
||||
sha256sums=('976b1392527c77383eb827de7fd44dacaf1297a63aa0df526f47af302f479d54')
|
||||
|
||||
package() {
|
||||
cd ${srcdir}/path.py-${pkgver}
|
||||
# python2 setup.py build || return 1
|
||||
python2 setup.py install --root=${pkgdir} --optimize=1 || return 1
|
||||
}
|
Loading…
Reference in a new issue