alarm/kodi-rbp to 18.1-3 (#1682)

This commit is contained in:
Lukasz Jankowski 2019-03-21 23:36:08 +00:00 committed by Kevin Mihelich
parent ed0a47dc50
commit 4c35b0ce0e
2 changed files with 1 additions and 17 deletions

View file

@ -1,14 +0,0 @@
diff -rupN a/xbmc/cores/AudioEngine/Sinks/AESinkALSA.cpp b/xbmc/cores/AudioEngine/Sinks/AESinkALSA.cpp
--- a/xbmc/cores/AudioEngine/Sinks/AESinkALSA.cpp 2019-01-28 19:02:31.000000000 +0100
+++ b/xbmc/cores/AudioEngine/Sinks/AESinkALSA.cpp 2019-02-15 22:20:14.000000000 +0100
@@ -1329,6 +1329,10 @@ void CAESinkALSA::EnumerateDevice(AEDevi
if (snd_card_get_name(cardNr, &cardName) == 0)
info.m_displayName = cardName;
+ /* hifiberry digi doesn't correctly report as iec958 device. Needs fixing in kernel driver */
+ if (info.m_displayName == "snd_rpi_hifiberry_digi")
+ info.m_deviceType = AE_DEVTYPE_IEC958;
+
if (info.m_deviceType == AE_DEVTYPE_HDMI && info.m_displayName.size() > 5 &&
info.m_displayName.substr(info.m_displayName.size()-5) == " HDMI")
{

View file

@ -12,7 +12,7 @@ _prefix=/usr
pkgbase=kodi-rbp
pkgname=('kodi-rbp' 'kodi-rbp-eventclients' 'kodi-rbp-tools-texturepacker' 'kodi-rbp-dev')
pkgver=18.1
pkgrel=2
pkgrel=3
_codename=Leia
_tag="18.1-$_codename"
_ffmpeg_version="4.0.3-$_codename-RC5"
@ -42,7 +42,6 @@ source=("https://github.com/popcornmix/xbmc/archive/newclock5_$_tag.tar.gz"
'99-kodi.rules'
'polkit.rules'
'00-fix.building.with.mariadb.patch::https://github.com/wsnipex/xbmc/commit/cd20c8eb8a0394db1f028b118c4ca9b91b7e746a.patch'
'01-fix.passthrough.for.hifiberry_digi.patch'
"ffmpeg-$_ffmpeg_version.tar.gz::https://github.com/xbmc/FFmpeg/archive/$_ffmpeg_version.tar.gz"
"libdvdcss-$_libdvdcss_version.tar.gz::https://github.com/xbmc/libdvdcss/archive/$_libdvdcss_version.tar.gz"
"libdvdnav-$_libdvdnav_version.tar.gz::https://github.com/xbmc/libdvdnav/archive/$_libdvdnav_version.tar.gz"
@ -68,7 +67,6 @@ sha256sums=('22a46122a8e6f5a6507baae8e6be6beaf5a4203358478c94da525187b0681b99'
'b31570f95654434b01fd8531612fbb6be77cbc1c519dd60f92feae26eb160f3d'
'9ea592205023ba861603d74b63cdb73126c56372a366dc4cb7beb379073cbb96'
'849daf1d5b081ef6d0e428bbc7d448799fc43a8ac9e79cd7513de0eb5a91b0bb'
'a7aa50c25ff53b87c79c9235d9a3de62ccffcab4faa15b489ae2d8be9b0c0b35'
'9a971662e44353c120f2ccf87655571998956e699a2dd800ec708b8b928a53c8'
'38816f8373e243bc5950449b4f3b18938c4e1c59348e3411e23f31db4072e40d'
'071e414e61b795f2ff9015b21a85fc009dde967f27780d23092643916538a57a'