mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
parent
00b55cb0bf
commit
4c6bc14c62
3 changed files with 61 additions and 3 deletions
25
community/mythtv/0001-libudfread-set-HAVE_PTHREAD_H.patch
Normal file
25
community/mythtv/0001-libudfread-set-HAVE_PTHREAD_H.patch
Normal file
|
@ -0,0 +1,25 @@
|
|||
From 6c3a0ad55021370f645d41cf3997b61510b796ad Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 8 May 2016 14:22:20 -0600
|
||||
Subject: [PATCH 1/2] libudfread: set HAVE_PTHREAD_H
|
||||
|
||||
---
|
||||
mythtv/external/libudfread/libudfread.pro | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/mythtv/external/libudfread/libudfread.pro b/mythtv/external/libudfread/libudfread.pro
|
||||
index 14a9af3..09f2256 100644
|
||||
--- a/mythtv/external/libudfread/libudfread.pro
|
||||
+++ b/mythtv/external/libudfread/libudfread.pro
|
||||
@@ -20,7 +20,7 @@ QMAKE_CLEAN += $(TARGET)
|
||||
|
||||
HEADERS += blockinput.h default_blockinput.h ecma167.h udfread.h
|
||||
SOURCES += default_blockinput.c ecma167.c udfread.c udfread-version.c
|
||||
-DEFINES += HAVE_CONFIG_H
|
||||
+DEFINES += HAVE_CONFIG_H HAVE_PTHREAD_H
|
||||
|
||||
inc.path = $${PREFIX}/include/mythtv/
|
||||
inc.files = blockinput.h udfread.h
|
||||
--
|
||||
2.8.2
|
||||
|
|
@ -0,0 +1,25 @@
|
|||
From 8e1d4a498e02ac2398aa4b5478e3d265319f0e41 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 8 May 2016 14:56:39 -0600
|
||||
Subject: [PATCH 2/2] visualisations: fix ambiguous abs call
|
||||
|
||||
---
|
||||
mythtv/libs/libmythtv/visualisations/videovisualcircles.cpp | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/mythtv/libs/libmythtv/visualisations/videovisualcircles.cpp b/mythtv/libs/libmythtv/visualisations/videovisualcircles.cpp
|
||||
index 1140372..554b1f9 100644
|
||||
--- a/mythtv/libs/libmythtv/visualisations/videovisualcircles.cpp
|
||||
+++ b/mythtv/libs/libmythtv/visualisations/videovisualcircles.cpp
|
||||
@@ -23,7 +23,7 @@ void VideoVisualCircles::DrawPriv(MythPainter *painter, QPaintDevice* device)
|
||||
painter->Begin(device);
|
||||
for (int i = 0; i < count; i++, rad += m_range, red += incr, green -= incr)
|
||||
{
|
||||
- double mag = abs((m_magnitudes[i] + m_magnitudes[i + count]) / 2.0);
|
||||
+ double mag = fabs((m_magnitudes[i] + m_magnitudes[i + count]) / 2.0);
|
||||
if (mag > 1.0)
|
||||
{
|
||||
pen.setWidth((int)mag);
|
||||
--
|
||||
2.8.2
|
||||
|
|
@ -8,6 +8,7 @@
|
|||
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
# - correctly define ARM cpus for configure
|
||||
# - disabled vdpau, mmx, incompatible ARM FPUs
|
||||
# - patch to fix v5 build
|
||||
|
||||
pkgname=mythtv
|
||||
pkgver=0.28
|
||||
|
@ -31,15 +32,22 @@ conflicts=('myththemes' 'mythplugins-mythvideo')
|
|||
replaces=('myththemes' 'mythplugins-mythvideo')
|
||||
install='mythtv.install'
|
||||
source=("$pkgname-$pkgver.tar.gz::https://github.com/MythTV/$pkgname/archive/v$pkgver.tar.gz"
|
||||
'mythbackend.service' '99-mythbackend.rules')
|
||||
sha256sums=('3b0028c8f86e1cdeb722ac54f9e0aa6e72d30f2e94fd8ae0a2c177d7bc1e1216'
|
||||
'mythbackend.service' '99-mythbackend.rules'
|
||||
'0001-libudfread-set-HAVE_PTHREAD_H.patch'
|
||||
'0002-visualisations-fix-ambiguous-abs-call.patch')
|
||||
sha256sums=('7b3476c0ec0fc17d6b734f0440383815e81850a70b78c12ee40d61a408eba340'
|
||||
'ecfde779ded8332cc62c86fac6b432b09cbf5d254135798287ada688af9a1302'
|
||||
'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333')
|
||||
'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333'
|
||||
'cd337cdf4de86c9343c1bcb6635ded717359cb249fde8eea4879b4abc7ee3c6b'
|
||||
'61cd9c37dc086131f41aea58e7a436acc76f79aa9dd0d5691941a3a8a16d3558')
|
||||
|
||||
prepare() {
|
||||
cd $pkgname-$pkgver/$pkgname
|
||||
|
||||
find 'bindings/python' 'contrib' 'programs/scripts' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
|
||||
|
||||
patch -p2 -i "${srcdir}/0001-libudfread-set-HAVE_PTHREAD_H.patch"
|
||||
patch -p2 -i "${srcdir}/0002-visualisations-fix-ambiguous-abs-call.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue