mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-19 00:21:40 +00:00
extra/firefox: updates
This commit is contained in:
parent
c8e4d80b83
commit
4c87f0a078
2 changed files with 10 additions and 20 deletions
|
@ -9,7 +9,6 @@
|
|||
|
||||
buildarch=12
|
||||
highmem=1
|
||||
noautobuild=1
|
||||
|
||||
pkgname=firefox
|
||||
pkgver=67.0
|
||||
|
@ -34,9 +33,9 @@ source=("https://hg.mozilla.org/releases/mozilla-release/archive/FIREFOX_${pkgve
|
|||
arm.patch
|
||||
build-arm-libopus.patch
|
||||
$pkgname.desktop firefox-symbolic.svg)
|
||||
sha256sums=('fde34091a75b0f54f9e5b8c3392866510a6597f2bd01036d48345934f4ce4859'
|
||||
sha256sums=('3f072d8c555d18f117af8755196643ad38b9b0c3ab0363f8be9470cd69655744'
|
||||
'd0673786a6a1f1b9f6f66a3a1356afa33f1f18f59dabd92bd193c88c52a1d04c'
|
||||
'2c9e39b9b62d5a75e31908cb4d42ff8006ff9406aed2f7deff826fe1466cd31a'
|
||||
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
|
||||
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
|
||||
'4a783dca1f88e003c72f32d22719a0915f3fa576adbc492240e7cc250246ce10'
|
||||
'9a1a572dc88014882d54ba2d3079a1cf5b28fa03c5976ed2cb763c93dabbd797')
|
||||
|
|
|
@ -1,24 +1,15 @@
|
|||
https://bugzilla.mozilla.org/show_bug.cgi?id=1526653
|
||||
|
||||
diff --git a/js/src/wasm/WasmSignalHandlers.cpp.orig b/js/src/wasm/WasmSignalHandlers.cpp
|
||||
index d46b1c6..cf4c957 100644
|
||||
index 636537f..0f3461a 100644
|
||||
--- a/js/src/wasm/WasmSignalHandlers.cpp.orig
|
||||
+++ b/js/src/wasm/WasmSignalHandlers.cpp
|
||||
@@ -228,7 +228,7 @@ using mozilla::DebugOnly;
|
||||
# error "Don't know how to read/write to the thread state via the mcontext_t."
|
||||
@@ -244,7 +244,7 @@ using mozilla::DebugOnly;
|
||||
// emulation here.
|
||||
|
||||
#if defined(__linux__) && defined(__arm__)
|
||||
-# define WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS
|
||||
+//# define WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS
|
||||
#endif
|
||||
|
||||
-#if defined(__linux__) && defined(__arm__)
|
||||
+#if 0 && defined(__linux__) && defined(__arm__)
|
||||
# include <sys/user.h>
|
||||
#endif
|
||||
|
||||
@@ -456,7 +456,7 @@ struct AutoHandlingTrap {
|
||||
}
|
||||
};
|
||||
|
||||
-#if defined(__linux__) && defined(__arm__)
|
||||
+#if 0 && defined(__linux__) && defined(__arm__)
|
||||
|
||||
// Code to handle SIGBUS for unaligned floating point accesses on 32-bit ARM.
|
||||
|
||||
#ifdef WASM_EMULATE_ARM_UNALIGNED_FP_ACCESS
|
||||
|
|
Loading…
Reference in a new issue