mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/texmacs to 1.99.9-1
This commit is contained in:
parent
6664501a28
commit
4cd8b625c2
2 changed files with 2 additions and 25 deletions
|
@ -1,4 +1,3 @@
|
|||
# $Id$
|
||||
# Maintainer: Ronald van Haren <ronald.archlinux.org>
|
||||
# Contributor: Damir Perisa <damir.perisa@bluewin.ch> # Contributor: Christopher Reimer <c.reimer1993@gmail.com>
|
||||
|
||||
|
@ -6,7 +5,7 @@
|
|||
# - patch to fix size_t check on ARM
|
||||
|
||||
pkgname=texmacs
|
||||
pkgver=1.99.8
|
||||
pkgver=1.99.9
|
||||
pkgrel=1
|
||||
pkgdesc="Free scientific text editor, inspired by TeX and GNU Emacs. WYSIWYG editor TeX-fonts and CAS-interface (Giac, GTybalt, Macaulay 2, Maxima, Octave, Pari, Qcl, R and Yacas) in one."
|
||||
arch=('x86_64')
|
||||
|
@ -21,11 +20,9 @@ optdepends=('transfig: convert images using fig2ps'
|
|||
'aspell: spell checking')
|
||||
makedepends=('ghostscript' 'cmake')
|
||||
source=(http://www.texmacs.org/Download/ftp/tmftp/source/TeXmacs-${pkgver}-src.tar.gz
|
||||
texmacs-fix-linking.patch
|
||||
fix-size_t-check.patch)
|
||||
options=('!emptydirs')
|
||||
sha256sums=('7febdbccc6d1ac16d9375a136814259499fb38a49078de2857ab4f47d29a20c0'
|
||||
'8b52633981cf71357064e816f898386a4aed3d424f3f417da8dc77c4df094e0f'
|
||||
sha256sums=('29f0cd141ac81a62fd6d1dd04a53b500083deeca97a5e150ebef62e493d32545'
|
||||
'c7ea32216be57e8cf29109c89b47afd55b2c1e6c4bc31e377ca9d278cde18f09')
|
||||
|
||||
prepare() {
|
||||
|
@ -36,8 +33,6 @@ prepare() {
|
|||
TeXmacs/misc/inkscape_extension/texmacs_reedit.py
|
||||
sed -i 's/"python"/"python2"/' plugins/python/progs/init-python.scm
|
||||
|
||||
patch -p1 -i ../texmacs-fix-linking.patch # Fix linking
|
||||
|
||||
patch -p1 -i ../fix-size_t-check.patch
|
||||
}
|
||||
|
||||
|
|
|
@ -1,18 +0,0 @@
|
|||
--- texmacs/src/CMakeLists.txt.orig 2018-07-14 09:20:14.114218215 +0000
|
||||
+++ texmacs/src/CMakeLists.txt 2018-07-14 09:21:07.651031679 +0000
|
||||
@@ -1,6 +1,8 @@
|
||||
|
||||
add_library(texmacs_body ${TeXmacs_All_SRCS})
|
||||
|
||||
+target_link_libraries (texmacs_body ${TeXmacs_Libraries})
|
||||
+
|
||||
add_executable (${TeXmacs_binary_name}
|
||||
./Texmacs/Texmacs/texmacs.cpp
|
||||
)
|
||||
@@ -19,4 +21,4 @@
|
||||
RUNTIME_OUTPUT_DIRECTORY ${TEXMACS_BINARY_DIR}
|
||||
)
|
||||
|
||||
-install(TARGETS ${TeXmacs_binary_name} DESTINATION lib/texmacs/TeXmacs/bin)
|
||||
\ No newline at end of file
|
||||
+install(TARGETS ${TeXmacs_binary_name} DESTINATION lib/texmacs/TeXmacs/bin)
|
Loading…
Reference in a new issue