Added alarm/libcec-cubox

This commit is contained in:
Aldrik Dunbar 2012-10-19 22:54:09 +02:00
parent b098eb753c
commit 4cdc032ed2
3 changed files with 84 additions and 1 deletions

View file

@ -0,0 +1,34 @@
From 71fa379cb561f66d60e3507cd823ce3b438b4454 Mon Sep 17 00:00:00 2001
From: warped-rudi <r.ihle@s-t.de>
Date: Fri, 19 Oct 2012 07:56:19 +0200
Subject: [PATCH] Added adapter ID interface
---
src/lib/adapter/CuBox/NxpCECAdapterCommunication.h | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/src/lib/adapter/CuBox/NxpCECAdapterCommunication.h b/src/lib/adapter/CuBox/NxpCECAdapterCommunication.h
index 066c032..42e611a 100644
--- a/src/lib/adapter/CuBox/NxpCECAdapterCommunication.h
+++ b/src/lib/adapter/CuBox/NxpCECAdapterCommunication.h
@@ -39,6 +39,8 @@
#include "lib/adapter/AdapterCommunication.h"
#include <map>
+#define NXP_ADAPTER_VID 0x0471
+#define NXP_ADAPTER_PID 0x1001
namespace PLATFORM
{
@@ -84,6 +86,8 @@ namespace CEC
cec_vendor_id GetVendorId(void);
bool SupportsSourceLogicalAddress(const cec_logical_address address) { return address > CECDEVICE_TV && address <= CECDEVICE_BROADCAST; }
cec_adapter_type GetAdapterType(void) { return ADAPTERTYPE_TDA995x; }
+ uint16_t GetAdapterVendorId(void) const { return NXP_ADAPTER_VID; }
+ uint16_t GetAdapterProductId(void) const { return NXP_ADAPTER_PID; }
void HandleLogicalAddressLost(cec_logical_address oldAddress);
///}
--
1.7.12

View file

@ -0,0 +1,40 @@
# Contributor: tomasgroth at yahoo.dk
buildarch=4
pkgname="libcec-cubox"
pkgver=2.0.1
pkgrel=1
pkgdesc="Pulse-Eight's libcec for the Pulse-Eight USB-CEC adapter with support for cubox"
arch=('armv7h')
url="https://github.com/Pulse-Eight/libcec"
license=('GPL')
depends=('udev' 'lockdev')
makedepends=('linux-headers-cubox')
conflicts=('libcec')
provides=('libcec')
source=("libcec-2.0.1.tar.gz::https://github.com/Pulse-Eight/libcec/tarball/libcec-2.0.1" \
"0001-Added-adapter-ID-interface.patch")
_srcfolder=Pulse-Eight-libcec-6be84fc
sha256sums=('3dc6d7080a98dbfddcab4605a1267c24751b4334a95f845583f34d9f24c9269a' \
'4dd4a93d9cf29f383ae9ae10fd35c730160518caff9582fb4cc01cf0d316cd2c')
options=(!libtool)
build() {
mv "$_srcfolder" "$pkgname-$pkgver"
_kernel_release="$(pacman -Q linux-headers-cubox | grep -Eo "[^\ ]+$")-ARCH"
cd "$pkgname-$pkgver"
patch -p1 -i "${srcdir}/${source[1]}"
autoreconf -vif
./configure --prefix=/usr --enable-cubox --enable-shared=lockdev
--with-tda995x-toolkit-path="/usr/src/linux-${_kernel_release}/include/nxp_hdmi"
make
}
package() {
cd "$pkgname-$pkgver"
make DESTDIR="$pkgdir" install
}

View file

@ -8,7 +8,7 @@ pkgname=('linux-cubox' 'linux-headers-cubox')
_kernelname=${pkgname#linux}
_basekernel=3.5
pkgver=${_basekernel}.7
pkgrel=2
pkgrel=3
arch=('arm')
url="http://www.kernel.org/"
license=('GPL2')
@ -184,6 +184,15 @@ package_linux-headers-cubox() {
cp -a drivers/media/video/${i}/*.h "${pkgdir}/usr/src/linux-${_kernver}/drivers/media/video/${i}"
done
# headers for libcec-cubox package
install -d "${pkgdir}/usr/src/linux-${_kernver}/include/nxp_hdmi"{,/comps/tmdlHdmiCEC}/inc
install -m644 drivers/video/dovefb/nxp_hdmi/tda998x_ioctl.h \
"${pkgdir}/usr/src/linux-${_kernver}/include/nxp_hdmi"
install -m644 drivers/video/dovefb/nxp_hdmi/inc/* \
"${pkgdir}/usr/src/linux-${_kernver}/include/nxp_hdmi/inc/"
install -m644 drivers/video/dovefb/nxp_hdmi/comps/tmdlHdmiCEC/inc/tmdlHdmiCEC_Types.h \
"${pkgdir}/usr/src/linux-${_kernver}/include/nxp_hdmi/comps/tmdlHdmiCEC/inc/"
# add docbook makefile
install -D -m644 Documentation/DocBook/Makefile \
"${pkgdir}/usr/src/linux-${_kernver}/Documentation/DocBook/Makefile"