extra/pixman to 0.26.0-1

This commit is contained in:
Kevin Mihelich 2012-06-01 13:58:02 -04:00
parent 7a2981fa19
commit 4cfcfc6162
2 changed files with 52 additions and 7 deletions

View file

@ -5,12 +5,8 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - disable arm extensions that aren't supported, autodetection fails
plugrel=1
noautobuild=1
# - remove noautobuild on next bump
pkgname=pixman
pkgver=0.24.4
pkgver=0.26.0
pkgrel=1
pkgdesc="The pixel-manipulation library for X and cairo"
arch=(i686 x86_64)
@ -18,11 +14,14 @@ url="http://xorg.freedesktop.org"
license=('custom')
depends=('glibc')
options=('!libtool')
source=(http://xorg.freedesktop.org/releases/individual/lib/${pkgname}-${pkgver}.tar.bz2)
sha1sums=('683450f917015366ac7918fc517c76801aeff374')
source=(http://xorg.freedesktop.org/releases/individual/lib/${pkgname}-${pkgver}.tar.bz2
test_failures_on_x86-32.diff)
sha1sums=('d772cf794ec5da0966eba3cb360919a0a5e0d23f'
'24a688271d5cf2c4137a147deaa2975122c01aa8')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -Np1 -i ${srcdir}/test_failures_on_x86-32.diff
[[ $CARCH = "arm" ]] && CONFIG="--disable-arm-simd --disable-arm-neon --disable-arm-iwmmxt"
[[ $CARCH = "armv7h" ]] && CONFIG="--disable-arm-neon --disable-arm-iwmmxt"
./configure --prefix=/usr --disable-static $CONFIG

View file

@ -0,0 +1,46 @@
From da6193b1fcc1dfab27f4c36917864f2f2c41cf3e Mon Sep 17 00:00:00 2001
From: Matt Turner <mattst88@gmail.com>
Date: Sun, 27 May 2012 17:01:57 +0000
Subject: mmx: add missing _mm_empty calls
Fixes spurious test failures on x86-32.
---
diff --git a/pixman/pixman-mmx.c b/pixman/pixman-mmx.c
index bb125bf..6e292c6 100644
--- a/pixman/pixman-mmx.c
+++ b/pixman/pixman-mmx.c
@@ -2232,6 +2232,8 @@ mmx_composite_src_x888_0565 (pixman_implementation_t *imp,
w--;
}
}
+
+ _mm_empty ();
}
static void
@@ -3542,6 +3544,7 @@ mmx_fetch_x8r8g8b8 (pixman_iter_t *iter, const uint32_t *mask)
w--;
}
+ _mm_empty ();
return iter->buffer;
}
@@ -3585,6 +3588,7 @@ mmx_fetch_r5g6b5 (pixman_iter_t *iter, const uint32_t *mask)
w--;
}
+ _mm_empty ();
return iter->buffer;
}
@@ -3630,6 +3634,7 @@ mmx_fetch_a8 (pixman_iter_t *iter, const uint32_t *mask)
w--;
}
+ _mm_empty ();
return iter->buffer;
}
--
cgit v0.9.0.2-2-gbebe