extra/boost to 1.55.0-2

This commit is contained in:
Kevin Mihelich 2013-12-07 17:43:45 +00:00
parent 0aeeb1b8e3
commit 4d06cd174d
5 changed files with 46 additions and 182 deletions

View file

@ -0,0 +1,13 @@
Index: libs/log/src/dump_avx2.cpp
===================================================================
--- libs/log/src/dump_avx2.cpp (revision 86614)
+++ libs/log/src/dump_avx2.cpp (working copy)
@@ -205,7 +205,7 @@
__m256i mm_input = _mm256_load_si256(reinterpret_cast< const __m256i* >(p));
__m256i mm_output1, mm_output2, mm_output3;
dump_pack(mm_char_10_to_a, mm_input, mm_output1, mm_output2, mm_output3);
- store_characters_x3(mm_output1, mm_output2, mm_output3, buf);
+ store_characters_x3(mm_output1, mm_output2, mm_output3, b);
}
_mm256_zeroall(); // need to zero all ymm registers to avoid register spills/restores the compler generates around the function call

View file

@ -12,58 +12,50 @@
pkgbase=boost
pkgname=('boost-libs' 'boost')
pkgver=1.54.0
pkgver=1.55.0
_boostver=${pkgver//./_}
pkgrel=4
pkgrel=2
url="http://www.boost.org/"
arch=('i686' 'x86_64')
license=('custom')
makedepends=('icu>=52.1' 'python' 'python2' 'bzip2' 'zlib')
makedepends=('icu>=52.1' 'python' 'python2' 'bzip2' 'zlib' 'clang')
source=(http://downloads.sourceforge.net/${pkgbase}/${pkgbase}_${_boostver}.tar.gz
boost-1.53.0-python3.patch
boost-1.54.0-Fix-macro-for-int128-detection.patch
fix-new-glibc.patch)
sha1sums=('069501636097d3f40ddfd996d29748bb23591c53'
'34026072a7cb2534164f20e77bb71a5c75093307'
'bf5177694ab8a0df6bc13aa47b05727c40febebb'
'e3a5fac340c12b39add50070efb439b857108a0b')
001-log_fix_dump_avx2.patch)
sha1sums=('61ed0e57d3c7c8985805bb0682de3f4c65f4b6e5'
'a4a47cc5716df87d544ae7684aaf402287132d50')
build() {
prepare() {
export _stagedir="${srcdir}/stagedir"
local JOBS="$(sed -e 's/.*\(-j *[0-9]\+\).*/\1/' <<< ${MAKEFLAGS})"
cd ${pkgbase}_${_boostver}
cd "${srcdir}/${pkgbase}_${_boostver}"
patch -p0 -i ../001-log_fix_dump_avx2.patch
patch -Np2 -i ../boost-1.54.0-Fix-macro-for-int128-detection.patch
#patch -Np2 -i ../fix-new-glibc.patch
# Fix build errors with python 3
sed -i "/PYTHON_ROOT/s/print sys.prefix/print(sys.prefix)/g" bootstrap.sh
patch -Np1 -i ../boost-1.53.0-python3.patch
# Shut up strict aliasing warnings
echo "using gcc : : : <compileflags>-fno-strict-aliasing ;" >> ./tools/build/v2/user-config.jam
# Add an extra python version. This does not replace anything and python 2.x need to be the default.
echo "using python : 3.3 : /usr/bin/python3 : /usr/include/python3.3m : /usr/lib ;" >> ./tools/build/v2/user-config.jam
./bootstrap.sh --with-toolset=gcc --with-icu --with-python=/usr/bin/python2
build() {
local JOBS="$(sed -e 's/.*\(-j *[0-9]\+\).*/\1/' <<< ${MAKEFLAGS})"
cd ${pkgbase}_${_boostver}
./bootstrap.sh --with-toolset=clang --with-icu --with-python=/usr/bin/python2
_bindir="bin.linuxarm"
[ "${CARCH}" = "x86_64" ] && _bindir="bin.linuxx86_64"
install -d -m 755 "${_stagedir}"/bin
install "${srcdir}"/${pkgbase}_${_boostver}/tools/build/v2/engine/${_bindir}/bjam "${_stagedir}"/bin/bjam
install -dm755 "${_stagedir}"/bin
install tools/build/v2/engine/${_bindir}/b2 "${_stagedir}"/bin/b2
pushd tools
for _tool in bcp inspect quickbook compiler_status process_jam_log wave; do
"${_stagedir}"/bin/bjam --toolset=gcc $_tool
"${_stagedir}"/bin/b2 --toolset=clang $_tool
done
"${_stagedir}"/bin/bjam --toolset=gcc cflags="-std=gnu++11" library_status
"${_stagedir}"/bin/b2 --toolset=clang cflags="-std=gnu++11 -D__STRICT_ANSI__" library_status
popd
cp -a dist/bin/* "${_stagedir}"/bin
#boostbook is needed by quickbook
install -d -m 755 "${_stagedir}"/share/boostbook
# boostbook is needed by quickbook
install -dm755 "${_stagedir}"/share/boostbook
cp -a tools/boostbook/{xsl,dtd} "${_stagedir}"/share/boostbook/
# default "minimal" install: "release link=shared,static
@ -72,20 +64,18 @@ build() {
# and installs includes in /usr/include/boost.
# --layout=system no longer adds the -mt suffix for multi-threaded libs.
# install to ${_stagedir} in preparation for split packaging
"${_stagedir}"/bin/bjam \
"${_stagedir}"/bin/b2 \
variant=release \
debug-symbols=off \
threading=multi \
runtime-link=shared \
link=shared,static \
toolset=gcc \
toolset=clang \
python=2.7 \
--layout=system \
--prefix="${_stagedir}" \
${JOBS} \
install
find ${_stagedir} -name \*.a -exec rm -f {} \;
}
package_boost() {
@ -94,21 +84,27 @@ package_boost() {
optdepends=('python: for python bindings'
'python2: for python2 bindings'
'boost-build: to use boost jam for building your project.')
options=('staticlibs')
install -d -m 755 "${pkgdir}"/usr
install -dm755 "${pkgdir}"/usr
cp -a "${_stagedir}"/{bin,include,share} "${pkgdir}"/usr
install -D -m 644 "${srcdir}/"${pkgbase}_${_boostver}/LICENSE_1_0.txt \
install -d "${pkgdir}"/usr/lib
find "${_stagedir}"/lib -name \*.a -exec mv {} "${pkgdir}"/usr/lib \;
install -Dm644 "${srcdir}/"${pkgbase}_${_boostver}/LICENSE_1_0.txt \
"${pkgdir}"/usr/share/licenses/boost/LICENSE_1_0.txt
ln -s /usr/bin/b2 "$pkgdir"/usr/bin/bjam
}
package_boost-libs() {
pkgdesc="Free peer-reviewed portable C++ source libraries - Runtime"
depends=('bzip2' 'zlib' 'icu')
install -d -m 755 "${pkgdir}"/usr
install -dm755 "${pkgdir}"/usr
cp -a "${_stagedir}"/lib "${pkgdir}"/usr
install -D -m 644 "${srcdir}/"${pkgbase}_${_boostver}/LICENSE_1_0.txt \
install -Dm644 "${srcdir}/"${pkgbase}_${_boostver}/LICENSE_1_0.txt \
"${pkgdir}"/usr/share/licenses/boost-libs/LICENSE_1_0.txt
}

View file

@ -1,96 +0,0 @@
diff -Naur boost_1_53_0.ori/libs/mpi/src/python/datatypes.cpp boost_1_53_0/libs/mpi/src/python/datatypes.cpp
--- boost_1_53_0.ori/libs/mpi/src/python/datatypes.cpp 2007-11-25 13:38:02.000000000 -0500
+++ boost_1_53_0/libs/mpi/src/python/datatypes.cpp 2013-03-11 20:59:57.171732691 -0400
@@ -13,6 +13,10 @@
#include <boost/mpi/python/serialize.hpp>
#include <boost/mpi.hpp>
+#if PY_MAJOR_VERSION >= 3
+#define PyInt_Type PyLong_Type
+#endif
+
namespace boost { namespace mpi { namespace python {
void export_datatypes()
diff -Naur boost_1_53_0.ori/libs/mpi/src/python/py_environment.cpp boost_1_53_0/libs/mpi/src/python/py_environment.cpp
--- boost_1_53_0.ori/libs/mpi/src/python/py_environment.cpp 2007-11-25 13:38:02.000000000 -0500
+++ boost_1_53_0/libs/mpi/src/python/py_environment.cpp 2013-03-11 21:02:12.961737401 -0400
@@ -11,6 +11,9 @@
* This file reflects the Boost.MPI "environment" class into Python
* methods at module level.
*/
+
+#include <locale>
+#include <string>
#include <boost/python.hpp>
#include <boost/mpi.hpp>
@@ -50,11 +53,65 @@
// If anything changed, convert C-style argc/argv into Python argv
if (mpi_argv != my_argv)
+ {
+#if PY_MAJOR_VERSION >= 3
+ // Code stolen from py3k/Modules/python.c.
+
+ wchar_t **argv_copy = (wchar_t **)PyMem_Malloc(sizeof(wchar_t*)*mpi_argc);
+ /* We need a second copies, as Python might modify the first one. */
+ wchar_t **argv_copy2 = (wchar_t **)PyMem_Malloc(sizeof(wchar_t*)*mpi_argc);
+
+ if (!argv_copy || !argv_copy2) {
+ fprintf(stderr, "out of memory\n");
+ return false;
+ }
+
+ std::locale mylocale;
+ mbstate_t mystate;
+
+ const std::codecvt<char, wchar_t, mbstate_t>& myfacet =
+ std::use_facet<std::codecvt<char, wchar_t, mbstate_t> >(mylocale);
+
+ for (int i = 0; i < mpi_argc; i++)
+ {
+ size_t length = strlen(mpi_argv[i]);
+
+ wchar_t *dest = (wchar_t *) PyMem_Malloc(sizeof(wchar_t) * (length + 1));
+
+ const char *from_next;
+ wchar_t *to_next;
+
+ std::codecvt<wchar_t,char,mbstate_t>::result myresult =
+ myfacet.out(mystate,
+ mpi_argv[i], mpi_argv[i] + length + 1, from_next,
+ dest, dest+length+1, to_next);
+
+ if (myresult != std::codecvt<wchar_t,char,mbstate_t>::ok )
+ {
+ fprintf(stderr, "failure translating argv\n");
+ return 1;
+ }
+
+ argv_copy2[i] = argv_copy[i] = dest;
+ if (!argv_copy[i])
+ return false;
+ }
+
+ PySys_SetArgv(mpi_argc, argv_copy);
+
+ for (int i = 0; i < mpi_argc; i++) {
+ PyMem_Free(argv_copy2[i]);
+ }
+ PyMem_Free(argv_copy);
+ PyMem_Free(argv_copy2);
+#else
PySys_SetArgv(mpi_argc, mpi_argv);
+#endif
+ }
- for (int arg = 0; arg < my_argc; ++arg)
- free(my_argv[arg]);
- delete [] my_argv;
+ for (int arg = 0; arg < mpi_argc; ++arg)
+ free(mpi_argv[arg]);
+ delete [] mpi_argv;
return true;
}

View file

@ -1,35 +0,0 @@
Index: /trunk/boost/lexical_cast.hpp
===================================================================
--- /trunk/boost/lexical_cast.hpp (revision 84136)
+++ /trunk/boost/lexical_cast.hpp (revision 84965)
@@ -70,8 +70,8 @@
#endif
-#if (defined(BOOST_LCAST_HAS_INT128) && !defined(__GNUC__)) || GCC_VERSION > 40700
+// GCC 4.6 has some issues with int128 and uint128. Issues were fixed in GCC 4.7
+#if defined(BOOST_HAS_INT128) && (!defined(__GNUC__) || __GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ > 6))
#define BOOST_LCAST_HAS_INT128
#endif
-
namespace boost
Index: /trunk/libs/conversion/test/lexical_cast_integral_types_test.cpp
===================================================================
--- /trunk/libs/conversion/test/lexical_cast_integral_types_test.cpp (revision 83717)
+++ /trunk/libs/conversion/test/lexical_cast_integral_types_test.cpp (revision 84965)
@@ -49,5 +49,5 @@
#endif
-#if (defined(BOOST_LCAST_HAS_INT128) && !defined(__GNUC__)) || GCC_VERSION > 40700
+#if defined(BOOST_HAS_INT128) && (!defined(__GNUC__) || __GNUC__ > 4 || (__GNUC__ == 4 && __GNUC_MINOR__ > 6))
#define BOOST_LCAST_HAS_INT128
#endif
@@ -445,6 +445,6 @@
// Overflow test case from David W. Birdsall
- std::string must_owerflow_str = "160000000000000000000";
- std::string must_owerflow_negative_str = "-160000000000000000000";
+ std::string must_owerflow_str = (sizeof(T) < 16 ? "160000000000000000000" : "1600000000000000000000000000000000000000");
+ std::string must_owerflow_negative_str = (sizeof(T) < 16 ? "-160000000000000000000" : "-1600000000000000000000000000000000000000");
for (int i = 0; i < 15; ++i) {
BOOST_CHECK_THROW(lexical_cast<T>(must_owerflow_str), bad_lexical_cast);

View file

@ -1,14 +0,0 @@
Index: /trunk/boost/cstdint.hpp
===================================================================
--- /trunk/boost/cstdint.hpp (revision 84805)
+++ /trunk/boost/cstdint.hpp (revision 84950)
@@ -42,5 +42,8 @@
// See https://svn.boost.org/trac/boost/ticket/3548 and http://sources.redhat.com/bugzilla/show_bug.cgi?id=10990
//
-#if defined(BOOST_HAS_STDINT_H) && (!defined(__GLIBC__) || defined(__GLIBC_HAVE_LONG_LONG))
+#if defined(BOOST_HAS_STDINT_H) \
+ && (!defined(__GLIBC__) \
+ || defined(__GLIBC_HAVE_LONG_LONG) \
+ || (defined(__GLIBC__) && ((__GLIBC__ > 2) || ((__GLIBC__ == 2) && (__GLIBC_MINOR__ >= 17)))))
// The following #include is an implementation artifact; not part of interface.