mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
extra/lirc to 0.9.1.a-3
This commit is contained in:
parent
0d3aed77ae
commit
4d149c2d6a
3 changed files with 83 additions and 45 deletions
|
@ -8,7 +8,7 @@ pkgbase=lirc
|
|||
pkgname=('lirc' 'lirc-utils')
|
||||
_pkgver=0.9.1a
|
||||
[[ $_pkgver =~ [a-z]$ ]] && pkgver="${_pkgver:0:-1}.${_pkgver: -1}" || pkgver="$_pkgver"
|
||||
pkgrel=2
|
||||
pkgrel=3
|
||||
epoch=1
|
||||
arch=('i686' 'x86_64')
|
||||
url="http://www.lirc.org/"
|
||||
|
@ -17,13 +17,13 @@ makedepends=('help2man' 'alsa-lib' 'libx11' 'libftdi-compat' 'libirman' 'python2
|
|||
options=('!makeflags' '!strip')
|
||||
source=("http://prdownloads.sourceforge.net/${pkgbase}/${pkgbase}-${_pkgver}.tar.bz2"
|
||||
wpc8769l-build-fix.patch
|
||||
lirc-0.9.1a-fix-segfault.patch
|
||||
lirc-0.9.1a-fix-segfaults.patch
|
||||
lirc.logrotate
|
||||
irexec.service
|
||||
lirc.tmpfiles)
|
||||
md5sums=('1f1fac162ed309dd50f307e96a292957'
|
||||
'9ec33169b3407f74264062d7679dd269'
|
||||
'13bfc8dbf1a9e30f8ed21ac6c099a676'
|
||||
'cd00acf480e82a0bf050032732d0d733'
|
||||
'3deb02604b37811d41816e9b4385fcc3'
|
||||
'32df3b9bc859565d6acf5f0e5b747083'
|
||||
'febf25c154a7d36f01159e84f26c2d9a')
|
||||
|
@ -32,7 +32,7 @@ prepare() {
|
|||
cd "${srcdir}/lirc-${_pkgver}"
|
||||
|
||||
patch -Np1 -i "${srcdir}/wpc8769l-build-fix.patch"
|
||||
patch -Np1 -i "${srcdir}/lirc-0.9.1a-fix-segfault.patch"
|
||||
patch -Np1 -i "${srcdir}/lirc-0.9.1a-fix-segfaults.patch"
|
||||
|
||||
sed -i '/AC_PATH_XTRA/d' configure.ac
|
||||
sed -e 's/@X_CFLAGS@//g' \
|
||||
|
|
|
@ -1,41 +0,0 @@
|
|||
commit 4a9b45822890f50c5ed36660468e0a99cd4531e0
|
||||
Author: Alec Leamas <leamas@nowhere.net>
|
||||
Date: Mon Aug 18 10:05:44 2014 +0200
|
||||
|
||||
lircd: Fix bad default for lircdfile.
|
||||
|
||||
diff --git a/daemons/lircd.c b/daemons/lircd.c
|
||||
index db8ea13..fa8cf17 100644
|
||||
--- a/daemons/lircd.c
|
||||
+++ b/daemons/lircd.c
|
||||
@@ -2147,7 +2147,7 @@ static void lircd_add_defaults(void)
|
||||
"lircd:device", LIRC_DRIVER_DEVICE,
|
||||
"lircd:listen", NULL ,
|
||||
"lircd:connect", NULL,
|
||||
- "lircd:output", LIRCD,
|
||||
+ "lircd:lircdfile", LIRCD,
|
||||
"lircd:pidfile", PIDFILE,
|
||||
"lircd:logfile", LOGFILE,
|
||||
"lircd:debug", "False",
|
||||
|
||||
commit 8459a881fd53525a47ae2f9180fa3644be5df343
|
||||
Author: Alec Leamas <leamas@nowhere.net>
|
||||
Date: Mon Aug 18 10:00:49 2014 +0200
|
||||
|
||||
Fix segfault when starting lircd (AUR 41581)
|
||||
|
||||
See https://bugs.archlinux.org/task/41581
|
||||
|
||||
diff --git a/lirc_options.conf b/lirc_options.conf
|
||||
index d8ddedd..11293e2 100644
|
||||
--- a/lirc_options.conf
|
||||
+++ b/lirc_options.conf
|
||||
@@ -7,7 +7,7 @@ nodaemon = False
|
||||
permission = 666
|
||||
driver = default
|
||||
device = /dev/lirc0
|
||||
-output = /var/run/lirc/lircd
|
||||
+lircdfile = /var/run/lirc/lircd
|
||||
pidfile = /var/run/lirc/lircd.pid
|
||||
plugindir = /usr/lib/lirc/plugins
|
||||
allow-simulate = No
|
79
extra/lirc/lirc-0.9.1a-fix-segfaults.patch
Normal file
79
extra/lirc/lirc-0.9.1a-fix-segfaults.patch
Normal file
|
@ -0,0 +1,79 @@
|
|||
From 8459a881fd53525a47ae2f9180fa3644be5df343 Mon Sep 17 00:00:00 2001
|
||||
From: Alec Leamas <leamas@nowhere.net>
|
||||
Date: Mon, 18 Aug 2014 10:00:49 +0200
|
||||
Subject: [PATCH 1/3] Fix segfault when starting lircd (AUR 41581)
|
||||
|
||||
See https://bugs.archlinux.org/task/41581
|
||||
---
|
||||
lirc_options.conf | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lirc_options.conf b/lirc_options.conf
|
||||
index d8ddedd..11293e2 100644
|
||||
--- a/lirc_options.conf
|
||||
+++ b/lirc_options.conf
|
||||
@@ -7,7 +7,7 @@ nodaemon = False
|
||||
permission = 666
|
||||
driver = default
|
||||
device = /dev/lirc0
|
||||
-output = /var/run/lirc/lircd
|
||||
+lircdfile = /var/run/lirc/lircd
|
||||
pidfile = /var/run/lirc/lircd.pid
|
||||
plugindir = /usr/lib/lirc/plugins
|
||||
allow-simulate = No
|
||||
--
|
||||
2.1.0
|
||||
|
||||
|
||||
From 4a9b45822890f50c5ed36660468e0a99cd4531e0 Mon Sep 17 00:00:00 2001
|
||||
From: Alec Leamas <leamas@nowhere.net>
|
||||
Date: Mon, 18 Aug 2014 10:05:44 +0200
|
||||
Subject: [PATCH 2/3] lircd: Fix bad default for lircdfile.
|
||||
|
||||
---
|
||||
daemons/lircd.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/daemons/lircd.c b/daemons/lircd.c
|
||||
index db8ea13..fa8cf17 100644
|
||||
--- a/daemons/lircd.c
|
||||
+++ b/daemons/lircd.c
|
||||
@@ -2147,7 +2147,7 @@ static void lircd_add_defaults(void)
|
||||
"lircd:device", LIRC_DRIVER_DEVICE,
|
||||
"lircd:listen", NULL ,
|
||||
"lircd:connect", NULL,
|
||||
- "lircd:output", LIRCD,
|
||||
+ "lircd:lircdfile", LIRCD,
|
||||
"lircd:pidfile", PIDFILE,
|
||||
"lircd:logfile", LOGFILE,
|
||||
"lircd:debug", "False",
|
||||
--
|
||||
2.1.0
|
||||
|
||||
|
||||
From 02252a9fe76c4a4fd809966971759c66af707f02 Mon Sep 17 00:00:00 2001
|
||||
From: Andreas Bader <andreasbader at badersystems.de>
|
||||
Date: Tue, 19 Aug 2014 16:58:21 +0200
|
||||
Subject: [PATCH 3/3] 0.9.1a: Bugfix: segfault when parsing --connect in config
|
||||
file.
|
||||
|
||||
---
|
||||
daemons/lircd.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/daemons/lircd.c b/daemons/lircd.c
|
||||
index fa8cf17..7af4265 100644
|
||||
--- a/daemons/lircd.c
|
||||
+++ b/daemons/lircd.c
|
||||
@@ -2311,7 +2311,7 @@ int main(int argc, char **argv)
|
||||
}
|
||||
opt = options_getstring("lircd:connect");
|
||||
if (opt != NULL) {
|
||||
- if (!add_peer_connection(optarg))
|
||||
+ if (!add_peer_connection(opt))
|
||||
return(EXIT_FAILURE);
|
||||
}
|
||||
# ifdef DEBUG
|
||||
--
|
||||
2.1.0
|
||||
|
Loading…
Reference in a new issue