mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/linux-chromebook2 to 20140814-1
This commit is contained in:
parent
f8fc3ccb5a
commit
4d4643defa
3 changed files with 94 additions and 13 deletions
|
@ -5,7 +5,7 @@ buildarch=4
|
|||
|
||||
pkgbase=linux-chromebook2
|
||||
pkgname=('linux-chromebook2' 'linux-headers-chromebook2')
|
||||
pkgver=20140719
|
||||
pkgver=20140814
|
||||
pkgrel=1
|
||||
_kernelname=${pkgname#linux}
|
||||
pkgdesc="ChromiumOS kernel with ArchLinux ARM tweaks"
|
||||
|
@ -15,20 +15,24 @@ url="https://chromium.googlesource.com/chromiumos/third_party/kernel/+/chromeos-
|
|||
license=('GPL2')
|
||||
makedepends=('xmlto' 'docbook-xsl' 'uboot-mkimage' 'dtc' 'inetutils' 'kmod' 'vboot-utils' 'git')
|
||||
options=('!strip')
|
||||
_commit=2969e1155c9dabf95df3dc5fc38e5bb83d6b18a4
|
||||
_commit=8ee4a3c774153aa80179a89b42cb43eafa0f40de
|
||||
source=("https://chromium.googlesource.com/chromiumos/third_party/kernel/+archive/${_commit}.tar.gz"
|
||||
'http://archlinuxarm.org/builder/src/sd8797_uapsta_cros.bin'
|
||||
http://archlinuxarm.org/builder/src/sd{8787,8797,8897}_uapsta_cros.bin
|
||||
'0001-exynos-drm-smem-start-len.patch'
|
||||
'mwifiex-cros.patch'
|
||||
'mwifiex-do-not-create-AP-and-P2P-interfaces-upon-driver-loading.patch'
|
||||
'config'
|
||||
'kernel.its'
|
||||
'kernel.keyblock'
|
||||
'kernel_data_key.vbprivk')
|
||||
noextract=("${_commit}.tar.gz")
|
||||
md5sums=('SKIP'
|
||||
'bda543cb5943eac34e16d12911f3ee99'
|
||||
'dc6da2272ffb8ea63f10bc4457cc3f70'
|
||||
'5d74feddd86b9c1e6cd23704795cc7d7'
|
||||
'dc8c3ffa65edd9ee30a1f9805d2b3460'
|
||||
'533ebbdc096adab3ec0d649fd04a0ca5'
|
||||
'25b21eebbb7bde980f666013e3fd3705'
|
||||
'df77c8bcdaf51b087fd38cacb1633c82'
|
||||
'3853f4a83db95448b0ebcd2810cd72fe'
|
||||
'1e66637b4771568d2dfa161f5e0357f7'
|
||||
'61c5ff73c136ed07a7aadbf58db3d96a'
|
||||
|
@ -45,9 +49,12 @@ prepare() {
|
|||
# fix for using xf86-video-fbturbo
|
||||
git apply ../0001-exynos-drm-smem-start-len.patch
|
||||
|
||||
# use ChromeOS version of mwifiex 8797 firmware we provide
|
||||
# use ChromeOS version of mwifiex firmware we provide
|
||||
patch -p1 -i ../mwifiex-cros.patch
|
||||
|
||||
# do not create uap0 and p2p0 interfaces by default
|
||||
patch -p1 -i ../mwifiex-do-not-create-AP-and-P2P-interfaces-upon-driver-loading.patch
|
||||
|
||||
# Kernel configuration
|
||||
cp "${srcdir}/config" .config
|
||||
|
||||
|
@ -136,9 +143,9 @@ package_linux-chromebook2() {
|
|||
mkdir -p "${pkgdir}/usr"
|
||||
mv "$pkgdir/lib" "$pkgdir/usr"
|
||||
|
||||
# install ChromeOS mwifiex 8797 firmware
|
||||
# install ChromeOS mwifiex firmware
|
||||
mkdir -p "${pkgdir}"/usr/lib/firmware/mrvl
|
||||
cp ../sd8797_uapsta_cros.bin "${pkgdir}"/usr/lib/firmware/mrvl
|
||||
cp ../sd{8787,8797,8897}_uapsta_cros.bin "${pkgdir}"/usr/lib/firmware/mrvl
|
||||
}
|
||||
|
||||
package_linux-headers-chromebook2() {
|
||||
|
|
|
@ -1,12 +1,15 @@
|
|||
diff -urN a/drivers/net/wireless/mwifiex/sdio.h b/drivers/net/wireless/mwifiex/sdio.h
|
||||
--- a/drivers/net/wireless/mwifiex/sdio.h 2014-06-28 19:50:40.000000000 -0600
|
||||
+++ b/drivers/net/wireless/mwifiex/sdio.h 2014-07-07 19:58:34.086771670 -0600
|
||||
@@ -31,7 +31,7 @@
|
||||
--- a/drivers/net/wireless/mwifiex/sdio.h 2014-08-14 19:21:32.018236913 -0600
|
||||
+++ b/drivers/net/wireless/mwifiex/sdio.h 2014-08-14 19:21:00.468341514 -0600
|
||||
@@ -30,9 +30,9 @@
|
||||
#include "main.h"
|
||||
|
||||
#define SD8786_DEFAULT_FW_NAME "mrvl/sd8786_uapsta.bin"
|
||||
#define SD8787_DEFAULT_FW_NAME "mrvl/sd8787_uapsta.bin"
|
||||
-#define SD8787_DEFAULT_FW_NAME "mrvl/sd8787_uapsta.bin"
|
||||
-#define SD8797_DEFAULT_FW_NAME "mrvl/sd8797_uapsta.bin"
|
||||
-#define SD8897_DEFAULT_FW_NAME "mrvl/sd8897_uapsta.bin"
|
||||
+#define SD8787_DEFAULT_FW_NAME "mrvl/sd8787_uapsta_cros.bin"
|
||||
+#define SD8797_DEFAULT_FW_NAME "mrvl/sd8797_uapsta_cros.bin"
|
||||
#define SD8897_DEFAULT_FW_NAME "mrvl/sd8897_uapsta.bin"
|
||||
+#define SD8897_DEFAULT_FW_NAME "mrvl/sd8897_uapsta_cros.bin"
|
||||
|
||||
#define BLOCK_MODE 1
|
||||
#define BYTE_MODE 0
|
||||
|
|
|
@ -0,0 +1,71 @@
|
|||
From patchwork Mon Aug 19 23:10:21 2013
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
MIME-Version: 1.0
|
||||
Content-Transfer-Encoding: 7bit
|
||||
Subject: mwifiex: do not create AP and P2P interfaces upon driver loading
|
||||
From: Bing Zhao <bzhao@marvell.com>
|
||||
X-Patchwork-Id: 2846729
|
||||
Message-Id: <1376953821-32188-1-git-send-email-bzhao@marvell.com>
|
||||
To: <linux-wireless@vger.kernel.org>
|
||||
Cc: "John W. Linville" <linville@tuxdriver.com>,
|
||||
Avinash Patil <patila@marvell.com>, Amitkumar Karwar <akarwar@marvell.com>,
|
||||
Nishant Sarmukadam <nishants@marvell.com>,
|
||||
Frank Huang <frankh@marvell.com>, Bing Zhao <bzhao@marvell.com>
|
||||
Date: Mon, 19 Aug 2013 16:10:21 -0700
|
||||
|
||||
Bug 60747 - 1286:2044 [Microsoft Surface Pro]
|
||||
Marvell 88W8797 wifi show 3 interface under network
|
||||
https://bugzilla.kernel.org/show_bug.cgi?id=60747
|
||||
|
||||
This issue was also reported previously by OLPC and some folks from
|
||||
the community.
|
||||
|
||||
There are 3 network interfaces with different types being created
|
||||
when mwifiex driver is loaded:
|
||||
|
||||
1. mlan0 (infra. STA)
|
||||
2. uap0 (AP)
|
||||
3. p2p0 (P2P_CLIENT)
|
||||
|
||||
The Network Manager attempts to use all 3 interfaces above without
|
||||
filtering the managed interface type. As the result, 3 identical
|
||||
interfaces are displayed under network manager. If user happens to
|
||||
click on an entry under which its interface is uap0 or p2p0, the
|
||||
association will fail.
|
||||
|
||||
Work around it by removing the creation of AP and P2P interfaces
|
||||
at driver loading time. These interfaces can be added with 'iw' or
|
||||
other applications manually when they are needed.
|
||||
|
||||
Signed-off-by: Bing Zhao <bzhao@marvell.com>
|
||||
Signed-off-by: Avinash Patil <patila@marvell.com>
|
||||
|
||||
---
|
||||
drivers/net/wireless/mwifiex/main.c | 14 --------------
|
||||
1 file changed, 14 deletions(-)
|
||||
|
||||
diff --git a/drivers/net/wireless/mwifiex/main.c b/drivers/net/wireless/mwifiex/main.c
|
||||
index 3402bff..fd77833 100644
|
||||
--- a/drivers/net/wireless/mwifiex/main.c
|
||||
+++ b/drivers/net/wireless/mwifiex/main.c
|
||||
@@ -477,20 +477,6 @@ static void mwifiex_fw_dpc(const struct firmware *firmware, void *context)
|
||||
dev_err(adapter->dev, "cannot create default STA interface\n");
|
||||
goto err_add_intf;
|
||||
}
|
||||
-
|
||||
- /* Create AP interface by default */
|
||||
- if (!mwifiex_add_virtual_intf(adapter->wiphy, "uap%d",
|
||||
- NL80211_IFTYPE_AP, NULL, NULL)) {
|
||||
- dev_err(adapter->dev, "cannot create default AP interface\n");
|
||||
- goto err_add_intf;
|
||||
- }
|
||||
-
|
||||
- /* Create P2P interface by default */
|
||||
- if (!mwifiex_add_virtual_intf(adapter->wiphy, "p2p%d",
|
||||
- NL80211_IFTYPE_P2P_CLIENT, NULL, NULL)) {
|
||||
- dev_err(adapter->dev, "cannot create default P2P interface\n");
|
||||
- goto err_add_intf;
|
||||
- }
|
||||
rtnl_unlock();
|
||||
|
||||
mwifiex_drv_get_driver_version(adapter, fmt, sizeof(fmt) - 1);
|
Loading…
Reference in a new issue