extra/mplayer to 36498-2

This commit is contained in:
Kevin Mihelich 2013-11-02 08:38:44 +00:00
parent b4a38dd71d
commit 4d856d5ce6
4 changed files with 68 additions and 64 deletions

View file

@ -1,34 +0,0 @@
From 5194f95d39ffbb0a4a7b027d8f1b084436feb22c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Bart=C5=82omiej=20Piotrowski?= <b@bpiotrowski.pl>
Date: Sun, 14 Jul 2013 10:51:11 +0200
Subject: [PATCH] demux_gif: declare missing PrintGifError
Apparently it has been removed from newer Giflib releases.
---
libmpdemux/demux_gif.c | 10 ++++++++++
1 file changed, 10 insertions(+)
diff --git a/libmpdemux/demux_gif.c b/libmpdemux/demux_gif.c
index eee7a85..3d761c0 100644
--- a/libmpdemux/demux_gif.c
+++ b/libmpdemux/demux_gif.c
@@ -44,6 +44,16 @@ typedef struct {
#define GIF_SIGNATURE (('G' << 16) | ('I' << 8) | 'F')
+static void PrintGifError(void)
+{
+ char *Err = GifErrorString();
+
+ if (Err != NULL)
+ fprintf(stderr, "\nGIF-LIB error: %s.\n", Err);
+ else
+ fprintf(stderr, "\nGIF-LIB undefined error %d.\n", GifError());
+}
+
#ifndef CONFIG_GIF_TVT_HACK
// not supported by certain versions of the library
static int my_read_gif(GifFileType *gif, uint8_t *buf, int len)
--
1.8.3.2

View file

@ -1,4 +1,4 @@
# $Id: PKGBUILD 152229 2012-03-05 09:55:27Z ibiru $
# $Id$
# Maintainer : Ionut Biru <ibiru@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
@ -9,33 +9,41 @@
pkgbase=mplayer
pkgname=('mplayer' 'mencoder')
pkgver=36285
pkgrel=5
pkgver=36498
pkgrel=3
arch=('i686' 'x86_64')
makedepends=('libxxf86dga' 'libxxf86vm' 'libmad' 'cdparanoia' 'libxinerama' 'sdl' 'lame' 'libtheora' 'xvidcore' 'libmng' 'libxss' 'libgl' 'smbclient'
'aalib' 'jack' 'libcaca' 'x264' 'faac' 'faad2' 'lirc-utils' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr' 'libdca' 'a52dec' 'schroedinger' 'libvpx'
'libpulse' 'fribidi' 'unzip' 'mesa' 'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass' 'libbluray' 'libcdio-paranoia' 'subversion')
makedepends=(
'libxxf86dga' 'libxxf86vm' 'libmad' 'libxinerama' 'sdl' 'lame' 'libtheora'
'xvidcore' 'libmng' 'libxss' 'libgl' 'smbclient' 'aalib' 'jack' 'libcaca'
'x264' 'faac' 'faad2' 'lirc-utils' 'libxvmc' 'enca' 'libvdpau' 'opencore-amr'
'libdca' 'a52dec' 'schroedinger' 'libvpx' 'libpulse' 'fribidi' 'unzip' 'mesa'
'live-media' 'yasm' 'git' 'fontconfig' 'mpg123' 'ladspa' 'libass' 'libbluray'
'libcdio-paranoia' 'opus'
)
license=('GPL')
url="http://www.mplayerhq.hu/"
url='http://www.mplayerhq.hu/'
options=('!buildflags' '!emptydirs')
source=(ftp://mirrors.kernel.org/archlinux/other/packages/$pkgbase/$pkgbase-$pkgver.tar.xz
source=(ftp://ftp.archlinux.org/other/packages/$pkgbase/$pkgbase-$pkgver.tar.xz
http://ffmpeg.org/releases/ffmpeg-2.1.tar.bz2
mplayer.desktop
cdio-includes.patch
0001-demux_gif-declare-missing-PrintGifError.patch)
md5sums=('5f96e829d711e7d1ea65e324710dca50'
'c0d6ef795cf6de48e3b87ff7c23f0319'
include-samba-4.0.patch)
md5sums=('8b856e8833d910b6e38b04bb8453d0dc'
'4ec1cedd4c7753512462f70b347c338a'
'62f44a58f072b2b1a3c3d3e4976d64b3'
'7b5be7191aafbea64218dc4916343bbc'
'12a2a5b79849d57eab60a1bfec2978c4')
'868a92bdef148df7f38bfa992b26ce9d')
prepare() {
cd "$srcdir/$pkgbase-$pkgver"
cd $pkgbase-$pkgver
patch -p0 -i ../cdio-includes.patch
patch -p1 -i ../include-samba-4.0.patch
patch -Np0 -i ../cdio-includes.patch
patch -Np1 -i ../0001-demux_gif-declare-missing-PrintGifError.patch
mv ../ffmpeg-2.1 ./ffmpeg
}
build() {
cd "$srcdir/$pkgbase-$pkgver"
cd $pkgbase-$pkgver
./configure --prefix=/usr \
--enable-armv5te \
@ -53,9 +61,10 @@ build() {
--enable-xvmc \
--enable-radio \
--enable-radio-capture \
--enable-smb \
--language=all \
--confdir=/etc/mplayer
[ "$CARCH" = "i686" ] && sed 's|-march=i486|-march=i686|g' -i config.mak
--confdir=/etc/mplayer
[[ "$CARCH" = "i686" ]] && sed 's|-march=i486|-march=i686|g' -i config.mak
make
}
@ -64,28 +73,44 @@ package_mplayer() {
pkgdesc="A movie player for linux"
install=mplayer.install
backup=('etc/mplayer/codecs.conf' 'etc/mplayer/input.conf')
depends=('desktop-file-utils' 'ttf-dejavu' 'enca' 'libxss' 'a52dec' 'libvpx' 'lirc-utils' 'x264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig' 'libgl'
'libxinerama' 'libvdpau' 'libpulse' 'smbclient' 'xvidcore' 'opencore-amr' 'jack' 'cdparanoia' 'libmad' 'sdl' 'libtheora' 'libcaca' 'libxxf86dga' 'fribidi'
'libjpeg' 'faac' 'faad2' 'libxvmc' 'schroedinger' 'mpg123' 'libass' 'libxxf86vm' 'libbluray' 'libcdio-paranoia')
cd "$srcdir/$pkgbase-$pkgver"
depends=(
'desktop-file-utils' 'ttf-dejavu' 'enca' 'libxss' 'a52dec' 'libvpx'
'lirc-utils' 'x264' 'libmng' 'libdca' 'aalib' 'lame' 'fontconfig'
'libgl' 'libxinerama' 'libvdpau' 'libpulse' 'smbclient' 'xvidcore'
'opencore-amr' 'jack' 'libmad' 'sdl' 'libtheora' 'libcaca' 'libxxf86dga'
'fribidi' 'libjpeg' 'faac' 'faad2' 'libxvmc' 'schroedinger' 'mpg123'
'libass' 'libxxf86vm' 'libbluray' 'libcdio-paranoia' 'opus'
)
cd $pkgbase-$pkgver
make DESTDIR="$pkgdir" install-mplayer install-mplayer-man
install -Dm644 etc/{codecs.conf,input.conf,example.conf} "$pkgdir/etc/mplayer/"
install -Dm644 etc/{codecs.conf,input.conf,example.conf} \
"$pkgdir/etc/mplayer/"
install -dm755 "$pkgdir/usr/share/mplayer/"
ln -s /usr/share/fonts/TTF/DejaVuSans.ttf "$pkgdir/usr/share/mplayer/subfont.ttf"
ln -s /usr/share/fonts/TTF/DejaVuSans.ttf \
"$pkgdir/usr/share/mplayer/subfont.ttf"
rm -rf "$pkgdir/usr/share/mplayer/font"
#desktop file FS#14770
install -Dm644 "$srcdir/mplayer.desktop" "$pkgdir/usr/share/applications/mplayer.desktop"
install -Dm644 etc/mplayer256x256.png "$pkgdir/usr/share/pixmaps/mplayer.png"
install -Dm644 "$srcdir/mplayer.desktop" \
"$pkgdir/usr/share/applications/mplayer.desktop"
install -Dm644 etc/mplayer256x256.png \
"$pkgdir/usr/share/pixmaps/mplayer.png"
}
package_mencoder() {
pkgdesc="Free command line video decoding, encoding and filtering tool"
depends=('enca' 'a52dec' 'libvpx' 'x264' 'libmng' 'libdca' 'bzip2' 'lame' 'alsa-lib' 'fontconfig' 'giflib' 'libpng' 'smbclient' 'xvidcore' 'opencore-amr' 'cdparanoia'
'libmad' 'libtheora' 'fribidi' 'libjpeg' 'faac' 'faad2' 'schroedinger' 'mpg123' 'libass' 'libbluray' 'libcdio-paranoia' 'libvorbis')
depends=(
'enca' 'a52dec' 'libvpx' 'x264' 'libmng' 'libdca' 'bzip2' 'lame'
'alsa-lib' 'fontconfig' 'giflib' 'libpng' 'smbclient' 'xvidcore'
'opencore-amr' 'libmad' 'libtheora' 'fribidi' 'libjpeg' 'faac' 'faad2'
'schroedinger' 'mpg123' 'libass' 'libbluray' 'libcdio-paranoia'
'libvorbis' 'opus'
)
cd "$srcdir/$pkgbase-$pkgver"
cd $pkgbase-$pkgver
make DESTDIR="$pkgdir" install-mencoder install-mencoder-man
find "$pkgdir/usr/share/man" -name mplayer.1 -exec rename mplayer.1 mencoder.1 {} +
}

View file

@ -0,0 +1,12 @@
diff -rupN a/stream/stream_smb.c b/stream/stream_smb.c
--- a/stream/stream_smb.c 2013-03-16 13:38:34.000000000 +0000
+++ b/stream/stream_smb.c 2013-10-31 20:05:32.473947926 +0000
@@ -18,7 +18,7 @@
#include "config.h"
-#include <libsmbclient.h>
+#include <samba-4.0/libsmbclient.h>
#include <unistd.h>
#include "mp_msg.h"

View file

@ -19,3 +19,4 @@ Terminal=false
NoDisplay=true
Categories=GTK;AudioVideo;Audio;Video;Player;TV;
MimeType=application/ogg;application/x-ogg;application/sdp;application/smil;application/x-smil;application/streamingmedia;application/x-streamingmedia;application/vnd.rn-realmedia;application/vnd.rn-realmedia-vbr;audio/aac;audio/x-aac;audio/m4a;audio/x-m4a;audio/mp1;audio/x-mp1;audio/mp2;audio/x-mp2;audio/mp3;audio/x-mp3;audio/mpeg;audio/x-mpeg;audio/mpegurl;audio/x-mpegurl;audio/mpg;audio/x-mpg;audio/rn-mpeg;audio/scpls;audio/x-scpls;audio/vnd.rn-realaudio;audio/wav;audio/x-pn-windows-pcm;audio/x-realaudio;audio/x-pn-realaudio;audio/x-ms-wma;audio/x-pls;audio/x-wav;video/mpeg;video/x-mpeg;video/x-mpeg2;video/mp4;video/msvideo;video/x-msvideo;video/quicktime;video/vnd.rn-realvideo;video/x-ms-afs;video/x-ms-asf;video/x-ms-wmv;video/x-ms-wmx;video/x-ms-wvxvideo;video/x-avi;video/x-fli;video/x-flv;video/x-theora;video/x-matroska;
X-KDE-Protocols=http,ftp,smb