mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-06 23:47:10 +00:00
community/seamonkey to 2.49.3-1
This commit is contained in:
parent
52ce2141bb
commit
4d9a8f02cb
5 changed files with 12 additions and 106 deletions
|
@ -7,7 +7,7 @@
|
|||
highmem=1
|
||||
|
||||
pkgname=seamonkey
|
||||
pkgver=2.49.2
|
||||
pkgver=2.49.3
|
||||
pkgrel=1
|
||||
pkgdesc="SeaMonkey internet suite"
|
||||
arch=('x86_64')
|
||||
|
@ -19,20 +19,16 @@ optdepends=('gst-plugins-base: vorbis decoding, ogg demuxing'
|
|||
'gst-plugins-good: webm and mp4 demuxing'
|
||||
'gst-plugins-ugly: h.264 decoding')
|
||||
url="http://www.seamonkey-project.org/"
|
||||
source=(https://archive.mozilla.org/pub/mozilla.org/seamonkey/releases/$pkgver/source/seamonkey-$pkgver.source.tar.xz
|
||||
source=("https://archive.mozilla.org/pub/mozilla.org/seamonkey/releases/$pkgver/source/seamonkey-$pkgver.source.tar.xz"
|
||||
mozconfig
|
||||
seamonkey-2.0-lang.patch
|
||||
rhbz-966424.patch
|
||||
mozbug1323209.patch
|
||||
mozbug1329272.patch
|
||||
patch-bug1435212.xz
|
||||
no-crmf.diff
|
||||
xulrunner-27.0-build-arm.patch)
|
||||
sha256sums=('09fc9f8b1817a901b4e0d7635701ab50236885821d73694ac21615c8d911b575'
|
||||
sha256sums=('1823ed983bbc62e40f622288d5b24be9214ff28f15bf3f21028cc992fa96484b'
|
||||
'da8cc2001ae77f2b357d267f9f8d3d7e48c7d37b99ff3fb73fbbfc0b9329744a'
|
||||
'ab19d10fbd6258aec37ab5e5efb12429814b2c24a1193284a48dd654311b4e2e'
|
||||
'746cb474c5a2c26fc474256e430e035e604b71b27df1003d4af85018fa263f4a'
|
||||
'87fb92e45f161d47b9e3ca31bcce60555bc33d633116dab4baa3bfba6ad965c4'
|
||||
'33c7031781357faf5fba7140d7723bf301c1569068922477742ac958ee82e62b'
|
||||
'dce68858694f820a9a1fc2428038a88ea00b4835cea0778734db794fea3bb21a'
|
||||
'fb85a538044c15471c12cf561d6aa74570f8de7b054a7063ef88ee1bdfc1ccbb'
|
||||
'bc83b8a51c81a401da2fbe1f7cd0843248c32607d3a51119585df074d797922e')
|
||||
|
||||
|
@ -44,14 +40,9 @@ prepare() {
|
|||
# FS#48404
|
||||
#echo "ac_add_options --enable-gstreamer=1.0" >> .mozconfig
|
||||
|
||||
# https://bugs.archlinux.org/task/41689
|
||||
#patch -Np1 -d mozilla -i ../../rhbz-966424.patch
|
||||
|
||||
# Support NSS 3.28
|
||||
#patch -Np1 -d mozilla -i ../../mozbug1323209.patch
|
||||
|
||||
# Bugfix for icu detection
|
||||
#patch -Np1 -d mozilla -i ../../mozbug1329272.patch
|
||||
# ffmpeg 4.0 patch from freebsd
|
||||
# https://github.com/freebsd/freebsd-ports/blob/master/www/seamonkey/files/patch-bug1435212
|
||||
patch -Np1 -d mozilla -i ../../patch-bug1435212
|
||||
|
||||
# Don't exit with error when some libs are missing which we have in
|
||||
# system.
|
||||
|
@ -66,6 +57,10 @@ prepare() {
|
|||
# work around from FS#54395
|
||||
patch -Np1 -d mozilla -i ../../no-crmf.diff
|
||||
sed -i "s/'crmf',//" mozilla/security/manager/ssl/moz.build
|
||||
sed -i 's/^.*-lcrmf/#&/' mozilla/config/external/nss/crmf/moz.build
|
||||
sed -i 's/ -lcrmf"/"/' mozilla/old-configure.in.orig
|
||||
sed -i 's/ -lcrmf"/"/' mozilla/old-configure
|
||||
sed -i 's/SDK_LIBS = crmf/SDK_LIBS = /' mozilla/config/external/nss/Makefile.in
|
||||
|
||||
[[ $CARCH != "aarch64" ]] && echo "ac_add_options --disable-elf-hack" >> .mozconfig
|
||||
LDFLAGS+=" -Wl,--no-keep-memory -Wl,--reduce-memory-overheads"
|
||||
|
|
|
@ -1,35 +0,0 @@
|
|||
|
||||
# HG changeset patch
|
||||
# User Franziskus Kiefer <franziskuskiefer@gmail.com>
|
||||
# Date 1469717280 -7200
|
||||
# Node ID 361ac226da2a83516db8d4e4c5b41a69b3ba754f
|
||||
# Parent 5d5d3ef04f3f77bb95616f56c129256a89f57831
|
||||
Bug 1290037 - Update keybits in H2, r=mt
|
||||
|
||||
MozReview-Commit-ID: 35oWoDMqe1Y
|
||||
|
||||
diff --git a/netwerk/protocol/http/Http2Session.cpp b/netwerk/protocol/http/Http2Session.cpp
|
||||
--- a/netwerk/protocol/http/Http2Session.cpp
|
||||
+++ b/netwerk/protocol/http/Http2Session.cpp
|
||||
@@ -3544,18 +3544,18 @@ Http2Session::ConfirmTLSProfile()
|
||||
RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
|
||||
}
|
||||
|
||||
uint32_t keybits = ssl->GetKEAKeyBits();
|
||||
if (kea == ssl_kea_dh && keybits < 2048) {
|
||||
LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to DH %d < 2048\n",
|
||||
this, keybits));
|
||||
RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
|
||||
- } else if (kea == ssl_kea_ecdh && keybits < 256) { // 256 bits is "security level" of 128
|
||||
- LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 256\n",
|
||||
+ } else if (kea == ssl_kea_ecdh && keybits < 224) { // see rfc7540 9.2.1.
|
||||
+ LOG3(("Http2Session::ConfirmTLSProfile %p FAILED due to ECDH %d < 224\n",
|
||||
this, keybits));
|
||||
RETURN_SESSION_ERROR(this, INADEQUATE_SECURITY);
|
||||
}
|
||||
|
||||
int16_t macAlgorithm = ssl->GetMACAlgorithmUsed();
|
||||
LOG3(("Http2Session::ConfirmTLSProfile %p MAC Algortihm (aead==6) %d\n",
|
||||
this, macAlgorithm));
|
||||
if (macAlgorithm != nsISSLSocketControl::SSL_MAC_AEAD) {
|
||||
|
|
@ -1,31 +0,0 @@
|
|||
|
||||
# HG changeset patch
|
||||
# User Daniel Stenberg <daniel@haxx.se>
|
||||
# Date 1484000700 -3600
|
||||
# Node ID ebcbf47a83e7d3b89460cf1c991b6be5a79a967b
|
||||
# Parent 0759511f24e1b8d42acf5e9612f3ab91715842c2
|
||||
Bug 1329272 - add bracket for sed 4.3 compliance, r=glandium
|
||||
|
||||
diff --git a/build/autoconf/icu.m4 b/build/autoconf/icu.m4
|
||||
--- a/build/autoconf/icu.m4
|
||||
+++ b/build/autoconf/icu.m4
|
||||
@@ -64,17 +64,17 @@ if test -n "$USE_ICU"; then
|
||||
icudir="$_topsrcdir/intl/icu/source"
|
||||
if test ! -d "$icudir"; then
|
||||
icudir="$_topsrcdir/../../intl/icu/source"
|
||||
if test ! -d "$icudir"; then
|
||||
AC_MSG_ERROR([Cannot find the ICU directory])
|
||||
fi
|
||||
fi
|
||||
|
||||
- version=`sed -n 's/^[[:space:]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
|
||||
+ version=`sed -n 's/^[[[:space:]]]*#[[:space:]]*define[[:space:]][[:space:]]*U_ICU_VERSION_MAJOR_NUM[[:space:]][[:space:]]*\([0-9][0-9]*\)[[:space:]]*$/\1/p' "$icudir/common/unicode/uvernum.h"`
|
||||
if test x"$version" = x; then
|
||||
AC_MSG_ERROR([cannot determine icu version number from uvernum.h header file $lineno])
|
||||
fi
|
||||
MOZ_ICU_VERSION="$version"
|
||||
|
||||
# TODO: the l is actually endian-dependent
|
||||
# We could make this set as 'l' or 'b' for little or big, respectively,
|
||||
# but we'd need to check in a big-endian version of the file.
|
||||
|
BIN
community/seamonkey/patch-bug1435212.xz
Normal file
BIN
community/seamonkey/patch-bug1435212.xz
Normal file
Binary file not shown.
|
@ -1,23 +0,0 @@
|
|||
--- a/toolkit/modules/CertUtils.jsm
|
||||
+++ b/toolkit/modules/CertUtils.jsm
|
||||
@@ -170,17 +170,19 @@ this.checkCert =
|
||||
issuerCert = issuerCert.QueryInterface(Ci.nsIX509Cert3);
|
||||
var tokenNames = issuerCert.getAllTokenNames({});
|
||||
|
||||
if (!tokenNames || !tokenNames.some(isBuiltinToken))
|
||||
throw new Ce(certNotBuiltInErr, Cr.NS_ERROR_ABORT);
|
||||
}
|
||||
|
||||
function isBuiltinToken(tokenName) {
|
||||
- return tokenName == "Builtin Object Token";
|
||||
+ return tokenName == "Builtin Object Token" ||
|
||||
+ tokenName == "Default Trust" ||
|
||||
+ tokenName == "System Trust";
|
||||
}
|
||||
|
||||
/**
|
||||
* This class implements nsIBadCertListener. Its job is to prevent "bad cert"
|
||||
* security dialogs from being shown to the user. It is better to simply fail
|
||||
* if the certificate is bad. See bug 304286.
|
||||
*
|
||||
* @param aAllowNonBuiltInCerts (optional)
|
Loading…
Reference in a new issue