mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
core/gcc to 4.6.0-4
This commit is contained in:
parent
41b21fc977
commit
4def714b3e
6 changed files with 160 additions and 189 deletions
|
@ -1,42 +1,44 @@
|
|||
# $Id: PKGBUILD 107993 2011-01-28 20:01:16Z allan $
|
||||
# $Id: PKGBUILD 121304 2011-04-30 13:23:58Z allan $
|
||||
# Maintainer: Allan McRae <allan@archlinux.org>
|
||||
|
||||
# toolchain build order: linux-api-headers->glibc->binutils->gcc->binutils->glibc
|
||||
# NOTE: libtool requires rebuilt with each new gcc version
|
||||
|
||||
# PlugApps: Kevin Mihelich
|
||||
# - removed ada, disabled checks at end of build, removed gnat (ada stuff) from gcc packaging, removed ada package
|
||||
# - CHOST in makepkg.conf must be set to arm-unknown-linux-gnueabi, or plan to fail
|
||||
# - disabled make check at the end of build(), too much stress, kills plugs :(
|
||||
# ALARM: Kevin Mihelich <kevin@plugapps.com>
|
||||
# - removed ada, go languages
|
||||
# - removed gnat (ada stuff) from gcc packaging
|
||||
# - removed ada and go packages
|
||||
# - disabled make check, too much stress, kills plugs :(
|
||||
# - specifid build host, disabled distcc and ccache, make -j1
|
||||
|
||||
plugrel=1
|
||||
noautobuild=1
|
||||
|
||||
pkgname=('gcc' 'gcc-libs' 'gcc-fortran' 'gcc-objc')
|
||||
pkgver=4.5.2
|
||||
pkgrel=6
|
||||
_snapshot=4.5-20110127
|
||||
_libstdcppmanver=4.5.2 # Note: check source directory name when updating this
|
||||
pkgver=4.6.0
|
||||
pkgrel=4
|
||||
_snapshot=4.6-20110429
|
||||
_libstdcppmanver=20110201 # Note: check source directory name when updating this
|
||||
pkgdesc="The GNU Compiler Collection"
|
||||
arch=('i686' 'x86_64')
|
||||
license=('GPL' 'LGPL' 'custom')
|
||||
license=('GPL' 'LGPL' 'FDL' 'custom')
|
||||
url="http://gcc.gnu.org"
|
||||
makedepends=('binutils>=2.21' 'libmpc' 'cloog-ppl>=0.15.9-2' 'elfutils' 'dejagnu')
|
||||
options=('!libtool' '!emptydirs')
|
||||
source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-{core,g++,fortran,objc,testsuite}-${pkgver}.tar.bz2
|
||||
ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-{core,g++,fortran,objc,testsuite}-${_snapshot}.tar.bz2
|
||||
ftp://gcc.gnu.org/pub/gcc/libstdc++/doxygen/libstdc++-api-${_libstdcppmanver}.man.tar.bz2
|
||||
makedepends=('binutils>=2.21' 'libmpc' 'cloog' 'ppl' 'dejagnu')
|
||||
options=('!libtool' '!emptydirs' '!distcc' '!ccache')
|
||||
source=(#ftp://gcc.gnu.org/pub/gcc/releases/gcc-${pkgver}/gcc-{core,g++,fortran,objc,go,testsuite}-${pkgver}.tar.bz2
|
||||
ftp://gcc.gnu.org/pub/gcc/snapshots/${_snapshot}/gcc-{core,g++,fortran,objc,go,testsuite}-${_snapshot}.tar.bz2
|
||||
ftp://gcc.gnu.org/pub/gcc/libstdc++/doxygen/libstdc++-api.${_libstdcppmanver}.man.tar.bz2
|
||||
gcc_pure64.patch
|
||||
gcc-hash-style-both.patch)
|
||||
md5sums=('7dbdf06186dc98955221b2f7b987645b'
|
||||
'4893036a98d8bedf44fe0741dfec6e1f'
|
||||
'c741c614e975c858cffb9e78b0b5124f'
|
||||
'b141fadc984cc0c1c0f15feb16db14e5'
|
||||
'daffd2ba5917a263cdff5f38dcf8c323'
|
||||
'2776eab5ebb7f9cc62dd2199a3a24382'
|
||||
md5sums=('fa586a5634ae3b462c5fb2d55160b14f'
|
||||
'2591b1fad977f7bd6136c9ac1298ef04'
|
||||
'366f93c1867f35c8860b42965efde955'
|
||||
'21779792ef7e0ed7abef611160b0099c'
|
||||
'f66ef8597b99961eda7573df505ea354'
|
||||
'3d89dd233ceb6a837d14ee6b940a43ed'
|
||||
'1e9fd2eaf0ee47ea64e82c48998f1999'
|
||||
'4030ee1c08dd1e843c0225b772360e76'
|
||||
'6fd395bacbd7b6e47c7b74854b478363')
|
||||
|
||||
'4df25b623799b148a0703eaeec8fdf3f')
|
||||
|
||||
if [ -n "${_snapshot}" ]; then
|
||||
_basedir="${srcdir}/gcc-${_snapshot}"
|
||||
|
@ -47,9 +49,6 @@ fi
|
|||
build() {
|
||||
cd ${_basedir}
|
||||
|
||||
# "Add" ppl-0.11 compatibility
|
||||
sed -i "/ppl_minor_version=/s#10#11#" configure
|
||||
|
||||
# Do not install libiberty
|
||||
sed -i 's/install_to_$(INSTALL_DEST) //' libiberty/Makefile.in
|
||||
|
||||
|
@ -65,23 +64,34 @@ build() {
|
|||
|
||||
cd ${srcdir}
|
||||
mkdir gcc-build && cd gcc-build
|
||||
|
||||
# ALARM: Specify build host types
|
||||
[[ $CARCH == "arm" ]] && CONFIGFLAG="--host=arm-unknown-linux-gnueabi --build=arm-unknown-linux-gnueabi"
|
||||
[[ $CARCH == "armv7" ]] && CONFIGFLAG="--host=armv7l-unknown-linux-gnueabi --build=armv7l-unknown-linux-gnueabi"
|
||||
|
||||
${_basedir}/configure --prefix=/usr \
|
||||
--enable-languages=c,c++,fortran,objc,obj-c++ \
|
||||
--enable-shared --enable-threads=posix --enable-__cxa_atexit \
|
||||
--enable-clocale=gnu --enable-gnu-unique-object \
|
||||
--enable-lto --enable-plugin \
|
||||
--enable-gold --with-plugin-ld=ld.gold \
|
||||
--disable-multilib --disable-libstdcxx-pch \
|
||||
--with-system-zlib --with-ppl \
|
||||
--with-cloog --with-cloog-include=/usr/include/cloog-ppl \
|
||||
--libdir=/usr/lib --libexecdir=/usr/lib \
|
||||
--mandir=/usr/share/man --infodir=/usr/share/info \
|
||||
--host=arm-unknown-linux-gnueabi --build=arm-unknown-linux-gnueabi
|
||||
make
|
||||
--with-bugurl=https://bugs.archlinux.org/ \
|
||||
--enable-languages=c,c++,fortran,lto,objc,obj-c++ \
|
||||
--enable-shared --enable-threads=posix \
|
||||
--with-system-zlib --enable-__cxa_atexit \
|
||||
--disable-libunwind-exceptions --enable-clocale=gnu \
|
||||
--enable-gnu-unique-object --enable-linker-build-id \
|
||||
--with-ppl --enable-cloog-backend=isl \
|
||||
--enable-lto --enable-gold --enable-ld=default \
|
||||
--enable-plugin --with-plugin-ld=ld.gold \
|
||||
--disable-multilib --disable-libstdcxx-pch \
|
||||
--enable-checking=release $CONFIGFLAG
|
||||
make -j1
|
||||
}
|
||||
|
||||
check() {
|
||||
cd gcc-build
|
||||
|
||||
# increase stack size to prevent test failures
|
||||
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=31827
|
||||
#ulimit -s 32768
|
||||
ulimit -s 32768
|
||||
|
||||
# do not abort on error as some are "expected"
|
||||
#make -k check || true
|
||||
|
@ -103,11 +113,12 @@ package_gcc-libs()
|
|||
make -j1 -C $CHOST/libstdc++-v3/po DESTDIR=${pkgdir} install
|
||||
make -j1 -C $CHOST/libgomp DESTDIR=${pkgdir} install-info
|
||||
|
||||
make -j1 DESTDIR=${pkgdir} install-target-libquadmath
|
||||
make -j1 DESTDIR=${pkgdir} install-target-libgfortran
|
||||
|
||||
make -j1 DESTDIR=${pkgdir} install-target-libobjc
|
||||
# I thought I said to only install the lib...
|
||||
rm -rf ${pkgdir}/usr/lib/gcc/
|
||||
|
||||
# remove unnecessary files installed by install-target-{libquadmath,libgfortran,libobjc}
|
||||
rm -rf ${pkgdir}/usr/lib/{gcc/,libgfortran.spec}
|
||||
|
||||
# remove static libraries
|
||||
find ${pkgdir} -name *.a -delete
|
||||
|
@ -120,21 +131,26 @@ package_gcc-libs()
|
|||
package_gcc()
|
||||
{
|
||||
pkgdesc="The GNU Compiler Collection - C and C++ frontends"
|
||||
depends=('binutils>=2.20.1' 'libmpc>=0.8.1-2' 'cloog-ppl>=0.15.9-2' 'elfutils')
|
||||
depends=('binutils>=2.20.1' 'libmpc>=0.8.1-2' 'cloog' 'ppl')
|
||||
groups=('base-devel')
|
||||
install=gcc.install
|
||||
|
||||
cd gcc-build
|
||||
|
||||
# much, much easier to install the lot and clean-up the mess
|
||||
# unfortunately it is much, much easier to install the lot and clean-up the mess...
|
||||
make -j1 DESTDIR=${pkgdir} install
|
||||
rm -f $pkgdir/usr/bin/{*gfortran*}
|
||||
rm -f $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/finclude,include/objc}/*
|
||||
rm -f $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/{cc1obj{,plus},f951,gnat1,libgfortranbegin.a}
|
||||
rm -f $pkgdir/usr/lib/{*.so*,lib{gfortran,objc}.a}
|
||||
rm -f $pkgdir/usr/share/info/{gfortran,gnat*,libgomp}.info
|
||||
rm -f $pkgdir/usr/bin/{{$CHOST-,}gfortran,{$CHOST-,}gccgo}
|
||||
rm -f $pkgdir/usr/lib/*.so*
|
||||
rm -f $pkgdir/usr/lib/lib{ffi,gfortran,go{,begin},objc,quadmath}.a
|
||||
rm -f $pkgdir/usr/lib/libgfortran.spec
|
||||
rm -rf $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/{finclude,include/objc}
|
||||
rm -f $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/include/{ffi{,target}.h,quadmath{,_weak}.h}
|
||||
rm -f $pkgdir/usr/lib/gcc/$CHOST/${pkgver}/{cc1obj{,plus},f951,go1,libgfortranbegin.a}
|
||||
rm -rf $pkgdir/usr/lib/go
|
||||
rm -f $pkgdir/usr/share/info/{gccgo,gfortran,libgomp,libquadmath}.info
|
||||
rm -f $pkgdir/usr/share/locale/{de,fr}/LC_MESSAGES/libstdc++.mo
|
||||
rm -f $pkgdir/usr/share/man/man1/gfortran.1
|
||||
rm -f $pkgdir/usr/share/man/man1/{gccgo,gfortran}.1
|
||||
rm -f $pkgdir/usr/share/man/man3/ffi*
|
||||
|
||||
# many packages require these symlinks
|
||||
install -dm755 ${pkgdir}/lib
|
||||
|
@ -173,8 +189,7 @@ EOF
|
|||
|
||||
# install the libstdc++ man pages
|
||||
install -dm755 ${pkgdir}/usr/share/man/man3
|
||||
install -m644 ${srcdir}/libstdc++-api-${_libstdcppmanver}.man/man3/* \
|
||||
${pkgdir}/usr/share/man/man3/
|
||||
install -m644 ${srcdir}/man/man3/* ${pkgdir}/usr/share/man/man3/
|
||||
|
||||
# Install Runtime Library Exception
|
||||
install -Dm644 ${_basedir}/COPYING.RUNTIME \
|
||||
|
@ -188,13 +203,15 @@ package_gcc-fortran()
|
|||
install=gcc-fortran.install
|
||||
|
||||
cd gcc-build
|
||||
make -j1 DESTDIR=${pkgdir} install-target-libquadmath
|
||||
make -j1 DESTDIR=$pkgdir install-target-libgfortran
|
||||
make -j1 -C $CHOST/libgomp DESTDIR=$pkgdir install-nodist_fincludeHEADERS
|
||||
make -j1 -C gcc DESTDIR=$pkgdir fortran.install-{common,man,info}
|
||||
install -Dm755 gcc/f951 $pkgdir/usr/lib/gcc/$CHOST/$pkgver/f951
|
||||
|
||||
# remove libraries included in gcc-libs
|
||||
rm -f ${pkgdir}/usr/lib/libgfortran.so*
|
||||
rm -f ${pkgdir}/usr/lib/lib{gfortran,quadmath}.so*
|
||||
rm -f ${pkgdir}/usr/share/info/libquadmath.info
|
||||
|
||||
# Install Runtime Library Exception
|
||||
install -Dm644 ${_basedir}/COPYING.RUNTIME \
|
||||
|
@ -218,4 +235,3 @@ package_gcc-objc()
|
|||
install -Dm644 ${_basedir}/COPYING.RUNTIME \
|
||||
${pkgdir}/usr/share/licenses/gcc-objc/RUNTIME.LIBRARY.EXCEPTION
|
||||
}
|
||||
|
||||
|
|
|
@ -18,5 +18,3 @@ pre_remove() {
|
|||
install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
|
||||
done
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
||||
|
|
|
@ -14,5 +14,3 @@ pre_remove() {
|
|||
[ -x usr/bin/install-info ] || return 0
|
||||
install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
||||
|
|
|
@ -1,47 +1,6 @@
|
|||
#! /bin/sh -e
|
||||
|
||||
# DP: Link using --hash-style=both (alpha, amd64, ia64, i386, powerpc, ppc64, s390, sparc)
|
||||
|
||||
dir=
|
||||
if [ $# -eq 3 -a "$2" = '-d' ]; then
|
||||
pdir="-d $3"
|
||||
dir="$3/"
|
||||
elif [ $# -ne 1 ]; then
|
||||
echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
|
||||
exit 1
|
||||
fi
|
||||
case "$1" in
|
||||
-patch)
|
||||
patch $pdir -f --no-backup-if-mismatch -p0 < $0
|
||||
#cd ${dir}gcc && autoconf
|
||||
;;
|
||||
-unpatch)
|
||||
patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
|
||||
#rm ${dir}gcc/configure
|
||||
;;
|
||||
*)
|
||||
echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
|
||||
exit 1
|
||||
esac
|
||||
exit 0
|
||||
|
||||
2006-07-11 Jakub Jelinek <jakub@redhat.com>
|
||||
|
||||
* config/i386/linux.h (LINK_SPEC): Add --hash-style=both.
|
||||
* config/i386/linux64.h (LINK_SPEC): Likewise.
|
||||
* config/rs6000/sysv4.h (LINK_OS_LINUX_SPEC): Likewise.
|
||||
* config/rs6000/linux64.h (LINK_OS_LINUX_SPEC32,
|
||||
LINK_OS_LINUX_SPEC64): Likewise.
|
||||
* config/s390/linux.h (LINK_SPEC): Likewise.
|
||||
* config/ia64/linux.h (LINK_SPEC): Likewise.
|
||||
* config/sparc/linux.h (LINK_SPEC): Likewise.
|
||||
* config/sparc/linux64.h (LINK_SPEC, LINK_ARCH32_SPEC,
|
||||
LINK_ARCH64_SPEC): Likewise.
|
||||
* config/alpha/linux-elf.h (LINK_SPEC): Likewise.
|
||||
|
||||
--- gcc/config/alpha/linux-elf.h.orig 2007-08-04 08:55:58.000000000 +0200
|
||||
+++ gcc/config/alpha/linux-elf.h 2007-09-01 15:47:26.605865578 +0200
|
||||
@@ -39,7 +39,7 @@
|
||||
--- gcc/config/alpha/linux-elf.h.orig 2010-12-09 23:27:07.000000000 +1000
|
||||
+++ gcc/config/alpha/linux-elf.h 2011-03-11 10:01:47.770000457 +1000
|
||||
@@ -41,7 +41,7 @@
|
||||
|
||||
#define ELF_DYNAMIC_LINKER LINUX_DYNAMIC_LINKER
|
||||
|
||||
|
@ -50,8 +9,68 @@ exit 0
|
|||
%{O*:-O3} %{!O*:-O1} \
|
||||
%{shared:-shared} \
|
||||
%{!shared: \
|
||||
--- gcc/config/s390/linux.h.orig 2007-08-04 08:55:59.000000000 +0200
|
||||
+++ gcc/config/s390/linux.h 2007-09-01 15:47:26.605865578 +0200
|
||||
--- gcc/config/i386/linux64.h.orig 2011-03-03 08:35:36.000000000 +1000
|
||||
+++ gcc/config/i386/linux64.h 2011-03-11 10:01:47.770000457 +1000
|
||||
@@ -78,7 +78,7 @@
|
||||
%{!mno-sse2avx:%{mavx:-msse2avx}} %{msse2avx:%{!mavx:-msse2avx}}"
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "%{" SPEC_64 ":-m elf_x86_64} %{" SPEC_32 ":-m elf_i386} \
|
||||
+#define LINK_SPEC "%{" SPEC_64 ":-m elf_x86_64} %{" SPEC_32 ":-m elf_i386} --hash-style=both \
|
||||
%{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!static: \
|
||||
--- gcc/config/i386/linux.h.orig 2011-01-15 04:45:06.000000000 +1000
|
||||
+++ gcc/config/i386/linux.h 2011-03-11 10:01:47.770000457 +1000
|
||||
@@ -104,7 +104,7 @@
|
||||
{ "dynamic_linker", LINUX_DYNAMIC_LINKER }
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "-m %(link_emulation) %{shared:-shared} \
|
||||
+#define LINK_SPEC "-m %(link_emulation) --hash-style=both %{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
--- gcc/config/ia64/linux.h.orig 2010-12-09 23:27:07.000000000 +1000
|
||||
+++ gcc/config/ia64/linux.h 2011-03-11 10:01:47.770000457 +1000
|
||||
@@ -64,7 +64,7 @@
|
||||
#define GLIBC_DYNAMIC_LINKER "/lib/ld-linux-ia64.so.2"
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "\
|
||||
+#define LINK_SPEC "--hash-style=both \
|
||||
%{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!static: \
|
||||
--- gcc/config/rs6000/linux64.h.orig 2011-02-11 03:30:10.000000000 +1000
|
||||
+++ gcc/config/rs6000/linux64.h 2011-03-11 10:03:34.280000457 +1000
|
||||
@@ -389,11 +389,11 @@
|
||||
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER64, UCLIBC_DYNAMIC_LINKER64)
|
||||
|
||||
|
||||
-#define LINK_OS_LINUX_SPEC32 "-m elf32ppclinux %{!shared: %{!static: \
|
||||
+#define LINK_OS_LINUX_SPEC32 "-m elf32ppclinux --hash-style=both %{!shared: %{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
-dynamic-linker " LINUX_DYNAMIC_LINKER32 "}}"
|
||||
|
||||
-#define LINK_OS_LINUX_SPEC64 "-m elf64ppc %{!shared: %{!static: \
|
||||
+#define LINK_OS_LINUX_SPEC64 "-m elf64ppc --hash-style=both %{!shared: %{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
-dynamic-linker " LINUX_DYNAMIC_LINKER64 "}}"
|
||||
|
||||
--- gcc/config/rs6000/sysv4.h.orig 2011-01-28 04:36:03.000000000 +1000
|
||||
+++ gcc/config/rs6000/sysv4.h 2011-03-11 10:01:47.773333792 +1000
|
||||
@@ -830,7 +830,7 @@
|
||||
#define LINUX_DYNAMIC_LINKER \
|
||||
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER, UCLIBC_DYNAMIC_LINKER)
|
||||
|
||||
-#define LINK_OS_LINUX_SPEC "-m elf32ppclinux %{!shared: %{!static: \
|
||||
+#define LINK_OS_LINUX_SPEC "-m elf32ppclinux --hash-style=both %{!shared: %{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
-dynamic-linker " LINUX_DYNAMIC_LINKER "}}"
|
||||
|
||||
--- gcc/config/s390/linux.h.orig 2010-12-09 23:27:07.000000000 +1000
|
||||
+++ gcc/config/s390/linux.h 2011-03-11 10:01:47.770000457 +1000
|
||||
@@ -77,7 +77,7 @@
|
||||
|
||||
#undef LINK_SPEC
|
||||
|
@ -61,103 +80,43 @@ exit 0
|
|||
%{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{static:-static} \
|
||||
--- gcc/config/sparc/linux.h.orig 2007-08-04 08:56:01.000000000 +0200
|
||||
+++ gcc/config/sparc/linux.h 2007-09-01 15:47:26.605865578 +0200
|
||||
@@ -132,7 +132,7 @@
|
||||
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "-m elf32_sparc -Y P,/usr/lib %{shared:-shared} \
|
||||
+#define LINK_SPEC "-m elf32_sparc --hash-style=both -Y P,/usr/lib %{shared:-shared} \
|
||||
%{!mno-relax:%{!r:-relax}} \
|
||||
%{!shared: \
|
||||
%{!ibcs: \
|
||||
--- gcc/config/sparc/linux64.h.orig 2007-08-04 08:56:01.000000000 +0200
|
||||
+++ gcc/config/sparc/linux64.h 2007-09-01 15:47:26.605865578 +0200
|
||||
@@ -166,7 +166,7 @@
|
||||
--- gcc/config/sparc/linux64.h.orig 2011-02-17 23:57:21.000000000 +1000
|
||||
+++ gcc/config/sparc/linux64.h 2011-03-11 10:01:47.770000457 +1000
|
||||
@@ -113,7 +113,7 @@
|
||||
{ "link_arch_default", LINK_ARCH_DEFAULT_SPEC }, \
|
||||
{ "link_arch", LINK_ARCH_SPEC },
|
||||
|
||||
-#define LINK_ARCH32_SPEC "-m elf32_sparc -Y P,%R/usr/lib %{shared:-shared} \
|
||||
+#define LINK_ARCH32_SPEC "-m elf32_sparc --hash-style=both -Y P,%R/usr/lib %{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!ibcs: \
|
||||
%{!static: \
|
||||
@@ -175,7 +175,7 @@
|
||||
%{static:-static}}} \
|
||||
%{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
@@ -121,7 +121,7 @@
|
||||
%{static:-static}} \
|
||||
"
|
||||
|
||||
-#define LINK_ARCH64_SPEC "-m elf64_sparc -Y P,%R/usr/lib64 %{shared:-shared} \
|
||||
+#define LINK_ARCH64_SPEC "-m elf64_sparc --hash-style=both -Y P,%R/usr/lib64 %{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!ibcs: \
|
||||
%{!static: \
|
||||
@@ -256,7 +256,7 @@
|
||||
%{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
@@ -193,7 +193,7 @@
|
||||
#else /* !SPARC_BI_ARCH */
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "-m elf64_sparc -Y P,%R/usr/lib64 %{shared:-shared} \
|
||||
+#define LINK_SPEC "-m elf64_sparc --hash-style=both -Y P,%R/usr/lib64 %{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!ibcs: \
|
||||
%{!static: \
|
||||
--- gcc/config/i386/linux.h.orig 2007-08-04 08:56:07.000000000 +0200
|
||||
+++ gcc/config/i386/linux.h 2007-09-01 15:47:26.605865578 +0200
|
||||
@@ -108,7 +108,7 @@
|
||||
{ "dynamic_linker", LINUX_DYNAMIC_LINKER }
|
||||
%{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
--- gcc/config/sparc/linux.h.orig 2011-01-27 06:30:12.000000000 +1000
|
||||
+++ gcc/config/sparc/linux.h 2011-03-11 10:01:47.770000457 +1000
|
||||
@@ -74,7 +74,7 @@
|
||||
#define GLIBC_DYNAMIC_LINKER "/lib/ld-linux.so.2"
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "-m %(link_emulation) %{shared:-shared} \
|
||||
+#define LINK_SPEC "-m %(link_emulation) --hash-style=both %{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!ibcs: \
|
||||
%{!static: \
|
||||
--- gcc/config/i386/linux64.h.orig 2007-08-04 08:56:07.000000000 +0200
|
||||
+++ gcc/config/i386/linux64.h 2007-09-01 15:48:27.336781690 +0200
|
||||
@@ -65,7 +65,7 @@
|
||||
#endif
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "%{" SPEC_64 ":-m elf_x86_64} %{" SPEC_32 ":-m elf_i386} \
|
||||
+#define LINK_SPEC "%{" SPEC_64 ":-m elf_x86_64} %{" SPEC_32 ":-m elf_i386} --hash-style=both \
|
||||
%{shared:-shared} \
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "-m elf32_sparc -Y P,/usr/lib %{shared:-shared} \
|
||||
+#define LINK_SPEC "-m elf32_sparc --hash-style=both -Y P,/usr/lib %{shared:-shared} \
|
||||
%{!mno-relax:%{!r:-relax}} \
|
||||
%{!shared: \
|
||||
%{!static: \
|
||||
--- gcc/config/ia64/linux.h.orig 2006-12-12 18:59:53.000000000 +0100
|
||||
+++ gcc/config/ia64/linux.h 2007-09-01 15:47:26.605865578 +0200
|
||||
@@ -40,7 +40,7 @@
|
||||
#define GLIBC_DYNAMIC_LINKER "/lib/ld-linux-ia64.so.2"
|
||||
|
||||
#undef LINK_SPEC
|
||||
-#define LINK_SPEC "\
|
||||
+#define LINK_SPEC "--hash-style=both \
|
||||
%{shared:-shared} \
|
||||
%{!shared: \
|
||||
%{!static: \
|
||||
--- gcc/config/rs6000/sysv4.h.orig 2007-08-08 23:37:49.000000000 +0200
|
||||
+++ gcc/config/rs6000/sysv4.h 2007-09-01 15:47:26.615865729 +0200
|
||||
@@ -901,7 +901,7 @@
|
||||
#define LINUX_DYNAMIC_LINKER \
|
||||
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER, UCLIBC_DYNAMIC_LINKER)
|
||||
|
||||
-#define LINK_OS_LINUX_SPEC "-m elf32ppclinux %{!shared: %{!static: \
|
||||
+#define LINK_OS_LINUX_SPEC "-m elf32ppclinux --hash-style=both %{!shared: %{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
%{!dynamic-linker:-dynamic-linker " LINUX_DYNAMIC_LINKER "}}}"
|
||||
|
||||
--- gcc/config/rs6000/linux64.h.orig 2007-08-04 08:56:12.000000000 +0200
|
||||
+++ gcc/config/rs6000/linux64.h 2007-09-01 15:47:26.615865729 +0200
|
||||
@@ -354,11 +354,11 @@
|
||||
CHOOSE_DYNAMIC_LINKER (GLIBC_DYNAMIC_LINKER64, UCLIBC_DYNAMIC_LINKER64)
|
||||
|
||||
|
||||
-#define LINK_OS_LINUX_SPEC32 "-m elf32ppclinux %{!shared: %{!static: \
|
||||
+#define LINK_OS_LINUX_SPEC32 "-m elf32ppclinux --hash-style=both %{!shared: %{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
%{!dynamic-linker:-dynamic-linker " LINUX_DYNAMIC_LINKER32 "}}}"
|
||||
|
||||
-#define LINK_OS_LINUX_SPEC64 "-m elf64ppc %{!shared: %{!static: \
|
||||
+#define LINK_OS_LINUX_SPEC64 "-m elf64ppc --hash-style=both %{!shared: %{!static: \
|
||||
%{rdynamic:-export-dynamic} \
|
||||
%{!dynamic-linker:-dynamic-linker " LINUX_DYNAMIC_LINKER64 "}}}"
|
||||
|
||||
|
|
|
@ -1,14 +1,16 @@
|
|||
infodir=usr/share/info
|
||||
file="libgomp.info"
|
||||
filelist=(libgomp.info libquadmath.info)
|
||||
|
||||
post_upgrade() {
|
||||
[ -x usr/bin/install-info ] || return 0
|
||||
install-info $infodir/$file.gz $infodir/dir 2> /dev/null
|
||||
for file in ${filelist[@]}; do
|
||||
install-info $infodir/$file.gz $infodir/dir 2> /dev/null
|
||||
done
|
||||
}
|
||||
|
||||
pre_remove() {
|
||||
[ -x usr/bin/install-info ] || return 0
|
||||
install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
|
||||
for file in ${filelist[@]}; do
|
||||
install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
|
||||
done
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
||||
|
|
|
@ -18,5 +18,3 @@ pre_remove() {
|
|||
install-info --delete $infodir/$file.gz $infodir/dir 2> /dev/null
|
||||
done
|
||||
}
|
||||
|
||||
# vim:set ts=2 sw=2 et:
|
||||
|
|
Loading…
Reference in a new issue