mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-28 22:57:37 +00:00
added extra/soundtouch 1.6.0-1
This commit is contained in:
parent
6715d1de46
commit
4df736e57a
2 changed files with 65 additions and 0 deletions
27
extra/soundtouch/01_remove_sse.patch
Normal file
27
extra/soundtouch/01_remove_sse.patch
Normal file
|
@ -0,0 +1,27 @@
|
||||||
|
Description: Remove -msse2 build option for gcc.
|
||||||
|
This flag is only available for amd64 and i386 archs.
|
||||||
|
Forwarded: yes
|
||||||
|
Bug-Debian: http://bugs.debian.org/479809
|
||||||
|
Last-Update: 2011-03-10
|
||||||
|
--- a/source/SoundTouch/Makefile.am
|
||||||
|
+++ b/source/SoundTouch/Makefile.am
|
||||||
|
@@ -36,7 +36,7 @@
|
||||||
|
# Note by authore: '-msse2' might not work in non-X86 compilations. If someone can
|
||||||
|
# fix this script to automatically check for CPU architecture, please submit a patch
|
||||||
|
# to me.
|
||||||
|
-AM_CXXFLAGS=-O3 -msse2 -fcheck-new -I../../include
|
||||||
|
+AM_CXXFLAGS=-O3 -fcheck-new -I../../include
|
||||||
|
|
||||||
|
|
||||||
|
# other linking flags to add
|
||||||
|
--- a/include/STTypes.h
|
||||||
|
+++ b/include/STTypes.h
|
||||||
|
@@ -93,7 +93,7 @@
|
||||||
|
/// routines compiled for whatever reason, you may disable these optimizations
|
||||||
|
/// to make the library compile.
|
||||||
|
|
||||||
|
- #define SOUNDTOUCH_ALLOW_X86_OPTIMIZATIONS 1
|
||||||
|
+ // #define SOUNDTOUCH_ALLOW_X86_OPTIMIZATIONS 1
|
||||||
|
|
||||||
|
#endif
|
||||||
|
|
38
extra/soundtouch/PKGBUILD
Normal file
38
extra/soundtouch/PKGBUILD
Normal file
|
@ -0,0 +1,38 @@
|
||||||
|
# $Id: PKGBUILD 136035 2011-08-21 23:31:51Z eric $
|
||||||
|
# Maintainer: Eric Bélanger <eric@archlinux.org>
|
||||||
|
|
||||||
|
# ALARM: Kevin Mihelich <kevin@plugapps.com>
|
||||||
|
# - removed upstream's x86 patches
|
||||||
|
# - added patch to pull sse flags from the build
|
||||||
|
# - --with-pic for v7h
|
||||||
|
|
||||||
|
plugrel=1
|
||||||
|
|
||||||
|
pkgname=soundtouch
|
||||||
|
pkgver=1.6.0
|
||||||
|
pkgrel=1
|
||||||
|
pkgdesc="An audio processing library"
|
||||||
|
arch=('i686' 'x86_64')
|
||||||
|
url="http://www.surina.net/soundtouch/"
|
||||||
|
license=('LGPL')
|
||||||
|
depends=('gcc-libs')
|
||||||
|
options=('!libtool')
|
||||||
|
source=(http://www.surina.net/soundtouch/${pkgname}-${pkgver}.tar.gz
|
||||||
|
01_remove_sse.patch)
|
||||||
|
|
||||||
|
build() {
|
||||||
|
cd "${srcdir}/${pkgname}"
|
||||||
|
patch -p1 -i "${srcdir}/01_remove_sse.patch"
|
||||||
|
|
||||||
|
[ "${CARCH}" = "armv7h" ] && CONFIGFLAG="--with-pic"
|
||||||
|
./bootstrap
|
||||||
|
./configure --prefix=/usr --enable-shared ${CONFIGFLAG}
|
||||||
|
make
|
||||||
|
}
|
||||||
|
|
||||||
|
package() {
|
||||||
|
cd "${srcdir}/${pkgname}"
|
||||||
|
make DESTDIR="${pkgdir}" pkgdocdir=/usr/share/doc/soundtouch install
|
||||||
|
}
|
||||||
|
md5sums=('aa1c63d4d67b033f044a6a48d2be5bdd'
|
||||||
|
'76442f1f6614be550c0ba1b031b606d8')
|
Loading…
Reference in a new issue