community/kodi to 14.2-4

This commit is contained in:
Kevin Mihelich 2015-05-26 21:51:01 +00:00
parent 1c9e73a958
commit 4e24a75c39
3 changed files with 59 additions and 16 deletions

View file

@ -21,23 +21,27 @@ pkgbase=kodi
pkgname=('kodi' 'kodi-eventclients')
pkgver=14.2
_codename=Helix
pkgrel=3
pkgrel=4
arch=('i686' 'x86_64')
url="http://kodi.tv"
license=('GPL2')
makedepends=(
'afpfs-ng' 'bluez-libs' 'boost' 'cmake' 'curl' 'cwiid' 'doxygen' 'git' 'glew'
'gperf' 'hicolor-icon-theme' 'jasper' 'java-runtime' 'libaacs' 'libass'
'libbluray' 'libcdio' 'libcec' 'libgl' 'libmariadbclient' 'libmicrohttpd'
'libmodplug' 'libmpeg2' 'libnfs' 'libplist' 'libpulse' 'libssh' 'libva'
'libxrandr' 'libxslt' 'lzo' 'nasm' 'nss-mdns' 'python2-pillow'
'python2-pybluez' 'python2-simplejson' 'rtmpdump' 'sdl2' 'sdl_image'
'shairplay' 'smbclient' 'swig' 'taglib' 'tinyxml' 'unzip' 'upower' 'yajl' 'zip'
'afpfs-ng' 'bluez-libs' 'boost' 'cmake' 'curl' 'cwiid' 'doxygen' 'ffmpeg'
'git' 'glew' 'gperf' 'hicolor-icon-theme' 'jasper' 'java-runtime' 'libaacs'
'libcdio' 'libcec' 'libgl' 'libmariadbclient' 'libmicrohttpd' 'libmpeg2'
'libnfs' 'libplist' 'libxrandr' 'libxslt' 'lzo' 'nasm' 'nss-mdns'
'python2-pillow' 'python2-pybluez' 'python2-simplejson' 'rtmpdump' 'sdl2'
'sdl_image' 'shairplay' 'smbclient' 'swig' 'taglib' 'tinyxml' 'unzip'
'upower' 'yajl' 'zip'
)
source=(
"$pkgname-$pkgver-$_codename.tar.gz::https://github.com/xbmc/xbmc/archive/$pkgver-$_codename.tar.gz"
"kodi-14.0-dvddemux-ffmpeg.patch"
"kodi-14.0-gcc5.patch"
)
sha256sums=('d9cb8590430a925fb789a5beb4da2695cdcd2d2500dd31126f3b77b31aa267f4')
sha256sums=('d9cb8590430a925fb789a5beb4da2695cdcd2d2500dd31126f3b77b31aa267f4'
'01453e18987b01ad40c9ae423a7e47422e537b648e74f5c942f132c37e6370f8'
'598f36cea0f63440e5755d88752552240fc5cd2b98e4f80a9feeb9605c917777')
prepare() {
cd "$srcdir/xbmc-$pkgver-$_codename"
@ -50,6 +54,9 @@ prepare() {
sed '/WiiRemote/d' -i tools/EventClients/Makefile.in
sed '/mkdir -p $(DESTDIR)$(bindir)/i \
install:' -i tools/EventClients/Makefile.in
patch -p0 -i "$srcdir/kodi-14.0-dvddemux-ffmpeg.patch"
patch -p1 -i "$srcdir/kodi-14.0-gcc5.patch"
}
build() {
@ -67,7 +74,7 @@ build() {
--disable-debug \
--enable-optimizations \
--enable-libbluray \
--enable-external-libraries \
--with-ffmpeg=shared \
--with-lirc-device=/run/lirc/lircd \
--disable-vaapi \
ac_cv_lib_bluetooth_hci_devid=no
@ -84,12 +91,10 @@ package_kodi() {
# depends expeced in FEH.py
# 'mesa-demos' 'xorg-xdpyinfo'
depends=(
'python2-pillow' 'python2-pybluez' 'python2-simplejson'
'mesa-demos' 'xorg-xdpyinfo'
'bluez-libs' 'fribidi' 'glew' 'hicolor-icon-theme' 'libcdio'
'libjpeg-turbo' 'libmariadbclient' 'libmicrohttpd' 'libpulse' 'libssh'
'libva' 'libxrandr' 'libxslt' 'lzo' 'sdl2' 'smbclient' 'taglib' 'tinyxml'
'yajl'
'python2-pillow' 'python2-pybluez' 'python2-simplejson' 'mesa-demos'
'xorg-xdpyinfo' 'bluez-libs' 'ffmpeg' 'glew' 'hicolor-icon-theme' 'libcdio'
'libjpeg-turbo' 'libmariadbclient' 'libmicrohttpd' 'libxrandr' 'libxslt'
'lzo' 'sdl2' 'smbclient' 'taglib' 'tinyxml' 'yajl'
)
optdepends=(
'afpfs-ng: Apple shares support'

View file

@ -0,0 +1,13 @@
--- xbmc/cores/dvdplayer/DVDDemuxers/DVDDemuxFFmpeg.cpp.orig 2014-08-01 11:18:24.000000000 -0500
+++ xbmc/cores/dvdplayer/DVDDemuxers/DVDDemuxFFmpeg.cpp 2014-08-24 15:36:34.844966866 -0500
@@ -519,10 +519,6 @@
void CDVDDemuxFFmpeg::Flush()
{
- // naughty usage of an internal ffmpeg function
- if (m_pFormatContext)
- av_read_frame_flush(m_pFormatContext);
-
m_currentPts = DVD_NOPTS_VALUE;
m_pkt.result = -1;

View file

@ -0,0 +1,25 @@
--- a/xbmc/screensavers/rsxs-0.9/lib/argp.h.orig 2015-03-26 13:25:20.000000000 -0500
+++ b/xbmc/screensavers/rsxs-0.9/lib/argp.h 2015-05-19 16:05:20.992493851 -0500
@@ -559,7 +559,7 @@
# endif
# ifndef ARGP_EI
-# define ARGP_EI extern __inline__
+# define ARGP_EI extern __inline__ __attribute__ ((gnu_inline))
# endif
ARGP_EI void
--- a/xbmc/screensavers/rsxs-0.9/lib/argp-fmtstream.h.orig 2015-03-26 13:25:20.000000000 -0500
+++ b/xbmc/screensavers/rsxs-0.9/lib/argp-fmtstream.h 2015-05-19 16:02:25.775456866 -0500
@@ -198,11 +198,7 @@
#endif
#ifndef ARGP_FS_EI
-#ifdef __clang__
#define ARGP_FS_EI extern inline __attribute__ ((__gnu_inline__))
-#else
-#define ARGP_FS_EI extern inline
-#endif
#endif
ARGP_FS_EI size_t