mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-02-16 23:57:11 +00:00
alarm/xf86-video-omapfb fix
This commit is contained in:
parent
435203a40a
commit
4e4190678e
8 changed files with 66 additions and 26 deletions
|
@ -1,7 +1,7 @@
|
|||
From 8fb7d0f99d4afbb574b30cb4f1e66a8f89d94ad5 Mon Sep 17 00:00:00 2001
|
||||
From 75cf4aad6f6e95bdbd7dbb16ec0f5abcf527c1ab Mon Sep 17 00:00:00 2001
|
||||
From: Koen Kooi <koen@dominion.thruhere.net>
|
||||
Date: Wed, 26 Jan 2011 12:04:36 +0100
|
||||
Subject: [PATCH 1/6] Revert "Set a large CRTC upper limit to not prune larger
|
||||
Subject: [PATCH 1/7] Revert "Set a large CRTC upper limit to not prune larger
|
||||
resolutions"
|
||||
|
||||
Picture is garbled after switching resolutions, so revert it.
|
||||
|
@ -37,5 +37,5 @@ index 9aaa52f..cbeff35 100644
|
|||
|
||||
|
||||
--
|
||||
1.8.0
|
||||
2.3.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 855c333ac0d16350f895f1d1b9391e9cbb0b6db4 Mon Sep 17 00:00:00 2001
|
||||
From 1b674f1f16bc43898865fa7ddfdb816692d18f4d Mon Sep 17 00:00:00 2001
|
||||
From: Koen Kooi <koen@dominion.thruhere.net>
|
||||
Date: Wed, 26 Jan 2011 13:27:20 +0100
|
||||
Subject: [PATCH 2/6] Revert "Set virtual size when configuring framebuffer"
|
||||
Subject: [PATCH 2/7] Revert "Set virtual size when configuring framebuffer"
|
||||
|
||||
Virtual size too big, so revert it.
|
||||
|
||||
|
@ -28,5 +28,5 @@ index cbeff35..9655db2 100644
|
|||
v.pixclock = KHZ2PICOS(mode->Clock ? mode->Clock : 56000);
|
||||
v.left_margin = mode->HTotal - mode->HSyncEnd;
|
||||
--
|
||||
1.8.0
|
||||
2.3.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 252f44c072d3447a32127fc9afe5d0d40f3c510e Mon Sep 17 00:00:00 2001
|
||||
From 8c154297978f1e79875f314647c3461d15353e9a Mon Sep 17 00:00:00 2001
|
||||
From: Koen Kooi <koen@dominion.thruhere.net>
|
||||
Date: Wed, 26 Jan 2011 13:20:20 +0100
|
||||
Subject: [PATCH 3/6] force 'plain' mode
|
||||
Subject: [PATCH 3/7] force 'plain' mode
|
||||
|
||||
The new DSS mode breaks XV, so force plain mode
|
||||
|
||||
|
@ -27,5 +27,5 @@ index 018e040..48aa09c 100644
|
|||
} else {
|
||||
ofb->dss = FALSE;
|
||||
--
|
||||
1.8.0
|
||||
2.3.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From cfa46b67f59115f6d8ef9414af60380749ff3eb3 Mon Sep 17 00:00:00 2001
|
||||
From 811a33882e980773459ca79c118759bad6eb1ce2 Mon Sep 17 00:00:00 2001
|
||||
From: Koen Kooi <koen@dominion.thruhere.net>
|
||||
Date: Wed, 26 Jan 2011 13:21:12 +0100
|
||||
Subject: [PATCH 4/6] blacklist tv out
|
||||
Subject: [PATCH 4/7] blacklist tv out
|
||||
|
||||
The tv-out gets added last and the driver tries to reconfigure dvi to TV resolutions, which fails. so blacklist it
|
||||
|
||||
|
@ -29,5 +29,5 @@ index 6cc52de..83cb711 100644
|
|||
}
|
||||
|
||||
--
|
||||
1.8.0
|
||||
2.3.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 8b1f697a60e35ab82fffdabfaefdb45e9a9df379 Mon Sep 17 00:00:00 2001
|
||||
From 85e4bdb8f375b343011d07e685a9cac9108f3734 Mon Sep 17 00:00:00 2001
|
||||
From: Eino-Ville Talvala <talvala@stanford.edu>
|
||||
Date: Tue, 23 Aug 2011 18:37:01 +0200
|
||||
Subject: [PATCH 5/6] Attempt to fix VRFB
|
||||
Subject: [PATCH 5/7] Attempt to fix VRFB
|
||||
|
||||
Upstream-Status: Pending
|
||||
|
||||
|
@ -321,5 +321,5 @@ index 1df651e..0fee2c6 100644
|
|||
return size;
|
||||
}
|
||||
--
|
||||
1.8.0
|
||||
2.3.0
|
||||
|
||||
|
|
|
@ -1,7 +1,7 @@
|
|||
From 803ecf2909949e6152f4a81b6cbb92a4430679ac Mon Sep 17 00:00:00 2001
|
||||
From 9bed77633b0b1c73cbce012664529a620ab3df37 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Jansa <Martin.Jansa@gmail.com>
|
||||
Date: Fri, 23 Nov 2012 00:31:06 +0100
|
||||
Subject: [PATCH 6/6] omapfb: port to new xserver video API
|
||||
Subject: [PATCH 6/7] omapfb: port to new xserver video API
|
||||
|
||||
Upstream-Status: Pending
|
||||
|
||||
|
@ -268,5 +268,5 @@ index 07989f5..486ffa4 100644
|
|||
xf86Msg(X_NOT_IMPLEMENTED, "%s\n", __FUNCTION__);
|
||||
}
|
||||
--
|
||||
1.8.0
|
||||
2.3.0
|
||||
|
||||
|
|
37
alarm/xf86-video-omapfb/0007-compat-for-newer-xorg.patch
Normal file
37
alarm/xf86-video-omapfb/0007-compat-for-newer-xorg.patch
Normal file
|
@ -0,0 +1,37 @@
|
|||
From 791b31abd4d1c76f04044195b60d62ee1e82e4e5 Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Sun, 15 Feb 2015 11:54:28 -0700
|
||||
Subject: [PATCH 7/7] compat for newer xorg
|
||||
|
||||
---
|
||||
src/omapfb-xv-blizzard.c | 1 +
|
||||
src/omapfb-xv-generic.c | 1 +
|
||||
2 files changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/omapfb-xv-blizzard.c b/src/omapfb-xv-blizzard.c
|
||||
index b71d2aa..d0328b9 100644
|
||||
--- a/src/omapfb-xv-blizzard.c
|
||||
+++ b/src/omapfb-xv-blizzard.c
|
||||
@@ -30,6 +30,7 @@
|
||||
* -
|
||||
*/
|
||||
|
||||
+#include <xorg-server.h>
|
||||
#include "xf86.h"
|
||||
#include "xf86_OSlib.h"
|
||||
#include "xf86xv.h"
|
||||
diff --git a/src/omapfb-xv-generic.c b/src/omapfb-xv-generic.c
|
||||
index b33f344..d8ea960 100644
|
||||
--- a/src/omapfb-xv-generic.c
|
||||
+++ b/src/omapfb-xv-generic.c
|
||||
@@ -25,6 +25,7 @@
|
||||
* Generic functions for the XV driver
|
||||
*/
|
||||
|
||||
+#include <xorg-server.h>
|
||||
#include "xf86.h"
|
||||
#include "xf86_OSlib.h"
|
||||
#include "xf86xv.h"
|
||||
--
|
||||
2.3.0
|
||||
|
|
@ -8,7 +8,7 @@ pkgname="xf86-video-omapfb"
|
|||
pkgver=0.1.1.1
|
||||
pkgrel=8
|
||||
arch=('armv7h')
|
||||
url="http://gitweb.pingu.fi/?p=xf86-video-omapfb.git"
|
||||
url="http://anonscm.debian.org/cgit/collab-maint/xf86-video-omapfb.git/"
|
||||
license=('GPL2')
|
||||
makedepends=('pkgconfig' 'xorg-server-devel' 'resourceproto' 'scrnsaverproto')
|
||||
options=('!libtool')
|
||||
|
@ -18,14 +18,16 @@ source=("http://archlinuxarm.org/builder/src/xf86-video-omapfb_0.1.1.1.tar.gz"
|
|||
"0003-force-plain-mode.patch"
|
||||
"0004-blacklist-tv-out.patch"
|
||||
"0005-Attempt-to-fix-VRFB.patch"
|
||||
"0006-omapfb-port-to-new-xserver-video-API.patch")
|
||||
"0006-omapfb-port-to-new-xserver-video-API.patch"
|
||||
"0007-compat-for-newer-xorg.patch")
|
||||
md5sums=('a9bca5424bd76d53b78826f9d5fa4abe'
|
||||
'f52826ee0feb5aefc92431df973a6ed2'
|
||||
'22d822068b570115a4613b73cb719ffd'
|
||||
'8e04b609ba12d094edecc2ada8335951'
|
||||
'1abeb90f138fc86015960a9269612e91'
|
||||
'2acd1c0448e4628353d084f0374c48b6'
|
||||
'4094ad2bb96ecd5c6faf51f09a7ce65b')
|
||||
'890884c69a2334d8c7e812c729af5b13'
|
||||
'723efe8327d43795e9a5b0efc6d7010d'
|
||||
'1cc90e32023eb989451ba0360becb96e'
|
||||
'8f322ad500ca6d73cbffa03dc8069db5'
|
||||
'66887007c4341ba693b46f90dc93e300'
|
||||
'198a41675ba379bb6545104270126f29'
|
||||
'2d7bb40047ebcb3997afa345d80f9e67')
|
||||
|
||||
prepare() {
|
||||
cd "${srcdir}/${pkgname}-${pkgver}"
|
||||
|
@ -35,6 +37,7 @@ prepare() {
|
|||
patch -p1 -i ../0004-blacklist-tv-out.patch
|
||||
patch -p1 -i ../0005-Attempt-to-fix-VRFB.patch
|
||||
patch -p1 -i ../0006-omapfb-port-to-new-xserver-video-API.patch
|
||||
patch -p1 -i ../0007-compat-for-newer-xorg.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue