extra/rust to 1.33.0-1

This commit is contained in:
Kevin Mihelich 2019-03-17 16:21:36 +00:00
parent fc5d734237
commit 4e43b45a05
2 changed files with 37 additions and 4 deletions

View file

@ -0,0 +1,30 @@
From c5f42fa1207dc6df476b55a9cdda439d8cfcba05 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Johannes=20L=C3=B6thberg?= <johannes@kyriasis.com>
Date: Thu, 14 Mar 2019 20:35:52 +0100
Subject: [PATCH] Revert 1c95f5a34c14f08d65cdd198827e3a2fcb63cf39 +
9452a8dfa3ba3575d5cf090a4e2305ee106d259e
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Johannes Löthberg <johannes@kyriasis.com>
---
src/librustc_codegen_llvm/debuginfo/metadata.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/librustc_codegen_llvm/debuginfo/metadata.rs b/src/librustc_codegen_llvm/debuginfo/metadata.rs
index 9f63038c36..553b952b56 100644
--- a/src/librustc_codegen_llvm/debuginfo/metadata.rs
+++ b/src/librustc_codegen_llvm/debuginfo/metadata.rs
@@ -1167,7 +1167,7 @@ fn use_enum_fallback(cx: &CodegenCx) -> bool {
// LLVM version 7 did not release with an important bug fix;
// but the required patch is in the LLVM 8. Rust LLVM reports
// 8 as well.
- || llvm_util::get_major_version() < 8;
+ || llvm_util::get_major_version() < 7;
}
// Describes the members of an enum value: An enum is described as a union of
--
2.20.1

View file

@ -15,8 +15,8 @@ highmem=1
pkgname=('rust' 'rust-docs')
epoch=1
pkgver=1.32.0
pkgrel=2
pkgver=1.33.0
pkgrel=1
pkgdesc='Systems programming language focused on safety, speed and concurrency'
url='https://www.rust-lang.org/'
@ -29,17 +29,20 @@ checkdepends=('procps-ng' 'gdb')
options=('!emptydirs')
source=("https://static.rust-lang.org/dist/rustc-$pkgver-src.tar.gz"{,.asc}
config.toml)
config.toml
0001-Revert-1c95f5a34c14f08d65cdd198827e3a2fcb63cf39-9452.patch)
sha256sums=('4c594c7712a0e7e8eae6526c464bf6ea1d82f77b4f61717c3fc28fb27ba2224a'
'SKIP'
'6a28c9768d0953d2774c7704d2bb293246c4733f2d4720e1ea441a0cd1763fb4')
'6a28c9768d0953d2774c7704d2bb293246c4733f2d4720e1ea441a0cd1763fb4'
'cf04a3c8ac0b4f5d786532e6e07a2f52cea2216d899be8d7c0b087aab78a2b68')
validpgpkeys=('108F66205EAEB0AAA8DD5E1C85AB96E6FA1BE5FE') # Rust Language (Tag and Release Signing Key) <rust-key@rust-lang.org>
prepare() {
cd "rustc-$pkgver-src"
cp "$srcdir"/config.toml config.toml
patch -p1 <"$srcdir"/0001-Revert-1c95f5a34c14f08d65cdd198827e3a2fcb63cf39-9452.patch
if [[ $CARCH == armv7h ]]; then
mkdir path