extra/firefox to 76.0-2

This commit is contained in:
Kevin Mihelich 2020-05-06 02:46:48 +00:00
parent e1e3c57df4
commit 4e4a13904a
3 changed files with 4 additions and 48 deletions

View file

@ -1,35 +0,0 @@
From 0447215abf836bbb8eef53aeccf029dd40bd1a52 Mon Sep 17 00:00:00 2001
From: Jeff Gilbert <jgilbert@mozilla.com>
Date: Sun, 12 Apr 2020 21:21:32 +0000
Subject: [PATCH] Bug 1623885 - Add "subsystem" to Mesa sandbox policy to fix
libdrm-2.4.101+. r=gcp, a=RyanVM
Differential Revision: https://phabricator.services.mozilla.com/D70579
---
.../linux/broker/SandboxBrokerPolicyFactory.cpp | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)
diff --git a/security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp b/security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp
index 3aa7cf27e353..0b3948ebd92e 100644
--- a/security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp
+++ b/security/sandbox/linux/broker/SandboxBrokerPolicyFactory.cpp
@@ -86,10 +86,12 @@ static void AddMesaSysfsPaths(SandboxBroker::Policy* aPolicy) {
// broker. To match this, allow the canonical paths.
UniqueFreePtr<char[]> realSysPath(realpath(sysPath.get(), nullptr));
if (realSysPath) {
- static const Array<const char*, 7> kMesaAttrSuffixes = {
- "revision", "vendor", "device", "subsystem_vendor",
- "subsystem_device", "uevent", "config"};
- for (const auto attrSuffix : kMesaAttrSuffixes) {
+ constexpr const char* kMesaAttrSuffixes[] = {
+ "config", "device", "revision",
+ "subsystem", "subsystem_device", "subsystem_vendor",
+ "uevent", "vendor",
+ };
+ for (const auto& attrSuffix : kMesaAttrSuffixes) {
nsPrintfCString attrPath("%s/%s", realSysPath.get(),
attrSuffix);
aPolicy->AddPath(rdonly, attrPath.get());
--
2.26.2

View file

@ -10,7 +10,7 @@ buildarch=12
highmem=1
pkgname=firefox
pkgver=75.0
pkgver=76.0
pkgrel=2
pkgdesc="Standalone web browser from mozilla.org"
arch=(x86_64)
@ -30,16 +30,14 @@ options=(!emptydirs !makeflags !strip)
source=(https://archive.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkgver.source.tar.xz{,.asc}
arm.patch
build-arm-libopus.patch
0001-Bug-1623885-Add-subsystem-to-Mesa-sandbox-policy-to-.patch
0001-Use-remoting-name-for-GDK-application-names.patch
$pkgname.desktop)
sha256sums=('bbb1054d8f2717c634480556d3753a8483986af7360e023bb6232df80b746b0f'
sha256sums=('3b7b97b0b0625fc6ec23ee28d425988c679d3a56f362d62fd3b225a5d50afdc8'
'SKIP'
'bc00516032330760444939c516a60c78f868631e1b37f075f0fe71a53737b966'
'2d4d91f7e35d0860225084e37ec320ca6cae669f6c9c8fe7735cdbd542e3a7c9'
'ebb169804750ddc10a4801ed6ddb37356331bbf76615f58eb29de2e6e15ee930'
'5f7ac724a5c5afd9322b1e59006f4170ea5354ca1e0e60dab08b7784c2d8463c'
'a9e5264257041c0b968425b5c97436ba48e8d294e1a0f02c59c35461ea245c33')
'298eae9de76ec53182f38d5c549d0379569916eebf62149f9d7f4a7edef36abf')
validpgpkeys=('14F26682D0916CDD81E37B6D61B7B526D98F0353') # Mozilla Software Releases <release@mozilla.com>
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@ -59,9 +57,6 @@ prepare() {
mkdir mozbuild
cd firefox-$pkgver
# https://bugs.archlinux.org/task/66185
patch -Np1 -i ../0001-Bug-1623885-Add-subsystem-to-Mesa-sandbox-policy-to-.patch
# https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
@ -103,10 +98,6 @@ ac_add_options --with-mozilla-api-keyfile=${PWD@Q}/mozilla-api-key
# ALARM
ac_add_options --disable-webrtc
# System libraries
ac_add_options --with-system-nspr
ac_add_options --with-system-nss
# Features
ac_add_options --enable-alsa
ac_add_options --enable-jack

View file

@ -117,7 +117,7 @@ Icon=firefox
Terminal=false
X-MultipleArgs=false
Type=Application
MimeType=text/html;text/xml;application/xhtml+xml;x-scheme-handler/http;x-scheme-handler/https;application/x-xpinstall;
MimeType=text/html;text/xml;application/xhtml+xml;x-scheme-handler/http;x-scheme-handler/https;application/x-xpinstall;application/pdf;application/json;
StartupNotify=true
StartupWMClass=firefox
Categories=Network;WebBrowser;