extra/boost to 1.47.0-1

This commit is contained in:
Kevin Mihelich 2011-07-30 18:07:37 -04:00
parent d1a1eaade7
commit 4e4fda7d28
3 changed files with 7 additions and 95 deletions

View file

@ -1,16 +0,0 @@
Index: libs/python/src/converter/builtin_converters.cpp
===================================================================
--- libs/python/src/converter/builtin_converters.cpp (revision 67279)
+++ libs/python/src/converter/builtin_converters.cpp (working copy)
@@ -431,7 +431,11 @@
if (!result.empty())
{
int err = PyUnicode_AsWideChar(
+#if PY_VERSION_HEX >= 0x03020000
+ intermediate
+#else
(PyUnicodeObject *)intermediate
+#endif
, &result[0]
, result.size());

View file

@ -1,10 +1,10 @@
# $Id: PKGBUILD 126799 2011-06-07 11:40:27Z ibiru $
# $Id: PKGBUILD 132748 2011-07-25 19:08:12Z ibiru $
# Maintainer: kevin <kevin@archlinux.org>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
# Contributor: Kritoke <kritoke@gamebox.net>
# Contributor: Luca Roccia <little_rock@users.sourceforge.net>
# PlugApps: Kevin Mihelich <kevin@plugapps.com>
# ALARM: Kevin Mihelich <kevin@plugapps.com>
# - changed _bindir to .linuxarm from .linuxx86
# - removed (optional) dep to openmpi - does not build on ARM
@ -12,19 +12,15 @@ plugrel=1
pkgbase=boost
pkgname=('boost-libs' 'boost')
pkgver=1.46.1
pkgver=1.47.0
_boostver=${pkgver//./_}
pkgrel=3
pkgrel=1
arch=('i686' 'x86_64')
url="http://www.boost.org/"
makedepends=('icu' 'python' 'python2' 'bzip2' 'zlib')
source=(http://downloads.sourceforge.net/sourceforge/${pkgbase}/${pkgbase}_${_boostver}.tar.gz
4994-compile-fix-for-Python32-v2.patch
boost-1.46.0-spirit.patch)
source=(http://downloads.sourceforge.net/sourceforge/${pkgbase}/${pkgbase}_${_boostver}.tar.gz)
license=('custom')
md5sums=('341e5d993b19d099bf1a548495ea91ec'
'cb59e8adbf2a45ef9264a2f4ab92b849'
'9d6e2f13fef23bf27d7bdddc104e182a')
md5sums=('ff180a5276bec773a7625cac7e2288e8')
_stagedir="${srcdir}/stagedir"
@ -36,7 +32,7 @@ build() {
echo "using mpi ;" >> build/v2/user-config.jam
# build bjam
cd "${srcdir}/${pkgbase}_${_boostver}/tools/build/v2/engine/src"
cd "${srcdir}/${pkgbase}_${_boostver}/tools/build/v2/engine"
./build.sh cc
_bindir="bin.linuxarm"
@ -61,10 +57,6 @@ build() {
# build libs
cd "${srcdir}/${pkgbase}_${_boostver}"
#python 3.2 support
#https://svn.boost.org/trac/boost/ticket/4994
patch -Np0 -i "${srcdir}/4994-compile-fix-for-Python32-v2.patch"
patch -Np0 -i "${srcdir}/boost-1.46.0-spirit.patch"
# default "minimal" install: "release link=shared,static
# runtime-link=shared threading=single,multi"
@ -83,11 +75,6 @@ build() {
--layout=system \
${MAKEFLAGS} \
install
# pyste is unmaintained: http://www.boost.org/doc/libs/1_46_0/libs/python/doc/index.html
# build pyste
#cd "${srcdir}/${pkgbase}_${_boostver}/libs/python/pyste/install"
#python2 setup.py install --root=${_stagedir} --optimize=1
}
package_boost() {

View file

@ -1,59 +0,0 @@
Index: boost/spirit/home/qi/nonterminal/detail/parameterized.hpp
===================================================================
--- boost/spirit/home/qi/nonterminal/detail/parameterized.hpp (revision 68724)
+++ boost/spirit/home/qi/nonterminal/detail/parameterized.hpp (revision 68725)
@@ -14,6 +14,7 @@
#include <boost/ref.hpp>
+#include <boost/spirit/home/support/handles_container.hpp>
#include <boost/spirit/home/qi/parser.hpp>
namespace boost { namespace spirit { namespace qi
@@ -59,4 +60,16 @@ namespace boost { namespace spirit { nam
};
}}}
+namespace boost { namespace spirit { namespace traits
+{
+ ///////////////////////////////////////////////////////////////////////////
+ template <typename Subject, typename Params, typename Attribute
+ , typename Context, typename Iterator>
+ struct handles_container<qi::parameterized_nonterminal<Subject, Params>
+ , Attribute, Context, Iterator>
+ : handles_container<typename remove_const<Subject>::type
+ , Attribute, Context, Iterator>
+ {};
+}}}
+
#endif
Index: boost/spirit/home/karma/nonterminal/detail/parameterized.hpp
===================================================================
--- boost/spirit/home/karma/nonterminal/detail/parameterized.hpp (revision 68724)
+++ boost/spirit/home/karma/nonterminal/detail/parameterized.hpp (revision 68725)
@@ -14,6 +14,7 @@
#include <boost/ref.hpp>
+#include <boost/spirit/home/support/handles_container.hpp>
#include <boost/spirit/home/karma/generator.hpp>
namespace boost { namespace spirit { namespace karma
@@ -60,4 +61,17 @@ namespace boost { namespace spirit { nam
};
}}}
+
+namespace boost { namespace spirit { namespace traits
+{
+ ///////////////////////////////////////////////////////////////////////////
+ template <typename Subject, typename Params, typename Attribute
+ , typename Context, typename Iterator>
+ struct handles_container<karma::parameterized_nonterminal<Subject, Params>
+ , Attribute, Context, Iterator>
+ : handles_container<typename remove_const<Subject>::type
+ , Attribute, Context, Iterator>
+ {};
+}}}
+
#endif