mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-27 23:44:04 +00:00
extra/mesa to 17.1.1-1
This commit is contained in:
parent
d8cff8fe43
commit
4eb96d1dfe
3 changed files with 4 additions and 95 deletions
|
@ -1,88 +0,0 @@
|
|||
From efa4f2ebc1e788c3f1cfcf3842058cf838171653 Mon Sep 17 00:00:00 2001
|
||||
From: Hans de Goede <hdegoede@redhat.com>
|
||||
Date: Mon, 20 Mar 2017 08:41:26 +0100
|
||||
Subject: [PATCH] glxglvnddispatch: Add missing dispatch for GetDriverConfig
|
||||
|
||||
Together with some fixes to xdriinfo this fixes xdriinfo not working
|
||||
with glvnd.
|
||||
|
||||
Since apps (xdriinfo) expect GetDriverConfig to work without going to
|
||||
need through the dance to setup a glxcontext (which is a reasonable
|
||||
expectation IMHO), the dispatch for this ends up significantly different
|
||||
then any other dispatch function.
|
||||
|
||||
This patch gets the job done, but I'm not really happy with how this
|
||||
patch turned out, suggestions for a better fix are welcome.
|
||||
|
||||
Cc: Kyle Brenneman <kbrenneman@nvidia.com>
|
||||
Signed-off-by: Hans de Goede <hdegoede@redhat.com>
|
||||
---
|
||||
src/glx/g_glxglvnddispatchfuncs.c | 18 ++++++++++++++++++
|
||||
src/glx/g_glxglvnddispatchindices.h | 1 +
|
||||
2 files changed, 19 insertions(+)
|
||||
|
||||
diff --git a/src/glx/g_glxglvnddispatchfuncs.c b/src/glx/g_glxglvnddispatchfuncs.c
|
||||
index b5e3398..040cdf8 100644
|
||||
--- a/src/glx/g_glxglvnddispatchfuncs.c
|
||||
+++ b/src/glx/g_glxglvnddispatchfuncs.c
|
||||
@@ -4,6 +4,7 @@
|
||||
*/
|
||||
#include <stdlib.h>
|
||||
|
||||
+#include "glxclient.h"
|
||||
#include "glxglvnd.h"
|
||||
#include "glxglvnddispatchfuncs.h"
|
||||
#include "g_glxglvnddispatchindices.h"
|
||||
@@ -50,6 +51,7 @@ const char * const __glXDispatchTableStrings[DI_LAST_INDEX] = {
|
||||
__ATTRIB(GetCurrentDisplayEXT),
|
||||
// glXGetCurrentDrawable implemented by libglvnd
|
||||
// glXGetCurrentReadDrawable implemented by libglvnd
|
||||
+ __ATTRIB(GetDriverConfig),
|
||||
// glXGetFBConfigAttrib implemented by libglvnd
|
||||
__ATTRIB(GetFBConfigAttribSGIX),
|
||||
__ATTRIB(GetFBConfigFromVisualSGIX),
|
||||
@@ -334,6 +336,21 @@ static Display *dispatch_GetCurrentDisplayEXT(void)
|
||||
|
||||
|
||||
|
||||
+static const char *dispatch_GetDriverConfig(const char *driverName)
|
||||
+{
|
||||
+ /*
|
||||
+ * The options are constant for a given driverName, so we do not need
|
||||
+ * a context (and apps expect to be able to call this without one).
|
||||
+ */
|
||||
+#if defined(GLX_DIRECT_RENDERING) && !defined(GLX_USE_APPLEGL)
|
||||
+ return glXGetDriverConfig(driverName);
|
||||
+#else
|
||||
+ return NULL;
|
||||
+#endif
|
||||
+}
|
||||
+
|
||||
+
|
||||
+
|
||||
static int dispatch_GetFBConfigAttribSGIX(Display *dpy, GLXFBConfigSGIX config,
|
||||
int attribute, int *value_return)
|
||||
{
|
||||
@@ -939,6 +956,7 @@ const void * const __glXDispatchFunctions[DI_LAST_INDEX + 1] = {
|
||||
__ATTRIB(DestroyGLXPbufferSGIX),
|
||||
__ATTRIB(GetContextIDEXT),
|
||||
__ATTRIB(GetCurrentDisplayEXT),
|
||||
+ __ATTRIB(GetDriverConfig),
|
||||
__ATTRIB(GetFBConfigAttribSGIX),
|
||||
__ATTRIB(GetFBConfigFromVisualSGIX),
|
||||
__ATTRIB(GetMscRateOML),
|
||||
diff --git a/src/glx/g_glxglvnddispatchindices.h b/src/glx/g_glxglvnddispatchindices.h
|
||||
index 05a2c8c..3ba50a7 100644
|
||||
--- a/src/glx/g_glxglvnddispatchindices.h
|
||||
+++ b/src/glx/g_glxglvnddispatchindices.h
|
||||
@@ -39,6 +39,7 @@ typedef enum __GLXdispatchIndex {
|
||||
DI_GetCurrentDisplayEXT,
|
||||
// GetCurrentDrawable implemented by libglvnd
|
||||
// GetCurrentReadDrawable implemented by libglvnd
|
||||
+ DI_GetDriverConfig,
|
||||
// GetFBConfigAttrib implemented by libglvnd
|
||||
DI_GetFBConfigAttribSGIX,
|
||||
DI_GetFBConfigFromVisualSGIX,
|
||||
--
|
||||
2.9.3
|
||||
|
|
@ -7,7 +7,7 @@
|
|||
|
||||
pkgbase=mesa
|
||||
pkgname=('mesa' 'libva-mesa-driver')
|
||||
pkgver=17.1.0
|
||||
pkgver=17.1.1
|
||||
pkgrel=1
|
||||
arch=('i686' 'x86_64')
|
||||
makedepends=('python2-mako' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dri3proto' 'presentproto'
|
||||
|
@ -18,13 +18,11 @@ license=('custom')
|
|||
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig}
|
||||
LICENSE
|
||||
0001-Fix-linkage-against-shared-glapi.patch
|
||||
0001-glxglvnddispatch-Add-missing-dispatch-for-GetDriverC.patch
|
||||
glvnd-fix-gl-dot-pc.patch)
|
||||
sha256sums=('cf234a6ed4764673886b6661553b54675776ef0898f774716173cec890ac3b17'
|
||||
0002-glvnd-fix-gl-dot-pc.patch)
|
||||
sha256sums=('aed503f94c0c1630a162a3e276f4ee12a86764cee4cb92338ea2dea99a04e7ef'
|
||||
'SKIP'
|
||||
'7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2'
|
||||
'c68d1522f9bce4ce31c92aa7a688da49f13043f5bb2254795b76dea8f47130b7'
|
||||
'4a0620f9197a65f830e3c512faba374a4bde45fee9e11f82321774c24d08232d'
|
||||
'64a77944a28026b066c1682c7258d02289d257b24b6f173a9f7580c48beed966')
|
||||
validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D') # Emil Velikov <emil.l.velikov@gmail.com>
|
||||
validpgpkeys+=('946D09B5E4C9845E63075FF1D961C596A7203456') # "Andres Gomez <tanty@igalia.com>"
|
||||
|
@ -34,9 +32,8 @@ prepare() {
|
|||
|
||||
# glvnd support patches - from Fedora
|
||||
# non-upstreamed ones
|
||||
patch -Np1 -i ../glvnd-fix-gl-dot-pc.patch
|
||||
patch -Np1 -i ../0001-Fix-linkage-against-shared-glapi.patch
|
||||
patch -Np1 -i ../0001-glxglvnddispatch-Add-missing-dispatch-for-GetDriverC.patch
|
||||
patch -Np1 -i ../0002-glvnd-fix-gl-dot-pc.patch
|
||||
|
||||
autoreconf -fiv
|
||||
}
|
||||
|
|
Loading…
Reference in a new issue