mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2024-11-08 22:45:43 +00:00
community/i2c-tools to 4.3-1
This commit is contained in:
parent
46798bd3fc
commit
4f0cc0d346
2 changed files with 26 additions and 13 deletions
|
@ -6,8 +6,8 @@
|
|||
# - !makeflags because concurrency fails
|
||||
|
||||
pkgname=i2c-tools
|
||||
pkgver=4.2
|
||||
pkgrel=3
|
||||
pkgver=4.3
|
||||
pkgrel=1
|
||||
pkgdesc="Heterogeneous set of I2C tools for Linux that used to be part of lm-sensors"
|
||||
arch=('x86_64')
|
||||
url="https://i2c.wiki.kernel.org/index.php/I2C_Tools"
|
||||
|
@ -22,30 +22,30 @@ source=(
|
|||
"https://www.kernel.org/pub/software/utils/i2c-tools/$pkgname-$pkgver.tar.sign"
|
||||
"$pkgname.sysusers"
|
||||
"45-i2c-tools.rules"
|
||||
"python-makefile.patch"
|
||||
)
|
||||
sha256sums=('37f2dabc7082d185903ff21d1f584b5dcb4dd2eb2c879bbd8d7c50ae900dacd6'
|
||||
sha256sums=('1f899e43603184fac32f34d72498fc737952dbc9c97a8dd9467fadfdf4600cf9'
|
||||
'SKIP'
|
||||
'bf5ee4f9876505628c5ce84e84e918c70d66be70b766d62bb138e294608ffbae'
|
||||
'af9dbdc771023cd04f5b0c638c30356e6a824b32f0c04ea61fe929c71122bccd')
|
||||
'af9dbdc771023cd04f5b0c638c30356e6a824b32f0c04ea61fe929c71122bccd'
|
||||
'2f512928ae4ad5cd3e2388b2391378f70b1d5f537f64ff5a0636e018d02d540e')
|
||||
validpgpkeys=(
|
||||
'7CA69F4460F1BDC41FD2C858A5526B9BB3CD4E6A' # Jean Delvare
|
||||
)
|
||||
|
||||
prepare() {
|
||||
cd "${pkgname}-${pkgver}"
|
||||
patch -Np1 < "$srcdir/python-makefile.patch"
|
||||
}
|
||||
|
||||
build() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
make
|
||||
make -C eepromer CFLAGS="$CFLAGS -I../include"
|
||||
cd py-smbus
|
||||
CPPFLAGS="$CPPFLAGS -I../include" python setup.py build
|
||||
make EXTRA="eeprog py-smbus"
|
||||
}
|
||||
|
||||
package() {
|
||||
cd ${pkgname}-${pkgver}
|
||||
make PREFIX="${pkgdir}/usr" sbindir="$pkgdir/usr/bin" install
|
||||
install -Dm755 eepromer/eeprom eepromer/eepromer "${pkgdir}/usr/bin"
|
||||
cd py-smbus
|
||||
python setup.py install --prefix "${pkgdir}/usr"
|
||||
|
||||
make EXTRA="eeprog py-smbus" PREFIX="${pkgdir}/usr" sbindir="$pkgdir/usr/bin" install
|
||||
install -Dm644 "${srcdir}/$pkgname.sysusers" "${pkgdir}/usr/lib/sysusers.d/$pkgname.conf"
|
||||
install -Dm644 "${srcdir}/45-i2c-tools.rules" "${pkgdir}/usr/lib/udev/rules.d/45-i2c-tools.rules"
|
||||
}
|
||||
|
|
13
community/i2c-tools/python-makefile.patch
Normal file
13
community/i2c-tools/python-makefile.patch
Normal file
|
@ -0,0 +1,13 @@
|
|||
diff --git a/py-smbus/Module.mk b/py-smbus/Module.mk
|
||||
index 04ceb64..1e2ded1 100644
|
||||
--- a/py-smbus/Module.mk
|
||||
+++ b/py-smbus/Module.mk
|
||||
@@ -22,7 +22,7 @@ clean-python:
|
||||
rm -rf py-smbus/build
|
||||
|
||||
install-python:
|
||||
- $(DISTUTILS) install
|
||||
+ $(DISTUTILS) install --prefix="$(PREFIX)"
|
||||
|
||||
all: all-python
|
||||
|
Loading…
Reference in a new issue