GD works from ABS, removed from Git

This commit is contained in:
Mike Staszel 2010-04-05 18:46:00 -05:00
parent d1ea302071
commit 4fc970920f
2 changed files with 0 additions and 34 deletions

View file

@ -1,22 +0,0 @@
# Maintainer: Eric Belanger <eric@archlinux.org>
pkgname=gd
pkgver=2.0.36RC1
pkgrel=3
pkgdesc="Library for the dynamic creation of images by programmers"
arch=('i686' 'x86_64')
url="http://www.libgd.org/"
license=('custom')
depends=('perl' 'libpng>=1.4.0' 'fontconfig' 'libjpeg>=8')
options=('!libtool')
source=(http://www.libgd.org/releases/${pkgname}-${pkgver}.tar.bz2 libpng14.patch)
md5sums=('e876979ca3130623a4e7866d9579171a'
'7921556f4960e8d66cf4fb67ea7101b5')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -Np1 -i ${srcdir}/libpng14.patch || return 1
./configure --prefix=/usr --without-xpm || return 1
make || return 1
make DESTDIR="${pkgdir}" install || return 1
install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING" || return 1
}

View file

@ -1,12 +0,0 @@
diff -Nur gd-2.0.36RC1.orig/gd_png.c gd-2.0.36RC1/gd_png.c
--- gd-2.0.36RC1.orig/gd_png.c 2007-11-27 10:30:34.000000000 +0200
+++ gd-2.0.36RC1/gd_png.c 2010-01-17 17:14:11.000000000 +0200
@@ -151,7 +151,7 @@
return NULL;
}
- if (!png_check_sig (sig, 8)) { /* bad signature */
+ if (png_sig_cmp (sig, 0, 8)) { /* bad signature */
return NULL; /* bad signature */
}