mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-03-09 00:17:31 +00:00
core/systemd: fix
This commit is contained in:
parent
20a2e19bef
commit
4fed9a148f
2 changed files with 0 additions and 31 deletions
|
@ -1,26 +0,0 @@
|
|||
From 5efc4609bdfb3db976f0e73f9da7148147d28eee Mon Sep 17 00:00:00 2001
|
||||
From: Kevin Mihelich <kevin@archlinuxarm.org>
|
||||
Date: Wed, 21 Mar 2018 17:26:15 +0000
|
||||
Subject: [PATCH] seccomp: include ARM cacheflush in @default
|
||||
|
||||
Whitelist the cacheflush system call, so that applications using it
|
||||
don't trigger a segfault when run under systemd-nspawn.
|
||||
---
|
||||
src/shared/seccomp-util.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/shared/seccomp-util.c b/src/shared/seccomp-util.c
|
||||
index 220658b3a..e244da0e4 100644
|
||||
--- a/src/shared/seccomp-util.c
|
||||
+++ b/src/shared/seccomp-util.c
|
||||
@@ -273,6 +273,7 @@ const SyscallFilterSet syscall_filter_sets[_SYSCALL_FILTER_SET_MAX] = {
|
||||
.name = "@default",
|
||||
.help = "System calls that are always permitted",
|
||||
.value =
|
||||
+ "cacheflush\0"
|
||||
"clock_getres\0"
|
||||
"clock_gettime\0"
|
||||
"clock_nanosleep\0"
|
||||
--
|
||||
2.16.2
|
||||
|
|
@ -28,7 +28,6 @@ validpgpkeys=('63CDA1E5D3FC22B998D20DD6327F26951A015CC4' # Lennart Poettering <
|
|||
source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
|
||||
"git+https://github.com/systemd/systemd#tag=v${pkgver%.*}?signed"
|
||||
'0001-Use-Arch-Linux-device-access-groups.patch'
|
||||
'0001-seccomp-include-ARM-cacheflush-in-default.patch'
|
||||
'initcpio-hook-udev'
|
||||
'initcpio-install-systemd'
|
||||
'initcpio-install-udev'
|
||||
|
@ -49,7 +48,6 @@ source=("git+https://github.com/systemd/systemd-stable#tag=${_tag}?signed"
|
|||
sha512sums=('SKIP'
|
||||
'SKIP'
|
||||
'e38c7c422c82953f9c2476a5ab8009d614cbec839e4088bff5db7698ddc84e3d8ed64f32ed323f57b1913c5c9703546f794996cb415ed7cdda930b627962a3c4'
|
||||
'df7ec8f840a54b404d1f3ab2708ae2a618820cb411b826128cf10b20ccdab057306446295c6b1c98a05ca0adb1b30d390dfb0156b52ea772978e1f1bf5135e09'
|
||||
'f0d933e8c6064ed830dec54049b0a01e27be87203208f6ae982f10fb4eddc7258cb2919d594cbfb9a33e74c3510cfd682f3416ba8e804387ab87d1a217eb4b73'
|
||||
'8e76f8334b95ce7fee9190f4a1016b16109f3a75b68635fc227b2b4791cf8179ef09b532b66b4ed885ddf98ed76befed3106f3c3088f1819ed8cdf4c13e0805a'
|
||||
'a25b28af2e8c516c3a2eec4e64b8c7f70c21f974af4a955a4a9d45fd3e3ff0d2a98b4419fe425d47152d5acae77d64e69d8d014a7209524b75a81b0edb10bf3a'
|
||||
|
@ -92,9 +90,6 @@ prepare() {
|
|||
|
||||
# Replace cdrom/dialout/tape groups with optical/uucp/storage
|
||||
patch -Np1 -i ../0001-Use-Arch-Linux-device-access-groups.patch
|
||||
|
||||
# seccomp: include ARM cacheflush in @default
|
||||
patch -Np1 -i ../0001-seccomp-include-ARM-cacheflush-in-default.patch
|
||||
}
|
||||
|
||||
build() {
|
||||
|
|
Loading…
Reference in a new issue