community/polymake to 3.1-2

This commit is contained in:
Kevin Mihelich 2017-06-06 12:26:37 +00:00
parent a9213e9fab
commit 4ff53243a7
2 changed files with 19 additions and 3 deletions

View file

@ -9,7 +9,7 @@ highmem=1
pkgname=polymake
pkgver=3.1
pkgrel=1
pkgrel=2
pkgdesc="Open source software for research in polyhedral geometry"
arch=(i686 x86_64)
url="https://polymake.org/"
@ -18,11 +18,14 @@ options=('!distcc')
depends=(mpfr perl-xml-writer perl-xml-libxml perl-xml-libxslt perl-term-readline-gnu perl-term-readkey)
makedepends=(normaliz cddlib lrs bliss-graphs ppl apache-ant boost singular)
optdepends=('singular: ideal library' 'ppl: polytope library' 'java-runtime: java module')
source=("https://polymake.org/lib/exe/fetch.php/download/polymake-$pkgver-minimal.tar.bz2")
sha256sums=('f751e3c34e5ee3a015a99d1151b357130f15878c0bcea82827a19a12009e7fc0')
source=("https://polymake.org/lib/exe/fetch.php/download/polymake-$pkgver-minimal.tar.bz2"
'gcc7.patch')
sha256sums=('f751e3c34e5ee3a015a99d1151b357130f15878c0bcea82827a19a12009e7fc0'
'e93c6d16a13b2701c999ff076fd6510f024b130cd47db2f86f096864b52ae37c')
prepare() {
cd polymake-$pkgver
patch -Np0 -i ../gcc7.patch
# fix lrs headers location
sed -e 's|lrslib.h|lrslib/lrslib.h|g' -i bundled/lrs/apps/polytope/src/lrs_interface.cc \
-i bundled/sympol/external/sympol/sympol/raycomputationlrs.cpp

View file

@ -0,0 +1,13 @@
--- lib/core/include/Graph.h.orig 2017-03-28 03:30:14.000000000 -0600
+++ lib/core/include/Graph.h 2017-03-28 21:33:36.040286583 -0600
@@ -709,8 +709,8 @@ public:
void swap(Table& t)
{
std::swap(R,t.R);
- std::swap(node_maps, t.node_maps);
- std::swap(edge_maps, t.edge_maps);
+ node_maps.swap(t.node_maps);
+ edge_maps.swap(t.edge_maps);
std::swap(n_nodes, t.n_nodes);
std::swap(free_node_id, t.free_node_id);
std::swap(free_edge_ids, t.free_edge_ids);