alarm/uboot-cubox-i to 2013.10-4; fix dtb subdir check as test -e doesn't work in this version of uboot

This commit is contained in:
moonman 2015-08-28 07:23:05 +00:00
parent bda45916e1
commit 500259a7fd
2 changed files with 5 additions and 7 deletions

View file

@ -6,7 +6,7 @@ buildarch=4
pkgbase=uboot-cubox-i
pkgname=('uboot-cubox-i')
pkgver=2013.10
pkgrel=3
pkgrel=4
arch=('armv7h')
url="http://git.denx.de/u-boot.git/"
license=('GPL')
@ -30,7 +30,7 @@ md5sums=('3417d53a913949fd80c052fc8662c2a4'
'8ed91e4257bfb7e0971fa988342537a3'
'629d34349b5652e2d4274ad89e1c4481'
'8087672256020417438b12ec4946e1cf'
'026cbdeee142187c6de8ae6713514ba9')
'e1487acbad44446e74a8825b4c88142c')
prepare() {
cd u-boot-imx6-${_commit}

View file

@ -9,16 +9,14 @@ diff -ruN a/include/configs/mx6_cubox-i.h b/include/configs/mx6_cubox-i.h
"console=ttymxc0\0" \
"splashpos=m,m\0" \
"fdt_high=0xffffffff\0" \
@@ -220,7 +221,11 @@
@@ -220,7 +221,9 @@
"fi;\0" \
"loadbootenv=load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${file_prefix}${bootenv};\0" \
"loadfdt=if test ${boottype} = mmc; then " \
- "load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${file_prefix}${fdt_file}; " \
+ "if test -e mmc ${mmcdev}:${mmcpart} ${file_prefix}${fdt_file}; then " \
+ "load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${file_prefix}${fdt_file}; " \
+ "else " \
+ "if load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${file_prefix}${fdt_file}; then; else " \
+ "load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${file_prefix}${fdtfile_prefix}${fdt_file}; " \
+ "fi; " \
+ "fi; " \
"else " \
"${get_cmd} ${fdt_addr} ${fdt_file}; " \
"fi;\0 " \