Cleaning up old bootlets stuff from alarm/

This commit is contained in:
Mike Brown 2013-06-13 16:22:21 -04:00
parent 0c1227df19
commit 50785df022
9 changed files with 0 additions and 244 deletions

View file

@ -1,36 +0,0 @@
# Contributor: Kiril Zyapkov <kiril.zyapkov@gmail.com>
buildarch=2
pkgname=elftosb
pkgver=10.12.01
pkgrel=1
pkgdesc="Helper utility for freescale imx platforms"
arch=(arm)
url="http://freescale.com"
license=('MIT')
makedepends=()
source=(
"http://repository.timesys.com/buildsources/e/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
"http://repository.timesys.com/buildsources/e/$pkgname/$pkgname-$pkgver/$pkgname-$pkgver-libm.patch")
md5sums=(
'e8005d606c1e0bb3507c82f6eceb3056'
'b4b758eb116914e284d6d12872948131')
build() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 < ../$pkgname-$pkgver-libm.patch
make all
}
package() {
mkdir -p $pkgdir/usr/local/bin
install -D -m 755 $srcdir/$pkgname-$pkgver/bld/linux/elftosb $pkgdir/usr/local/bin/ || return 1
install -D -m 755 $srcdir/$pkgname-$pkgver/bld/linux/keygen $pkgdir/usr/local/bin/ || return 1
install -D -m 755 $srcdir/$pkgname-$pkgver/bld/linux/sbtool $pkgdir/usr/local/bin/ || return 1
cd $pkgdir/usr/local/bin
ln -sf elftosb elftosb2
}
# vim:set ts=2 sw=2 et:

View file

@ -1,39 +0,0 @@
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
# Contributor: Kiril Zyapkov <kiril.zyapkov@gmail.com>
buildarch=2
pkgname=imx-bootlets-olinuxino-ntsc
pkgver=10.12.01
pkgrel=5
pkgdesc="Bootlets for the i.MX233 Freescale processor"
arch=(arm)
url="http://freescale.com"
license=('MIT')
makedepends=()
source=("http://download.ossystems.com.br/bsp/freescale/source/imx-bootlets-src-${pkgver}.tar.gz"
"linux_prep-fix-cmdlines.patch"
"linux-fix-paths.patch"
"imx233-olinuxino-maxi.patch")
md5sums=('cf0ab3822dca694b930a051501c1d0e4'
'd764749e7d5461c19924861ad7194395'
'a1caba49ccc1772f33e0e954ca7b719d'
'a3ecd391021d32723c34c955a3e2a0f5')
build() {
cd ${srcdir}/imx-bootlets-src-${pkgver}
patch -Np1 -i ../linux_prep-fix-cmdlines.patch
patch -Np1 -i ../linux-fix-paths.patch
patch -Np1 -i ../imx233-olinuxino-maxi.patch
BOARD=stmp378x_dev make linux_prep boot_prep power_prep
}
package() {
cd ${srcdir}/imx-bootlets-src-${pkgver}
mkdir -p ${pkgdir}/opt/imx-bootlets-olinuxino-ntsc
install -m 0644 linux.bd ${pkgdir}/opt/imx-bootlets-olinuxino-ntsc
install -m 0644 power_prep/power_prep ${pkgdir}/opt/imx-bootlets-olinuxino-ntsc
install -m 0644 boot_prep/boot_prep ${pkgdir}/opt/imx-bootlets-olinuxino-ntsc
install -m 0644 linux_prep/output-target/linux_prep ${pkgdir}/opt/imx-bootlets-olinuxino-ntsc
}

View file

@ -1,19 +0,0 @@
mx23/platform: set machine ID
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
diff --git a/linux_prep/include/mx23/platform.h b/linux_prep/include/mx23/platform.h
index ed58d79..3cbe2eb 100644
--- a/linux_prep/include/mx23/platform.h
+++ b/linux_prep/include/mx23/platform.h
@@ -18,7 +18,7 @@
#define __37XX_PLATFORM_H
#if defined (BOARD_STMP378X_DEV)
-#define MACHINE_ID 0xa45
+#define MACHINE_ID 0x1009
#else
#error "Allocate a machine ID for your board"
#endif

View file

@ -1,16 +0,0 @@
diff -urN a/linux.bd b/linux.bd
--- a/linux.bd 2010-11-04 01:35:38.000000000 -0600
+++ b/linux.bd 2013-01-15 17:13:59.295587512 -0700
@@ -4,9 +4,9 @@
flags = 0x01;
}
sources {
- power_prep="./power_prep/power_prep";
- sdram_prep="./boot_prep/boot_prep";
- linux_prep="./linux_prep/output-target/linux_prep";
+ power_prep="imx-bootlets-olinuxino-ntsc/power_prep";
+ sdram_prep="imx-bootlets-olinuxino-ntsc/boot_prep";
+ linux_prep="imx-bootlets-olinuxino-ntsc/linux_prep";
zImage = "./zImage";
}

View file

@ -1,30 +0,0 @@
imx-bootlets: Fix cmdlines for Linux boot
This adapt the cmdlines for the partitioning layout used on the
generated SD cards.
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
diff --git a/linux_prep/cmdlines/iMX28_EVK.txt b/linux_prep/cmdlines/iMX28_EVK.txt
index 6bc36b9..6cf89a0 100644
--- a/linux_prep/cmdlines/iMX28_EVK.txt
+++ b/linux_prep/cmdlines/iMX28_EVK.txt
@@ -1 +1 @@
-console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait
+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait
diff --git a/linux_prep/cmdlines/stmp378x_dev.txt b/linux_prep/cmdlines/stmp378x_dev.txt
index 9a717eb..fdb7390 100644
--- a/linux_prep/cmdlines/stmp378x_dev.txt
+++ b/linux_prep/cmdlines/stmp378x_dev.txt
@@ -1,6 +1,3 @@
-console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait lcd_panel=lms430 no_console_suspend
-console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait lcd_panel=lms350
-console=ttyAM0,115200 ssp1=spi1 ubi.mtd=2 root=ubi0:rootfs0 rootfstype=ubifs lcd_panel=lms430
-
-
-
+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait ssp1=mmc lcd_panel=tvenc_ntsc no_console_suspend
+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait ssp1=mmc lcd_panel=lms350
+console=ttyAMA0,115200 ssp1=spi1 ubi.mtd=2 root=ubi0:rootfs0 rootfstype=ubifs lcd_panel=lms430

View file

@ -1,39 +0,0 @@
# Maintainer: Kevin Mihelich <kevin@archlinuxarm.org>
# Contributor: Kiril Zyapkov <kiril.zyapkov@gmail.com>
buildarch=2
pkgname=imx-bootlets-olinuxino
pkgver=10.12.01
pkgrel=5
pkgdesc="Bootlets for the i.MX233 Freescale processor"
arch=(arm)
url="http://freescale.com"
license=('MIT')
makedepends=()
source=("http://download.ossystems.com.br/bsp/freescale/source/imx-bootlets-src-${pkgver}.tar.gz"
"linux_prep-fix-cmdlines.patch"
"linux-fix-paths.patch"
"imx233-olinuxino-maxi.patch")
md5sums=('cf0ab3822dca694b930a051501c1d0e4'
'27056e5005be16bfa14ae9ee5233974d'
'a714eb6bcc1ed30b771d98ff2f2c251b'
'a3ecd391021d32723c34c955a3e2a0f5')
build() {
cd ${srcdir}/imx-bootlets-src-${pkgver}
patch -Np1 -i ../linux_prep-fix-cmdlines.patch
patch -Np1 -i ../linux-fix-paths.patch
patch -Np1 -i ../imx233-olinuxino-maxi.patch
BOARD=stmp378x_dev make linux_prep boot_prep power_prep
}
package() {
cd ${srcdir}/imx-bootlets-src-${pkgver}
mkdir -p ${pkgdir}/opt/imx-bootlets-olinuxino
install -m 0644 linux.bd ${pkgdir}/opt/imx-bootlets-olinuxino
install -m 0644 power_prep/power_prep ${pkgdir}/opt/imx-bootlets-olinuxino
install -m 0644 boot_prep/boot_prep ${pkgdir}/opt/imx-bootlets-olinuxino
install -m 0644 linux_prep/output-target/linux_prep ${pkgdir}/opt/imx-bootlets-olinuxino
}

View file

@ -1,19 +0,0 @@
mx23/platform: set machine ID
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
diff --git a/linux_prep/include/mx23/platform.h b/linux_prep/include/mx23/platform.h
index ed58d79..3cbe2eb 100644
--- a/linux_prep/include/mx23/platform.h
+++ b/linux_prep/include/mx23/platform.h
@@ -18,7 +18,7 @@
#define __37XX_PLATFORM_H
#if defined (BOARD_STMP378X_DEV)
-#define MACHINE_ID 0xa45
+#define MACHINE_ID 0x1009
#else
#error "Allocate a machine ID for your board"
#endif

View file

@ -1,16 +0,0 @@
diff -urN a/linux.bd b/linux.bd
--- a/linux.bd 2010-11-04 01:35:38.000000000 -0600
+++ b/linux.bd 2013-01-15 17:03:51.797178012 -0700
@@ -4,9 +4,9 @@
flags = 0x01;
}
sources {
- power_prep="./power_prep/power_prep";
- sdram_prep="./boot_prep/boot_prep";
- linux_prep="./linux_prep/output-target/linux_prep";
+ power_prep="imx-bootlets-olinuxino/power_prep";
+ sdram_prep="imx-bootlets-olinuxino/boot_prep";
+ linux_prep="imx-bootlets-olinuxino/linux_prep";
zImage = "./zImage";
}

View file

@ -1,30 +0,0 @@
imx-bootlets: Fix cmdlines for Linux boot
This adapt the cmdlines for the partitioning layout used on the
generated SD cards.
Upstream-Status: Inappropriate [configuration]
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
diff --git a/linux_prep/cmdlines/iMX28_EVK.txt b/linux_prep/cmdlines/iMX28_EVK.txt
index 6bc36b9..6cf89a0 100644
--- a/linux_prep/cmdlines/iMX28_EVK.txt
+++ b/linux_prep/cmdlines/iMX28_EVK.txt
@@ -1 +1 @@
-console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait
+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait
diff --git a/linux_prep/cmdlines/stmp378x_dev.txt b/linux_prep/cmdlines/stmp378x_dev.txt
index 9a717eb..fdb7390 100644
--- a/linux_prep/cmdlines/stmp378x_dev.txt
+++ b/linux_prep/cmdlines/stmp378x_dev.txt
@@ -1,6 +1,3 @@
-console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait lcd_panel=lms430 no_console_suspend
-console=ttyAM0,115200 root=/dev/mmcblk0p3 rw rootwait lcd_panel=lms350
-console=ttyAM0,115200 ssp1=spi1 ubi.mtd=2 root=ubi0:rootfs0 rootfstype=ubifs lcd_panel=lms430
-
-
-
+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait ssp1=mmc lcd_panel=tvenc_pal no_console_suspend
+console=ttyAMA0,115200 root=/dev/mmcblk0p2 rw rootwait ssp1=mmc lcd_panel=lms350
+console=ttyAMA0,115200 ssp1=spi1 ubi.mtd=2 root=ubi0:rootfs0 rootfstype=ubifs lcd_panel=lms430