added extra/ghostscript

This commit is contained in:
Kevin Mihelich 2015-10-09 18:18:29 +00:00
parent 03c40a22fe
commit 507f079941
2 changed files with 117 additions and 0 deletions

View file

@ -0,0 +1,92 @@
# $Id$
# Maintainer: AndyRTR <andyrtr@archlinux.org>
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - build v7 and v8 with -fPIC
### !!! rebuild groff from core that picks up hardcoding the GS versioned font path !!! ###
pkgname=ghostscript
pkgver=9.18
pkgrel=1
pkgdesc="An interpreter for the PostScript language"
arch=('i686' 'x86_64')
license=('AGPL' 'custom')
depends=('libxt' 'libcups' 'fontconfig' 'jasper' 'zlib' 'libpng>=1.5.7' 'libjpeg'
'libtiff>=4.0.0' 'lcms2' 'dbus' 'libpaper')
makedepends=('gtk3' 'gnutls' 'hardening-wrapper')
optdepends=('texlive-core: needed for dvipdf'
'gtk3: needed for gsx')
url="http://www.ghostscript.com/"
source=(http://downloads.ghostscript.com/public/ghostscript-${pkgver}.tar.bz2
ghostscript-sys-zlib.patch)
#options=('!makeflags')
# http://downloads.ghostscript.com/public/SHA1SUMS
sha1sums=('388fea50a38e422a4c6ff27c184491bf5ecb96e1'
'e054caf753df4d67221b29a2eac66130653f7556')
prepare() {
cd ghostscript-${pkgver}
# fix build with system zlib
patch -Np1 -i ${srcdir}/ghostscript-sys-zlib.patch
}
build() {
cd ghostscript-${pkgver}
[[ $CARCH == "armv7h" || $CARCH == "aarch64" ]] && CFLAGS+=" -fPIC" && CXXFLAGS+=" -fPIC"
# force it to use system-libs
# keep heavily patched included openjpeg, leads to segfault with system openjpeg
# https://bugs.archlinux.org/task/38226
rm -rf jpeg libpng zlib jasper expat tiff lcms lcms2 freetype cups/libs # jbig2dec is in community
autoconf --force
./configure --prefix=/usr \
--enable-dynamic \
--with-ijs \
--with-jbig2dec \
--with-omni \
--with-x \
--with-drivers=ALL\
--with-fontpath=/usr/share/fonts/Type1:/usr/share/fonts \
--enable-fontconfig \
--enable-freetype \
--enable-openjpeg \
--without-luratech \
--without-omni \
--with-system-libtiff \
--with-libpaper \
--disable-compile-inits #--help # needed for linking with system-zlib
make
# Build IJS
cd ijs
sed -i "s:AM_PROG_CC_STDC:AC_PROG_CC:g" configure.ac
./autogen.sh
./configure --prefix=/usr --enable-shared --disable-static
make
}
package() {
cd ghostscript-${pkgver}
make DESTDIR="${pkgdir}" \
cups_serverroot="${pkgdir}"/etc/cups \
cups_serverbin="${pkgdir}"/usr/lib/cups install install-so
# install missing doc files # http://bugs.archlinux.org/task/18023
install -m 644 "${srcdir}"/ghostscript-${pkgver}/doc/{Ps2ps2.htm,gs-vms.hlp,gsdoc.el,pscet_status.txt} "${pkgdir}"/usr/share/ghostscript/$pkgver/doc/
install -D -m644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
# remove unwanted localized man-pages
rm -rf "$pkgdir"/usr/share/man/[^man1]*
# install IJS
cd ijs
make DESTDIR="${pkgdir}" install
# remove filters that are now maintained in cups-filters as upstream home
rm -rf "$pkgdir"/usr/lib/cups/filter/{gstopxl,gstoraster}
}

View file

@ -0,0 +1,25 @@
diff -up ghostscript-9.12/configure.ac.sys-zlib ghostscript-9.12/configure.ac
--- ghostscript-9.12/configure.ac.sys-zlib 2014-03-26 11:48:54.983972222 +0000
+++ ghostscript-9.12/configure.ac 2014-03-26 11:49:36.807230531 +0000
@@ -854,7 +854,7 @@ AC_MSG_CHECKING([for local zlib source])
dnl zlib is needed for language level 3, and libpng
# we must define ZLIBDIR regardless because png.mak does a -I$(ZLIBDIR)
# this seems a harmless default
-ZLIBDIR=src
+ZLIBDIR=$includedir
AUX_SHARED_ZLIB=
if test -d $srcdir/zlib; then
diff -up ghostscript-9.12/configure.sys-zlib ghostscript-9.12/configure
--- ghostscript-9.12/configure.sys-zlib 2014-03-26 11:49:45.547284521 +0000
+++ ghostscript-9.12/configure 2014-03-26 11:49:56.171350127 +0000
@@ -6254,7 +6254,7 @@ fi
$as_echo_n "checking for local zlib source... " >&6; }
# we must define ZLIBDIR regardless because png.mak does a -I$(ZLIBDIR)
# this seems a harmless default
-ZLIBDIR=src
+ZLIBDIR=$includedir
AUX_SHARED_ZLIB=
if test -d $srcdir/zlib; then