extra/libreoffice-still to 4.3.6-3

This commit is contained in:
Kevin Mihelich 2015-04-09 20:11:19 +00:00
parent 7fe80908f0
commit 50b8f99e20
2 changed files with 156 additions and 1 deletions

View file

@ -11,7 +11,7 @@ pkgbase=libreoffice-still
pkgname=('libreoffice-still-sdk' 'libreoffice-still')
_LOver=4.3.6.2
pkgver=4.3.6
pkgrel=2
pkgrel=3
arch=('i686' 'x86_64')
license=('LGPL3')
url="http://www.libreoffice.org/"
@ -70,6 +70,7 @@ source=(${_mirror}/libreoffice{,-help,-translations}-${_LOver}.tar.xz{,.asc}
${_additional_source_url}/OpenCOLLADA-master-6509aa13af.tar.bz2
${_additional_source_url}/libgltf/libgltf-0.0.2.tar.bz2
make-pyuno-work-with-system-wide-module-install.diff
support-external-hamcrest-with-junit-4.11.patch
libreoffice-still.sh libreoffice-still.csh)
noextract=(d6eef4b4cacb2183f2bf265a5a03a354-boost_1_55_0.tar.bz2
9e96ed4c1d99c0d14ac03c140f9f346c-icu4c-52_1-src.tgz
@ -153,6 +154,7 @@ md5sums=('92139917fbb2dd5e6dc7cc2808f002a1'
'4ca8a6ef0afeefc864e9ef21b9f14bd6'
'd63a9f47ab048f5009d90693d6aa6424'
'07d2bf5ad839a394cca008b3ec6e7bb1'
'9e96d59020e09732dea9b4befdafa694'
'4195735a80876ae812fca5736b50192a'
'e7e4b3e70e99e5cba8f8dfcacf3b0d87')
validpgpkeys=('C2839ECAD9408FBE9531C3E9F434A1EFAFEEAEA3') # LibreOffice Build Team (CODE SIGNING KEY) <build@documentfoundation.org>
@ -175,6 +177,9 @@ prepare() {
# fix not upstreamable pyuno paths - patch taken from Debian
patch -Np1 -i ${srcdir}/make-pyuno-work-with-system-wide-module-install.diff
# support for external hamcrest with junit >= 4.11
patch -Np1 -i ${srcdir}/support-external-hamcrest-with-junit-4.11.patch
#use the CFLAGS but remove the LibO overridden ones
for i in $CFLAGS; do
case "$i" in

View file

@ -0,0 +1,150 @@
From 4db2d600ebc541adfaaf0a1a176df1c74e3ae0e4 Mon Sep 17 00:00:00 2001
From: Peter Foley <pefoley2@pefoley.com>
Date: Tue, 9 Sep 2014 22:19:42 -0400
Subject: Add support for external hamcrest when using junit 4.11+
Starting with junit 4.11 hamcrest is no longer bundled,
so add a --with-hamcrest option to support this.
Change-Id: Icdae946af82b9c56bf25d37cbf88275fc6a6a1eb
Reviewed-on: https://gerrit.libreoffice.org/11383
Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
Tested-by: Stephan Bergmann <sbergman@redhat.com>
diff --git a/config_host.mk.in b/config_host.mk.in
index e717745..605bb6b 100644
--- a/config_host.mk.in
+++ b/config_host.mk.in
@@ -239,6 +239,7 @@ export GTK_LIBS=$(gb_SPACE)@GTK_LIBS@
export GTK_PRINT_CFLAGS=$(gb_SPACE)@GTK_PRINT_CFLAGS@
export GTK_PRINT_LIBS=$(gb_SPACE)@GTK_PRINT_LIBS@
export GUIBASE=@GUIBASE@
+export HAMCREST_JAR=@HAMCREST_JAR@
export HARDLINKDELIVER=@HARDLINKDELIVER@
export HAVE_GCC_AVX=@HAVE_GCC_AVX@
export HAVE_GCC_BUILTIN_ATOMIC=@HAVE_GCC_BUILTIN_ATOMIC@
diff --git a/configure.ac b/configure.ac
index e5c01e8..84add6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1987,6 +1987,15 @@ AC_ARG_WITH(junit,
],
,with_junit=yes)
+AC_ARG_WITH(hamcrest,
+ AS_HELP_STRING([--with-hamcrest],
+ [Specifies the hamcrest jar file to use for JUnit-based tests.
+ --without-junit disables those tests. Not relevant in the --without-java case.])
+ [
+ Usage: --with-hamcrest=<absolute path to hamcrest jar>
+ ],
+,with_hamcrest=yes)
+
AC_ARG_WITH(perl-home,
AS_HELP_STRING([--with-perl-home],
[If you have installed Perl 5 Distribution, on your system, please
@@ -12051,23 +12060,53 @@ if test "$ENABLE_JAVA" != "" -a "$with_junit" != "no"; then
if test "$_os" = "WINNT"; then
OOO_JUNIT_JAR=`cygpath -m "$OOO_JUNIT_JAR"`
fi
- printf 'import org.junit.Before; import org.hamcrest.BaseDescription;' \
- > conftest.java
+ printf 'import org.junit.Before;' > conftest.java
if "$JAVACOMPILER" -classpath "$OOO_JUNIT_JAR" conftest.java >&5 2>&5; then
AC_MSG_RESULT([$OOO_JUNIT_JAR])
else
AC_MSG_ERROR(
-[cannot find JUnit 4 jar, or JUnit 4 jar does not provide Hamcrest; please
-install one in the default location (/usr/share/java), specify its pathname via
---with-junit=..., or disable it via --without-junit])
+[cannot find JUnit 4 jar; please install one in the default location (/usr/share/java),
+ specify its pathname via --with-junit=..., or disable it via --without-junit])
fi
- rm -f conftestj.class conftestj.java
+ rm -f conftest.class conftest.java
if test $OOO_JUNIT_JAR != ""; then
BUILD_TYPE="$BUILD_TYPE QADEVOOO"
fi
fi
AC_SUBST(OOO_JUNIT_JAR)
+HAMCREST_JAR=
+if test "$ENABLE_JAVA" != "" -a "$with_junit" != "no"; then
+ AC_MSG_CHECKING([for included Hamcrest])
+ printf 'import org.hamcrest.BaseDescription;' > conftest.java
+ if "$JAVACOMPILER" -classpath "$OOO_JUNIT_JAR" conftest.java >&5 2>&5; then
+ AC_MSG_RESULT([Included in $OOO_JUNIT_JAR])
+ else
+ AC_MSG_RESULT([Not included])
+ AC_MSG_CHECKING([for standalone hamcrest jar.])
+ if test "$with_hamcrest" = "yes"; then
+ if test -e /usr/share/lib/java/hamcrest.jar; then
+ HAMCREST_JAR=/usr/share/lib/java/hamcrest.jar
+ else
+ HAMCREST_JAR=/usr/share/java/hamcrest.jar
+ fi
+ else
+ HAMCREST_JAR=$with_hamcrest
+ fi
+ if test "$_os" = "WINNT"; then
+ HAMCREST_JAR=`cygpath -m "$HAMCREST_JAR"`
+ fi
+ if "$JAVACOMPILER" -classpath "$HAMCREST_JAR" conftest.java >&5 2>&5; then
+ AC_MSG_RESULT([$HAMCREST_JAR])
+ else
+ AC_MSG_ERROR([junit does not contain hamcrest; please use a junit jar that includes hamcrest, install a hamcrest jar in the default location (/usr/share/java),
+ specify its path with --with-hamcrest=..., or disable junit with --without-junit])
+ fi
+ fi
+ rm -f conftest.class conftest.java
+fi
+AC_SUBST(HAMCREST_JAR)
+
AC_SUBST(SCPDEFS)
diff --git a/solenv/gbuild/JunitTest.mk b/solenv/gbuild/JunitTest.mk
index 9801ed2..8370603 100644
--- a/solenv/gbuild/JunitTest.mk
+++ b/solenv/gbuild/JunitTest.mk
@@ -54,12 +54,13 @@ $(call gb_JunitTest_get_target,%) :
$(CLEAN_CMD)
define gb_JunitTest_JunitTest
-$(call gb_JunitTest_get_target,$(1)) : T_CP := $(call gb_JavaClassSet_get_classdir,$(call gb_JunitTest_get_classsetname,$(1)))$$(gb_CLASSPATHSEP)$(OOO_JUNIT_JAR)$$(gb_CLASSPATHSEP)$(INSTROOT)/$(LIBO_URE_LIB_FOLDER)
+$(call gb_JunitTest_get_target,$(1)) : T_CP := $(call gb_JavaClassSet_get_classdir,$(call gb_JunitTest_get_classsetname,$(1)))$$(gb_CLASSPATHSEP)$(OOO_JUNIT_JAR)$(if $(HAMCREST_JAR),$$(gb_CLASSPATHSEP)$(HAMCREST_JAR))$$(gb_CLASSPATHSEP)$(INSTROOT)/$(LIBO_URE_LIB_FOLDER)
$(call gb_JunitTest_get_target,$(1)) : CLASSES :=
$(eval $(call gb_JunitTest_JunitTest_platform,$(1)))
$(call gb_JavaClassSet_JavaClassSet,$(call gb_JunitTest_get_classsetname,$(1)))
$(call gb_JavaClassSet_use_system_jar,$(call gb_JunitTest_get_classsetname,$(1)),$(OOO_JUNIT_JAR))
+$(if $(HAMCREST_JAR),$(call gb_JavaClassSet_use_system_jar,$(call gb_JunitTest_get_classsetname,$(1)),$(HAMCREST_JAR)))
$(call gb_JunitTest_get_target,$(1)) : $(call gb_JavaClassSet_get_target,$(call gb_JunitTest_get_classsetname,$(1)))
$(eval $(call gb_Module_register_target,$(call gb_JunitTest_get_target,$(1)),$(call gb_JunitTest_get_clean_target,$(1))))
$(call gb_Helper_make_userfriendly_targets,$(1),JunitTest)
--
cgit v0.10.2
From 8419fa8c28dd9c5f64a72d28d561b3817d781232 Mon Sep 17 00:00:00 2001
From: Stephan Bergmann <sbergman@redhat.com>
Date: Fri, 23 Jan 2015 15:55:24 +0100
Subject: Related rhbz#1185307: One more location to look for Hamcrest jar
Change-Id: I307a009c14dd5cd946b39fbfb80ffc3962a7739b
diff --git a/configure.ac b/configure.ac
index 5c67205..607e97e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -12022,6 +12022,8 @@ if test "$ENABLE_JAVA" != "" -a "$with_junit" != "no"; then
if test "$with_hamcrest" = "yes"; then
if test -e /usr/share/lib/java/hamcrest.jar; then
HAMCREST_JAR=/usr/share/lib/java/hamcrest.jar
+ elif test -e /usr/share/java/hamcrest/core.jar; then
+ HAMCREST_JAR=/usr/share/java/hamcrest/core.jar
else
HAMCREST_JAR=/usr/share/java/hamcrest.jar
fi
--
cgit v0.10.2