mirror of
https://github.com/archlinuxarm/PKGBUILDs.git
synced 2025-01-17 23:34:07 +00:00
community/go to 1.14-1
This commit is contained in:
parent
732578bfa2
commit
50cea0c95d
2 changed files with 8 additions and 9 deletions
|
@ -18,7 +18,7 @@
|
||||||
pkgbase=go
|
pkgbase=go
|
||||||
pkgname=(go go-pie)
|
pkgname=(go go-pie)
|
||||||
epoch=2
|
epoch=2
|
||||||
pkgver=1.13.8
|
pkgver=1.14
|
||||||
pkgrel=1
|
pkgrel=1
|
||||||
arch=(x86_64)
|
arch=(x86_64)
|
||||||
url='https://golang.org/'
|
url='https://golang.org/'
|
||||||
|
@ -26,8 +26,8 @@ license=(BSD)
|
||||||
makedepends=(git go)
|
makedepends=(git go)
|
||||||
source=(https://storage.googleapis.com/golang/go$pkgver.src.tar.gz
|
source=(https://storage.googleapis.com/golang/go$pkgver.src.tar.gz
|
||||||
default-buildmode-pie.patch)
|
default-buildmode-pie.patch)
|
||||||
sha256sums=('b13bf04633d4d8cf53226ebeaace8d4d2fd07ae6fa676d0844a688339debec34'
|
sha256sums=('6d643e46ad565058c7a39dac01144172ef9bd476521f42148be59249e4b74389'
|
||||||
'9d2f0d201d4e002d74f548cc82bd131139bab5dd62191004c71dd430fdc1666d')
|
'be1269689de3cf5c926cf7de07f88d2a6d1ecbfc86694baaf5baee3bdcfdd79a')
|
||||||
|
|
||||||
export GOOS=linux
|
export GOOS=linux
|
||||||
case "$CARCH" in
|
case "$CARCH" in
|
||||||
|
|
|
@ -2,13 +2,12 @@ diff --git a/src/cmd/go/internal/work/init.go b/src/cmd/go/internal/work/init.go
|
||||||
index 7f894f5..a517887 100644
|
index 7f894f5..a517887 100644
|
||||||
--- a/src/cmd/go/internal/work/init.go
|
--- a/src/cmd/go/internal/work/init.go
|
||||||
+++ b/src/cmd/go/internal/work/init.go
|
+++ b/src/cmd/go/internal/work/init.go
|
||||||
@@ -111,7 +111,8 @@ func buildModeInit() {
|
@@ -131,7 +131,7 @@ func buildModeInit() {
|
||||||
ldBuildmode = "c-shared"
|
ldBuildmode = "c-shared"
|
||||||
case "default":
|
case "default":
|
||||||
switch platform {
|
switch cfg.Goos {
|
||||||
- case "android/arm", "android/arm64", "android/amd64", "android/386":
|
- case "android":
|
||||||
+ case "linux/amd64", "linux/arm", "linux/arm64", "linux/386", "linux/ppc64le",
|
+ case "android", "linux":
|
||||||
+ "android/arm", "android/arm64", "android/amd64", "android/386":
|
|
||||||
codegenArg = "-shared"
|
codegenArg = "-shared"
|
||||||
ldBuildmode = "pie"
|
ldBuildmode = "pie"
|
||||||
case "darwin/arm", "darwin/arm64":
|
case "darwin":
|
||||||
|
|
Loading…
Reference in a new issue